Jump to content

DiRT Rally 2.0 - V1.2 - found a bug? Post it here!

Recommended Posts

1 hour ago, Ha3aP said:

WRX content is oficial?

Why in WRX Champs drivers name is not real? ((

They are official in the WRX championship mode under freeplay, they wont (and shouldn't imo) be official in career 

  • Agree 1

Share this post


Link to post
Share on other sites
2 minutes ago, MattyH1812 said:

They are official in the WRX championship mode under freeplay, they wont (and shouldn't imo) be official in career 

Why not?

Share this post


Link to post
Share on other sites
1 minute ago, Ha3aP said:

Why not?

Because it's dynamic, the top 3 get promoted and the bottom 3 get demoted, having the real drivers you could end up with Solberg competing in the Elite championship for example

  • Disagree 1

Share this post


Link to post
Share on other sites

Hey guys, nice reports. I've updated the bug list in the first page. Keep them coming! The more feedback we get, the better are the chances to get this game fixed sooner than later as this is a great help for the dev team to track those bugs down.

  • Like 1
  • Agree 5
  • Disagree 2

Share this post


Link to post
Share on other sites
20 minutes ago, Riggs said:

Hey guys, nice reports. I've updated the bug list in the first page. Keep them coming! The more feedback we get, the better are the chances to get this game fixed sooner than later as this is a great help for the dev team to track those bugs down.

I really like your optimism :)

  • Haha 1
  • Agree 1
  • Disagree 1

Share this post


Link to post
Share on other sites

guys but none of you to graphics problems on standard xbox and ps4, the more we are the more they can solve this problem.:classic_sleep:

Share this post


Link to post
Share on other sites
Posted (edited)

Ok i've had the first test on my PC with v1.2 and the problems from v1.1 persist and there's even new ones.

- The game still crashes to desktop when going from a stage to another (loading process) but this time the crash report is different. It's reporting a d3d11.dll error.

868883487_SemTtulo.png.44b4984698a442e43f42ce6f6fdfcfd7.png

- The no grip bug is happening more than ever before. @ChristinaMc This no grip bug should be investigated before any FFB changes are applied to the final build, because this can be very well related to the lack of FFB in the surfaces. Basically, this time when the bug was happening, my wheel felt very light with lack of FFB (even SAT and Center Steering Forces). Once the bug stopped happening mid-stage the FFB went back to normal. There's really something wrong with gravity in this game, and I bet that this gravity bug is what's causing the faulty FFB since launch and I fear your team might be wasting time trying to fix what's not broken at all.

- HDR and lighting on PC is also poor. The fix wasn't a fix at all because despite being able to see the road better on night stages, and despite the cockpit being dark on night stages (which is correct imo), the outside lighting is just too over-exposed (white is burnt, and so on, just like in the consoles). It seems that this HDR lighting or whatever is responsible for controling the brightness and over exposure needs to be done from scratch, because it's simply a mess. Notice in the picture below how the lights burn the ground with over-exposure. It's as the ground material is totally flat and with 0 roughness. Also, lights don't work at all on dark places of the stages (same problem as in v1.1). You go through a dark place in the forest of NZ during day time, you turn on the lights and there's no effect.

 

The dirt is over-exposed and reflecting light.

unknown.png

 

The outside of the car is so over-exposed that you can't even see the vinyls on the bonnet etc.

Desktop_Screenshot_2019.03.24_-_22.55.40.31.png

I recorded a video of this last experience I've had, which shows up these 3 bugs. If we add the persistent sound bug to the equation, it looks as if patch v1.2 was barely effective and a serious v1.3 patch needs to be issued steadfast and it needs to be a game-changer solid one. Notice how the wheels refuse to grip, like if it was a clutch slipping or the car levitating.

I would like to note that this grip bug / slipping clutch is not due to a custom livery installation, as it has happened to me before on v1.1 with a Peugeot 208 R5 with the game totally default. Only the texture file of this Lancer has been modified, no nefs have been touched.

Edited by Riggs
  • Thanks 2

Share this post


Link to post
Share on other sites
Posted (edited)

Quick update:

So I went on to stage 2 and the same grip bug happened to me in the first section. I noticed that both cockpit and exterior were properly visible but there was barely any color as the HDR was washing everything up and it was all too whitey and brighty on the road and environment.

Finally the game froze mid-stage, with audio freezing and graphics turning weird on some vegetation and the PC just froze, forcing me to do a hard reset.

 

IMG_4818.thumb.JPG.49bbb678cbae64a922288d6f4884a231.JPG

Unfortunately I'll have to put the game in the shelf until all these issues have been fixed because it's not being even funny to play the game anymore. This is what I consider an "unplayable" state, unlike in v1.1. I'm looking forward to Monte Carlo, but right now I can barely play the game, and if these bugs are happening right now with no grips and all, I cant imagine how Monte Carlo's experience is going to be.

Best of luck and see you in patch v1.3 hopefully.

I attached my dxdiag for diagnosing purposes.

DxDiag.txt

Edited by Riggs
  • Agree 1

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, Riggs said:

Ok i've had the first test on my PC with v1.2 and the problems from v1.1 persist and there's even new ones.

- The no grip bug is happening more than ever before. @ChristinaMc This no grip bug should be investigated before any FFB changes are applied to the final build, because this can be very well related to the lack of FFB in the surfaces. Basically, this time when the bug was happening, my wheel felt very light with lack of FFB (even SAT and Center Steering Forces). Once the bug stopped happening mid-stage the FFB went back to normal. There's really something wrong with gravity in this game, and I bet that this gravity bug is what's causing the faulty FFB since launch and I fear your team might be wasting time trying to fix what's not broken at all.

- HDR and lighting on PC is also poor. The fix wasn't a fix at all because despite being able to see the road better on night stages, and despite the cockpit being dark on night stages (which is correct imo), the outside lighting is just too over-exposed (white is burnt, and so on, just like in the consoles). It seems that this HDR lighting or whatever is responsible for controling the brightness and over exposure needs to be done from scratch, because it's simply a mess.

 

I just experienced the no grip bug today in a weekly on monthly event with the Subaru Impreza in Australia. The car's rpm meter is instantly goes into the red area after changing the gear, so I'm going from gear 1 to gear 5 in 4 seconds at full throttle....

The lighting needs to be adjusted too, its too dark, i hope it just needs a little correction in the ini file. It has a hdr setting. Try changing that.

Edited by Lollerke

Share this post


Link to post
Share on other sites

I've had Argentina x2 with no Spain since the patch.

  • Agree 1

Share this post


Link to post
Share on other sites

The times the AI sets using the H2 FWD cars are completely messed up. They are absolutely unbeatable on Clubman difficulty and additionally also set more or less the same stage times as the Up to 2000cc cars. Please fix this, it really makes this class unplayable at the moment.

  • Agree 1

Share this post


Link to post
Share on other sites

The model of the co-drivers pace notes don't appear whilst in cockpit cams, looks like he's holding thin air

Share this post


Link to post
Share on other sites
Posted (edited)

No grip still - can see in video below how much steering input is being done, also full acceleration. Also lots of crashing and banging noises, thinking collision/friction errors with road? Restart stage fixes it, but only have so many of those during career rally

 

Edited by drewbphoto
  • Confused 1

Share this post


Link to post
Share on other sites

Those suffering this no grip bug and crashing on PC, have you had steam verify game files?

Share this post


Link to post
Share on other sites
Posted (edited)
14 minutes ago, nbates66 said:

Those suffering this no grip bug and crashing on PC, have you had steam verify game files?

Yes, I did that 2 days ago, but every problem persists.

Edited by Lollerke

Share this post


Link to post
Share on other sites

I had a strange new bug in Australia, my steering wheel became more stiff when i had a small collision in the stage. I drove the Mitsubishi Lancer Evolution VI. When i disconnect the wheel and connect it again, it's back normal, but every time when i had a collision it became more stiff. I don't have this problem at other rallies.

Share this post


Link to post
Share on other sites

Hi guys i have a thing to report: my Logitech Attack III (joystick) perfectly working as HandBrake, still correctly recognized, but doesn't work after last patch. I can assign, as Y axys, the HandBrake command, but at the start the message "hold on your handbrake" doesn't disappear when i pull it and the countdown to the start doesn't begin.

I had to bind the HB command to a key on the wheel.

As always, many thanks for your attention! 🏁🏁🏁

Share this post


Link to post
Share on other sites
Posted (edited)
11 hours ago, MattyH1812 said:

The model of the co-drivers pace notes don't appear whilst in cockpit cams, looks like he's holding thin air

i had this week ago, and i think maybe you see rear mirrors black. to solve you have to tweak with graphics options, i think it's a shader related question. If options are set too low mirrors become black and pacenote notebook disappears in internal cams: 

 

Edited by Black75

Share this post


Link to post
Share on other sites
On 3/24/2019 at 11:10 AM, Duke83 said:

Hello ChristinaMc, developers and drivers,
I have decided to write because I am affected by a serious bug that is hardly mentioned here.


Bug Description:
At all rally stages without service area there are physics problems.

  • The car is hard to steer or has no grip and you can not drive.
  • Occasionally, the car shakes before the start and / or
  • with activated start control no handbrake is held and it comes to the early start

This applies to all rally events including the online rally events, the online rallying career and
all events in the historic rally and custom rally events.


Impact:
With this bug, stages without a service area can not be won and you have to be frustration-resistant to get to the finish.
Community events with more than one stage make little sense and are frustrating.


Additional Information:
I found out that after a restart of the stage the bug disappears, this makes the historic rally playable.
This works in the online rallying career severely limited because the restarts are limited.

On YouTube you can find some videos of this bug.
I have the Steam version of the game but other platforms are affected as well.

You could fix it relatively quickly by attaching something like a free auto-restart before each race without a service area.

I would be very happy if this bug is removed soon so I can finally play. :classic_smile:

Rallycross is not affected.

 

That is what I call the "no-grip-bug". It has different kind of appearances, but its the same thing. It happens to me also every second stage and to restart the stage is the only way to fix it!

  • Agree 1

Share this post


Link to post
Share on other sites
19 hours ago, Riggs said:

Ok i've had the first test on my PC with v1.2 and the problems from v1.1 persist and there's even new ones.

- The game still crashes to desktop when going from a stage to another (loading process) but this time the crash report is different. It's reporting a d3d11.dll error.

868883487_SemTtulo.png.44b4984698a442e43f42ce6f6fdfcfd7.png

- The no grip bug is happening more than ever before. @ChristinaMc This no grip bug should be investigated before any FFB changes are applied to the final build, because this can be very well related to the lack of FFB in the surfaces. Basically, this time when the bug was happening, my wheel felt very light with lack of FFB (even SAT and Center Steering Forces). Once the bug stopped happening mid-stage the FFB went back to normal. There's really something wrong with gravity in this game, and I bet that this gravity bug is what's causing the faulty FFB since launch and I fear your team might be wasting time trying to fix what's not broken at all.

- HDR and lighting on PC is also poor. The fix wasn't a fix at all because despite being able to see the road better on night stages, and despite the cockpit being dark on night stages (which is correct imo), the outside lighting is just too over-exposed (white is burnt, and so on, just like in the consoles). It seems that this HDR lighting or whatever is responsible for controling the brightness and over exposure needs to be done from scratch, because it's simply a mess. Notice in the picture below how the lights burn the ground with over-exposure. It's as the ground material is totally flat and with 0 roughness. Also, lights don't work at all on dark places of the stages (same problem as in v1.1). You go through a dark place in the forest of NZ during day time, you turn on the lights and there's no effect.

  Reveal hidden contents

The dirt is over-exposed and reflecting light.

unknown.png

 

The outside of the car is so over-exposed that you can't even see the vinyls on the bonnet etc.

Desktop_Screenshot_2019.03.24_-_22.55.40.31.png

I recorded a video of this last experience I've had, which shows up these 3 bugs. If we add the persistent sound bug to the equation, it looks as if patch v1.2 was barely effective and a serious v1.3 patch needs to be issued steadfast and it needs to be a game-changer solid one. Notice how the wheels refuse to grip, like if it was a clutch slipping or the car levitating.

I would like to note that this grip bug / slipping cutch is not due to a custom livery installation, as it has happened to me before on v1.1 with a Peugeot 208 R5 with the game totally default. Only the texture file of this Lancer has been modified, no nefs have been touched.

No grip also happens on PS4 Pro.

Share this post


Link to post
Share on other sites

UPDATE:

Hi all,

The latest patch notes for v1.2.1 are below:

- My Team Special Events issues fixed

- We've fixed not receiving input from unofficial devices (without re-connecting the device after press start)

- Special liveries and Monte Carlo Rally unlocked for Deluxe Edition players on Steam. These will unlock for PlayStation and Xbox players at midnight local time

We're continuing to monitor your feedback, so if there is anything new or existing that you feel has slipped through the cracks, please let us know on the pinned Steam/Codemasters forums threads.

Thanks,
Christina

  • Like 2
  • Thanks 1

Share this post


Link to post
Share on other sites
8 minutes ago, ChristinaMc said:

UPDATE:

Hi all,

The latest patch notes for v1.2.1 are below:

- My Team Special Events issues fixed

- We've fixed not receiving input from unofficial devices (without re-connecting the device after press start)

- Special liveries and Monte Carlo Rally unlocked for Deluxe Edition players on Steam. These will unlock for PlayStation and Xbox players at midnight local time

We're continuing to monitor your feedback, so if there is anything new or existing that you feel has slipped through the cracks, please let us know on the pinned Steam/Codemasters forums threads.

Thanks,
Christina

Keep the updates coming. Thanks for the info @ChristinaMc. Are the team aware of the car modelling issues we've noted? I've been wondering if that's as designed or if it's something you intend to fix.

Share this post


Link to post
Share on other sites
13 minutes ago, ChristinaMc said:

UPDATE:

Hi all,

The latest patch notes for v1.2.1 are below:

- My Team Special Events issues fixed

- We've fixed not receiving input from unofficial devices (without re-connecting the device after press start)

- Special liveries and Monte Carlo Rally unlocked for Deluxe Edition players on Steam. These will unlock for PlayStation and Xbox players at midnight local time

We're continuing to monitor your feedback, so if there is anything new or existing that you feel has slipped through the cracks, please let us know on the pinned Steam/Codemasters forums threads.

Thanks,
Christina

What about "Fire Up that car... Again" Achievement?
In v.1.2 still not working.
SNBNfnd.jpg

  • Agree 1

Share this post


Link to post
Share on other sites
9 minutes ago, warpengage said:

Keep the updates coming. Thanks for the info @ChristinaMc. Are the team aware of the car modelling issues we've noted? I've been wondering if that's as designed or if it's something you intend to fix.

The feedback is with the team for review - however as those car models have been approved by manufacturers and licensors, any proposed changes become quite difficult!

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×