Jump to content
Sign in to follow this  

Colin McRae Rally 1 on Win8.1 - how I get it super smooth (also on Win8) - partly updated for Win10

Recommended Posts

I basically did this:

1. Install the game from the CD-ROM; on my PC there was no need to set Win98 compatibility, but you might need to.

2. Once installed, install the 1.5 patch, which can be found here: http://www.patches-scrolls.de/patch/917 - I DID need to set XP compatibility (at least) on that european.exe file, or it wouldn't find the game.

3. If you now try to run the game, you may get an error 2094. To fix this, use Win98 compatibility on the game.exe file (or the Colin McRae Rally shortcut). If you use XP compatibility or above the game will detect this and say incorrect operating system.

4. There is a Win7 unofficial patch on the net, which you can find here: https://web.archive.org/web/20150401005453/http://kfyatek-dev.jogger.pl/2011/09/25/colin-mcrae-rally-1-unofficial-windows-7-patch/ however when I tried this patch the game seemed to crash for me, so I uninstalled and reinstalled without using this patch, and now it seems to work. Again, it might just be my setup, so you might need to run this patch.

5. I can see both opening videos on my PC, as I installed the Indeo video drivers from *somewhere* on the net already. Not very helpful, this bit, I admit...

6. Try running the game, it *should* work. It might occasionally crash when loading a race though. You'll also notice graphics corruption in the 3D items in the menu, as it uses 256 colour mode, which is no longer supported. However the game will be okay.

7. Here's the smoothness trick. If you use "Motion Smoothing" option in the games Advanced graphics setting, it seems to lock the framerate to something like 25fps. Just turn that off! There might be the odd glitch every few seconds though, but it's better that judder! I did have an Application Compatibility Toolkit fix for framerates, but that's not needed in Win10.

And that's it. Sometimes it might crash loading a race though, perhaps the Win7 patch may help more there, I didn't experiment with it too much.

Share this post


Link to post
Share on other sites
I might have spoke too soon, as the game crashed halfway through a stage too... maybe it doesn't like high fps, or my sound card, or needs the Win7 patch, or something else :-p anyway it's a starting point!

Share this post


Link to post
Share on other sites
Thank you very much for this! Your help allowed me to get the game running in the first place. However the game would still crash often when loading a new stage. What worked for me was that I right clicked the rally.exe icon, then properties ---> shortcut icon ---> run and set that option to "minimized". Nothing visible changed in the way that the game runs, but the crashing stopped and I have now managed to complete ten stages in a row without the game crashing.

Share this post


Link to post
Share on other sites
UPDATE: step 7, if you used the ACT fix, then change it from DXPrimaryEmulation ticked, to NoGDIHWAcceleration instead, it seems more compatible. Good luck!

Share this post


Link to post
Share on other sites
UPDATE: step 7, if you used the ACT fix, then change it from DXPrimaryEmulation ticked, to NoGDIHWAcceleration instead, it seems more compatible. Good luck!
Hi, I tried the ddraw-fix and the game always crashes - and I don't know how to handle this act fix? I'd really love to play the game with higher fps. If you could help again, it would be really cool, thanks :)

Share this post


Link to post
Share on other sites
You download Application Compatibility Toolkit from Microsoft (might be a few steps to find the right version) then you have to set up a fix against the game executable.

I updated the original URL as it's changed: http://www.blitzbasic.com/Community/post.php?topic=99477&post=1271915
Follow step 1 but instead of using DXPrimaryEmulation, use NoGDIHWAcceleration instead.

Share this post


Link to post
Share on other sites
Hey, I know it's an old topic, but I still need help, my game still looks corrupted af and everything lags and doubles up and it's hard to navigate. :( I did everything like you said in the post and it's still messed..

Share this post


Link to post
Share on other sites
I am on my laptop (Windows 10) and the Main Menu is all out of shape, lags, everything doubles and the gameplay is fine, 60 fps at least, but the menu is the only issue and I have turned off the smoothing thing option.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×