Jump to content
Sign in to follow this  

Dirt Rally Windows 10 64 bit No Sound

Recommended Posts


Upgraded my old computer with these components :


Windows 10 Pro 64bit

500 Gig ssd

i5-9600 CPU LGA 1151

16 gig ram DDR 3000

Gigabyte motherboard Z390 UD LGA


Original Parts/Software I am now using on the new computer: 


Steam version of Dirt Rally  (re-installed all software of course)

Oculus Rift VR

Nvidia 1080ti

Sim Commander 4 / Sim Vibe

Fanatec Wheel Base/Pedals/Shifter


I ran Dirt Rally on Win 8.1 64 bit previously with no problems.  But on my new Windows 10 64 bit I get no sound at all.  I have tried 3 different sound devices (on board sound card, oculus rift headset, wireless Logitech headset) and Dirt never output's sound to any of the devices.  I was able to get sound when I put the compatibility mode to Windows 7 on the drt.exe, but in this mode it will not run in VR.  Windows 8 compatibility mode had no sound as well.

I have uninstalled and reinstalled twice.

I have deleted drt.exe and used steam verify to pull a new one.

I launch rfactor2 exactly the same way I run Dirt Rally and sound works via any device I tell it to output to.  So my hardware is not the problem.

Everything else with the game works just fine, just no sound.

FYI, the telemetry data worked with my Sim Vibe off the on board sound card.  I just don't get one peep of sound from Dirt.  I spent 7 hours on this problem so I am now turning to you guys for some pointers.  Thanks for such an awesome title (sim)!!


Edited by killerhair
changed windows version to Pro

Share this post

Link to post
Share on other sites

Solved : but not technically.

This is maybe more of a clue than anything else.

I bought another copy of Dirt Rally via Oculus. (Yes I spent another $25 US on this.  Much cheaper than my time.)  The sound worked right out of the box.

I don't know if the Steam version of Dirt Rally is the problem.  I don't know if Steam it self was causing my problem.  I just know installing and running the Oculus version works.

If i ever come across a true fix I will post it here to help anyone else that might have this problem in the future.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this