Jump to content

DiRT Rally 2.0, Version 1.5: Bug Reporting Thread

Recommended Posts

Posted (edited)

PC. Deluxe edition.

Having completed most of the daily and weekly community events, I can report the following observations. ūüôā

On the positive side:

  1. Recommended repairs  working properly - most of the time......see item 8 below.
  2. Visibility during rain at night improved and more natural.
  3. Seem to have picked up some FPS especially around crowds.
  4. Sound during stages seems to be stable, no drop outs so far.....

On the negative side, in approximate order of impact to game play:

  1. Sound drop outs still occurring.
  2. Suffering a puncture after crossing the finish leaves you starting with an unrepairable flat tyre on the next stage even though I was carrying a spare - surely this should be repaired without penalty between stages. My¬†Peugeot 205 T16 Evo2¬†was almost undrivable (otherwise undamaged) after this occured at Poland in the current weekly GrB 4WD community event - took nearly 6 minutes to finish a normally sub 3 minute stage, only to find the flat (now just a rim obviously) persisted on the next stage. Retired after that. ūüėě
  3. Night lights still a bit dim especially in tightly forested sections, and the road surface itself.
  4. Random auto wipes still occurring with wipers set to manual.
  5. Leaderboards appearing after completion of a community event still bugged (but to be fair patch notes only mention Monthly event leaderboards were fixed).
  6. Fanatec LEDs still lighting in reverse order.
  7. Engine mapping upgrade progress not shown after event (dynamic visualisation after rewards screen) or in vehicle selection menus. Progress is still occurring and upgrade can be selected from the garage once it's at 100% (at least for the NR4 Mitsi Evo X anyway).
  8. Recommended repairs still buggy on some occasions. E.g. occurred when repairing a used car from the market place (GrB MG Metro)
  9. Notification added for when a player completes research on a car’s final engine upgrade in My Team doesn't seem to be working (just finished the weekly NR4 in the Mitsi Evo X to achieve final engine upgrade, didn't see any notification, just saw it upon checking the car upgrade menu in the garage).
  10. Ambient sounds and music dropping out in vehicle service area (while menu selection feedback sound and rain still works). Happens immediately upon selecting menu items e.g. option, tyres, tune, event details. Normal sounds resume after starting stage.
Edited by KoAStR
typo, flat tyre is unrepairable despite carrying a spare. Sound drop out bug still occuring
  • Thanks 1
  • Agree 3

Share this post


Link to post
Share on other sites

PC (Deluxe Edition)

There Is a bug with motor options on 205 T16 RX, motor options #5 and #6.

Share this post


Link to post
Share on other sites
Posted (edited)

on Xbox One the beug of the event ranking ( during playing the event) is partially resolved: 1) it's OK, it's the good cumulative time of the rally that is displayed : solved  ……….. 2) but it's the same bug insolved on the display "found me" : above the lines are empty and filled with "player dirt" without time and my rank is false. When I do a scrolling up I find my name higher at the right rank. and when I redo "found me" the first false display reappears. 

Edited by Didd31

Share this post


Link to post
Share on other sites
Posted (edited)

Nothing major...is this a ******* joke? Codemasters, are you trolling us? Another month for..."nothing"! I'm tired of waiting.¬†ūüė†

Edited by orangejuiced83
  • Agree 2

Share this post


Link to post
Share on other sites

"Elite and Master AI difficulty adjusted in My Team Rally Events to provide a fairer transition upwards from Pro"

has anyone tested it yet?
i'm tired of driving the free lancia which is the only vehicle i manage to compete with the ai times. 

Share this post


Link to post
Share on other sites

20. If you don't take spare tyres and have a puncture in a stage, the tyre will still get repaired on the next one. If you don't take spare tyres, the tyre shouldn't get repaired in the next stage. If you do take spare tyres, it should use one or more depending on how many tyres you have punctured and how many you have in the trunk. This used to work before v1.2.

Something to take into account.

Share this post


Link to post
Share on other sites

Doh just had the sound drop out on the new Daily RX GrB at hell so edited my earlier post.

Share this post


Link to post
Share on other sites

PC deluxe edition. Running an AMD RX580. Never seen this before v1.5. Rendered the stage undriveable. So I paused and grabbed this video. The effect persisted even after ALT+Enter input, in the replay, and when the service area when loading up a new event (so didn't bother starting that one). Restarting the game resolved the issue. Will update graphics drivers and see if it happens again.

Also recommended repairs bugged out on first time repair of a used MG metro... same as reported in v1.4 where components out of view stay on 'no fix' until scrolling down to view and re-selecting "recommended repairs".

Share this post


Link to post
Share on other sites
4 minutes ago, KoAStR said:

Also recommended repairs bugged out on first time repair of a used MG metro... same as reported in v1.4 where components out of view stay on 'no fix' until scrolling down to view and re-selecting "recommended repairs".

So, not really fixed like you mentioned before? It's intermittent.

Share this post


Link to post
Share on other sites
6 minutes ago, Riggs said:

So, not really fixed like you mentioned before? It's intermittent.

Yea unfortunately not. Thought having done a dozen or so repairs was a big enough sample as it was occurring frequently before. Have edited my earlier post.

  • Thanks 1

Share this post


Link to post
Share on other sites

PS4, Deluxe

in the clubs, at each workshop, you have to reload the car settings

  • Agree 2

Share this post


Link to post
Share on other sites

PS4, Deluxe

In clubs, windshield broken at the start of the stage despite all repairs being done

 

Share this post


Link to post
Share on other sites
15 hours ago, danielofifi said:

When I resumed my championship in rally career, a bug with tyre choice appeared: at every service stop it showed medium tyres being used, even though I chose softs before every stage. Also, the number of available tyre changes did not go down, it remained 3/3 throughout the whole rally.

the same for me @Riggs

Share this post


Link to post
Share on other sites
Posted (edited)

Not sure if this has been reported but I played in career mode this morning and noticed that whatever tyres I place on my car before completing a couple stages, the wrong tyre is shown installed when viewing at the next service area. For instance, I had an 8KM stint in Poland split between 2 stages, followed by a service area. I threw on "soft" tyres and then went on to complete the next 2 stages with those tyres. Upon returning to the next service area, I went to replace my tyres with new ones and the tyres shown equipped were "mediums". They drove like "softs", there is no mistaking those 2 compounds and am sure this is a bug. They were shown as "worn" which is good, that function is still working but the tyre compound seems to be stuck on "medium" regardless of what you put on your car. 

 

Other than this, I've only encountered the audio bug before you race a stage. Happens to me whenever I go to repair/view part condition on the vehicle. There is still a little bit of sound but it's quite muffled with a bit of static, it's like if you fell into the trunk of the car and someone closed the hatch lol. Everything else is running smoothly for me and overall quite happy with this patch. Keep up the good work devs. Really appreciate everything you guys do for us. Have a great rest of your week. Cheers.

 

-your friend,

zero

Edited by ZeroAffex
  • Agree 2

Share this post


Link to post
Share on other sites
22 hours ago, Riggs said:

42. Engine upgrade progression seems to have stopped, either that or the notification with the circle filling in isn't working anymore, showing the progress made. NOTE: Bug introduced in v1.5, officially acknowledged by CM. A hotfix is in the works.

 

This one's fixed, team pushed a server-side fix through RaceNet a short while ago ūüôā¬†

(excellent list/post by the way)

 

 

  • Like 1
  • Thanks 9

Share this post


Link to post
Share on other sites
5 minutes ago, PJTierney said:

 

This one's fixed, team pushed a server-side fix through RaceNet a short while ago ūüôā¬†

(excellent list/post by the way)

Immediately working on my end. Thanks.

Share this post


Link to post
Share on other sites
17 minutes ago, PJTierney said:

 

This one's fixed, team pushed a server-side fix through RaceNet a short while ago ūüôā¬†

(excellent list/post by the way)

That was quick! Great job guys!

Share this post


Link to post
Share on other sites

Hi, thanks for the update. In the next one would it be possible to let us change the AI difficulty between each race of a single event in rallycross (as it is in F1 2018 between practices, qualy and race for exemple) ? For now we can modify the difficulty only between two events and sometimes when I enter a new weekend in a championship, I notice the difficulty is unbalanced and I can't change it anymore. Thank you in advance ! @Riggs @ChristinaMc

Share this post


Link to post
Share on other sites
2 minutes ago, joulz75 said:

Hi, thanks for the update. In the next one would it be possible to let us change the AI difficulty between each race of a single event in rallycross (as it is in F1 2018 between practices, qualy and race for exemple) ? For now we can modify the difficulty only between two events and sometimes when I enter a new weekend in a championship, I notice the difficulty is unbalanced and I can't change it anymore. Thank you in advance ! @Riggs @ChristinaMc

Wish i could do something :classic_biggrin:

Fwd: @PJTierney

Share this post


Link to post
Share on other sites
4 hours ago, GregPit81 said:

PS4, Deluxe

in the clubs, at each workshop, you have to reload the car settings

I’ve noticed this is a thing on Xbox too. This could very easily catch you out. 

Share this post


Link to post
Share on other sites
  • What platform you're playing on.
  • Whether you're a Standard Edition or Deluxe edition user.
  • Where the bug happened.
  • Have you been able to reproduce the bug?
  • If you have been able to reproduce the bug, post as clearly as possible the steps you went through to trigger it.
  • Screenshots or video would be nice too but a detailed description is often good enough.

Playing on Xbox one, Standard Edition.

While in service stations between stages in the new Racenet Clubs mode the tune for the car would reset to stock.

so before stage 1 you would change stock tune, and for stage 2 it would reset, always when there was a service station.

 

the first time I was using a Tune I saved before and applied without changes for stage 1.

then for stage 2 it was reset to stock.

The second time I changed the stock tune without applying a saved tune, same thing happened. 

Both times were in different clubs, cars, car classes and locations.

  • Agree 1

Share this post


Link to post
Share on other sites

no changes for me whatsoever.

- cars still clean in every new (rallye)stage.

- rallycross Ai still dirty

- AI in Master does still better times then WR

- engine upgrade research still not working (despite server update?)

 

only thing that¬īs changed for me is the rain effects...

  • Sad 1

Share this post


Link to post
Share on other sites
Posted (edited)

So we are in a real simulation?

- If you do not have a new tire after a stage, nobody in the real life will send you on the rims
- After all, no one will be sent out anyone  without any light (if ithas broken during the formerly the stage).

This is nonsense! Offer penalties - but not in this shape!

Edited by Flens07
  • Agree 2

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×