Jump to content
Want to report an issue? Have a bug to report? Please look here first!!!! Read more... ×

Archived

This topic is now archived and is closed to further replies.

F1 2019 - Game crashes on start (Win7 DX11) [SG]

Recommended Posts

I've a problem: when I launch the game it starts with a video resolution too high for my screen. I tried to change it with "Launcher option" with Steam but nothing. I tried with ALT+ENTER and the game crashes. I sent two email to Codemaster's assistence but they said that I can change it in-game. But I can't enter the game because the video resolution is too high so black screen, "Not Optimum Resolution", ecc...

Can anyone help me?

Thanks,

Icerion

Share this post


Link to post
Share on other sites

Hey! You can modify the hardwaresettings.xml that is located in the F1 2019 folder in Your Documents 🙂 You can google for more info.

Hopefully that helps.

Share this post


Link to post
Share on other sites

I think you have a GTX960, you might try disabling the Steam overlay as that is said to conflict with the 430.86 driver. Also, if you use MSI Afterburner, turn it off?

And 1280x1024 is a 5:4 aspect? That's odd for a display. What screen are you using?

Share this post


Link to post
Share on other sites

Yes, i've 2 GTX960  (SLI). I changed the driver and I've now the precedent version of 430.86. The Steam Overlay is off. And...what is MSI Afterburner? And How can I turn it off?😅

A screen 18 inch screen Samsung but it's old and that resolution is the max.

And no i don't have afterburner

Share this post


Link to post
Share on other sites
11 minutes ago, icerion said:

Yes, i've 2 GTX960  (SLI). I changed the driver and I've now the precedent version of 430.86. The Steam Overlay is off. And...what is MSI Afterburner? And How can I turn it off?😅

If you don't know what MSI Afterburner is, you don't have it. It's a downloadable utility that lets you monitor the card and lock the framerate, etc. 🙂

Try running the game in Single GPU Mode, the older versions of F1 didn't run well in SLI. Not a problem I've been (un)lucky enough to have.

Share this post


Link to post
Share on other sites

Done but nothing. Same problem.

Sorry about that, maybe is a stupid thing but...If you change your in-game graphics option and then you post here your hardware_setting file with my resolution and all. I can replace my files with yours...Do you think that is solution?😩

Share this post


Link to post
Share on other sites

That suggestion may work, providing that the settings are compatible between your systems. We usually only see problems where there are more complex GPU and monitor setups, so I suspect that there is something else going on here. I'd suggest trying the following things first:

  1. Delete your hardware settings file. This will force the game to create a new settings file next time it launches using default settings for your system.
  2. If you have more than one monitor then unplug any extras so that only a single monitor is plugged in,
  3. Set your system to use a single graphics card and a standard resolution for your monitor.
  4. Launch the game.

If this doesn't work then try ALT+ENTER again and confirm whether it is still crashing. Then send through your dxdiag, hardware settings file and Steam ID (see here for instructions) with a link to this thread and one of the support team will be able to get back to you. 

Share this post


Link to post
Share on other sites

Ok, I send the email like you said. I hope the support team have a solution for this; is since yesterday night that I'm trying to solve this😥

Share this post


Link to post
Share on other sites

We cannot solve this problem here? With email is so confusionary i sent the dxdiag and they told that I have to send it to them.

Share this post


Link to post
Share on other sites

Hi @icerion, we ask people to send certain information directly to us to avoid this being publicly available, as there is sometimes personally identifiable information in there (for example your PC name in your dxdiag, or your Steam ID). To confirm, please send the requested info to community(AT)codemasters.com (replacing the (AT) with an @ ). Thanks.

Share this post


Link to post
Share on other sites

Thanks - I will check if our Community Team have the info and will see if the dev team can assist with this.

Share this post


Link to post
Share on other sites

Hi @icerion,

Your dxdiag shows that you are running Windows 7 which only supports DX11. F1 2019 will try to launch in DX12 by default, so if running the game directly from the Steam startup menu (or possibly desktop shortcut) then it might be trying to launch in DX12 which will fail during launch. To confirm if this is the issue, please try running the game from the Steam library page - this should bring up a pop-up window before the game launches which asks you to select whether to run DX12 or DX11. Please select DX11 and try launching the game again.

Thanks,
Hoo.

Share this post


Link to post
Share on other sites

I always start it with Dx11 from the Steam Library. I'll never try Dx12 cuz is only for Windows 10

Share this post


Link to post
Share on other sites

Hi @icerion,

Please could you try launching in safe mode to see if this allows you to launch the game? To do this, you need to add the -safemode command line argument when you run the game. The simplest way to do this in Steam is:

  1. Right-click on the F1 2019 game in the Steam Library and select Properties
  2. Prress the "Set Launch Options..." button on the first tab.
  3. Enter -safemode into the text box and press OK to confirm.
  4. Launch the game.

This should launch the game with minimum settings. Does this allow you to boot the game?

Share this post


Link to post
Share on other sites

Ok, it's open in window (before this it never did it) but black window and than the game crash.

It crash when is windowed

Share this post


Link to post
Share on other sites

Hi @icerion,

Thanks for trying this out. We've located the crash information based on your Steam ID, so I've sent this through to the dev team for further investigation. I'll update this thread once I have anymore information. 

Share this post


Link to post
Share on other sites

I hope I can solve this today or tomorrow.

3 days that I can't launch the game😭

Share this post


Link to post
Share on other sites

I haven't been able to get the game to start, it just goes blackscreen for roughly 5sec then crashes and gives me the EGO crash dump window.

Specs:

Win7 Pro 64bit

Intel Core i5-2400

8gb RAM

Geforce GTX750Ti SC

I tried launching both on the current NVIDIA graphics driver version and on a previous one, as well as after disabling the steam overlay and the NVIDIA game overlay. The EGO crash log is attached. I may end up refunding this game until some fix comes, its simply frustrating, I've run all previous F1 games without issue on this system.

egodumper.log

Share this post


Link to post
Share on other sites

Suggestion removed as the hotfix is W10 only.

There is a conflict in 430.86 with Intel Sandy Bridge GPU drivers.

All Nvidia hotfix solutions are W10 only. It's time to upgrade

Share this post


Link to post
Share on other sites

Well that's certainly unfortunate, given that Win7 should work as per listed in the game requirements. I hope some fix on codies' end comes through.

Share this post


Link to post
Share on other sites
1 minute ago, MediumFrosty said:

Well that's certainly unfortunate, given that Win7 should work as per listed in the game requirements. I hope some fix on codies' end comes through.

When Nvidia pull their finger and get a new driver, maybe so.

Share this post


Link to post
Share on other sites

I did the clean boot procedure as suggested from the Codemaster's Custemers Service and launched the game in -safemode ma it's the same. The game crashed.

Share this post


Link to post
Share on other sites

×