Jump to content

F1 2019 MAJOR Force Feedback glitch on Starting Grid [ZX]

Recommended Posts

There is a massive force to the right when achieving optimum rpm at the starting grid, making good starts very difficult.

Im using a Fanatec Club-sport wheelbase V2.5.

Edited by RickyBelch98

Share this post


Link to post
Share on other sites

PC, Fanatec CSW V2.5, F1 2019 Limited Edition Formula Rim

On the starting grid in both F2 and F1, when you pull in the clutch and rev the engine, the force feedback is FORCED heavily to the right. Others are experiencing this as well.

Three other issues that need to be taken a look at are:

1. The F1 cars force feedback when driving needs to be increased, they feel too light compared to the F2 cars at the moment.

2. When using the exact same FFB settings as in F1 2018 the FFB clips (goes numb) when going through high speed corners, such as T12 at Bahrain in 2019 when this didn't happen at all in 2018.

3. The braking distances for the F1 2019 cars with Anti-Lock Brakes assist need to be the same as the AI. Currently we have to brake much earlier than the AI to make the corner which isn't fair.

PLEASE address these issues, they're extremely important.

Share this post


Link to post
Share on other sites

Hi,

As soon as i start, and just rev a little bit for the first time, my force feedback goes completly to the right side. I have made a video with 3 race starts zoomed in on the steering wheel.

I did not hear this problem from other users so i hope i can fix it by myself then.

Kind regards,

Daan

 

Share this post


Link to post
Share on other sites

Do you happen to be using a Fanatec CSW V2.5 or Fanatec DD on PC? I had the same issue with the CSW V2.5 in the beta, as well as other people with this wheel and the Podium DDs. It only seemed to affect these wheels and only PC. It was never fixed while the beta was going. Currently there is no known solution, changing drivers/firmware or reinstalling anything doesn't help. The only workaround is using assisted start and pit release assist (it jerks to the right on pit release too) while we wait for a fix from Codies.

  • Agree 1

Share this post


Link to post
Share on other sites

I use the Fanatec CSW V2.5 on PC. Then we need to wait for a fix then... i heard from a codemasters employee a few minutes ago that they will bring a patch out very soon.

  • Agree 1

Share this post


Link to post
Share on other sites

Here's another thread about the same issue: 

 

As I explain in my comment there, this was already an issue in the beta, so far no fix... seems to only affect CSW V2.5 and Podium DD users on PC.

Share this post


Link to post
Share on other sites

Here's another thread about the same issue: 

 

As I explain in my comment there, this was already an issue in the beta, so far no fix... seems to only affect CSW V2.5 and Podium DD users on PC.

Share this post


Link to post
Share on other sites

Hi all and thanks for posting, I've merged a couple of threads together as they appear to be about the same thing, mostly.

The team is aware of this and I believe a fix is in test.

As a note, please only have one issue per thread. This is so it's easier for us to track threads and reports. For any extra issues, please see if any one else has already posted about it, if so, add your comments to that thread. If there are no other threads, then please do create a new one. 

Thanks again! 

 

 

  • Thanks 1

Share this post


Link to post
Share on other sites
3 minutes ago, Faya said:

Hi all and thanks for posting, I've merged a couple of threads together as they appear to be about the same thing, mostly.

The team is aware of this and I believe a fix is in test.

As a note, please only have one issue per thread. This is so it's easier for us to track threads and reports. For any extra issues, please see if any one else has already posted about it, if so, add your comments to that thread. If there are no other threads, then please do create a new one. 

Thanks again! 

 

 

Thanks Faya! Good to know it's being worked on.

Share this post


Link to post
Share on other sites

No worries, @Desmond0313! Thanks for linking the other threads by the way. I've merged another thread into this one as they were about the same thing.

  • Agree 1

Share this post


Link to post
Share on other sites

During race start in F1 2019 the steering wheel turns suddenly to right with a lot of force. Is this Bugfix known to Codemasters? What counter measures do we have?

my System:

  • PC, F1 2019 Version 1.03
  • Fanatac CSW2.5, F1 V2 Wheel

Share this post


Link to post
Share on other sites

Hi all! I've merged another thread about the same item into this one. Thanks!

  • Thanks 1

Share this post


Link to post
Share on other sites

Still there for me.

Any chance we could get a progress report on this.

  • Agree 1

Share this post


Link to post
Share on other sites

Same issue for me using Fanatec Clubsport 2.5 wheelbase and formula carbon wheel, it startled me completely first time, I thought my wrist was going to brake

Share this post


Link to post
Share on other sites

Yeah thats right, it s too dangerous. I can't let play my son anymore. He was already injured by that behavior.

Share this post


Link to post
Share on other sites

I hurt my wrist slightly the first time. And waiting for a fix before driving it again. And to think a younger kid experiencing this issue, is a scary thought.

Share this post


Link to post
Share on other sites

Same issue. CSW 2.5. Start of every race, reach optimal revs and the game's like "Oh I heard you wanted your wrists broken LUL". The game is literally unplayable for me due to this ridiculous bug. How can something like this get through testing? Assuming any kind of testing is done at all...

Share this post


Link to post
Share on other sites
11 minutes ago, werrrrr said:

Same issue. CSW 2.5. Start of every race, reach optimal revs and the game's like "Oh I heard you wanted your wrists broken LUL". The game is literally unplayable for me due to this ridiculous bug. How can something like this get through testing? Assuming any kind of testing is done at all...

Wanna know something funny? This was reported during the beta, on the first week... and here we are

Share this post


Link to post
Share on other sites

Any ETA on a fix? It's almost 2 weeks since a 'fix' was in the works? I'd like to play the game at some point before the season is over.

Share this post


Link to post
Share on other sites

In Codemasters F1 2019 V1.05 preview notes it is mentioned that this bug is fixed.

Expected in 1-2 weeks.
 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×