Jump to content
Want to report an issue? Have a bug to report? Please look here first!!!! Read more... ×

F1 2019 - Brake Input Display - unplayable

Recommended Posts

When I am in the calibration menu, my brakes are recognized properly but as soon as I am on the driving screen, about the first 30% of my brakes are not recognized by the car and have no display on the HUD. After 30+% the brakes suddenly turn on and wheels lock. 

Playing on PC, windows 10, using steam, fanatec v2.5, csl elite load cell usb to pc.

I have tried messing with the sensitivity and threshold and
 re-install the game, the wheel and pedal driver. I have also changed USB ports, set new control configurations but no change.

With this issue the game is unplayable, any advice is appreciated - Thank you

Edited by YngwieReid
wanted to add unplayable

Share this post


Link to post
Share on other sites

Are you using the new 336 driver and included firmwares from Fanatec? If so the Brake force (if you have a loadcell brake) was switched so if you ran a 15 on the old driver in will now be 85 on the new driver. Everything seems alright on PS4 with my CSL Elite+ and ClubSport V3 pedals

Share this post


Link to post
Share on other sites

I believe so, I definitely updated the drivers. I'll flash the firmware and try again. May have to make a video to better show what's happening. The only solution I've found to make it mostly playable is to set sensitivity to 100 and shape to 100.

Really appreciate the help either way, incredibly frustrating. 

Share this post


Link to post
Share on other sites

Hi

i have the same setup (Fanatec CSL Elite WHeelbase + Elite Pedals Loadcell) and im using firmware 328 but the brake is absolutely working fine if you look on your "Fanatec Wheel Property Page".

I just need to touch the brake pedal around 1-2mm and you can see there is input. But in F1 2019 i need atleast 20-25% brake input before the ingame brakes start to work.

Absolutely unplayable in F1 2018 i didnt had this problem.

Share this post


Link to post
Share on other sites

Atom this is the same issue I have exactly.

What refresh rate are you using? do you have steam overlay turned off? running full screen mode? have you tried to tell if the HUD is incorrect and it is actually braking or is the HUD correct and the brake isnt applying? 

fwiw I've reinstalled everything and have the same issue still

Share this post


Link to post
Share on other sites

your hardware is fine the game is having a massive brake deadzone 20-30% i would say.

you can look in the calibration menu in f1 2019 and also on track you have to brake for 20-30% before anything happens. 

i have steam overlay turned off and running in fullscreen mode. the hud is correct.

Edited by AtomPirat

Share this post


Link to post
Share on other sites

Hey guys solved the issue for me :classic_biggrin:

You just need to remap all your Steering,Throttle and Brake Axis (delete the input buttons and remap them) and then in the Input Display just press Throttle and Brake to its max value.

Now my Brakes working just fine from 1-100% like in all other sims.

Dont know what the problem was.

Share this post


Link to post
Share on other sites

I have similar. I'm playing on PS4 with Fanatec Clubsport pedals v3. On PC on calibrations everything works. In game in calibration everything works (I barely touch the brake pedal and it's registering input). But in car the brake is registering only when load cells are fully engaged.

Share this post


Link to post
Share on other sites

I’m having the same problem and I have a thrustmaster wheel (T300) so not a firmware problem from the wheels 

Share this post


Link to post
Share on other sites

Any solution to this?


I just need to touch the brake pedal around 1-2mm and you can see there is input in ALL other games and in the Fanatec calibration. 

But in F1 2019 i need atleast 20-25% brake input before the ingame brakes start to work.

I am using Fanatec CSL LC pedals connected via USB.

 

Hope there is a solution because this is Unplayable! 

Share this post


Link to post
Share on other sites
2 hours ago, challenger: said:

Any solution to this?


I just need to touch the brake pedal around 1-2mm and you can see there is input in ALL other games and in the Fanatec calibration. 

But in F1 2019 i need atleast 20-25% brake input before the ingame brakes start to work.

I am using Fanatec CSL LC pedals connected via USB.

 

Hope there is a solution because this is Unplayable! 

Restart the PC. Look in your Fanatec properties and observe the correct pedal travel.

Start the game, go to your pedals control scheme and remap the (clutch) brake and throttle by depressing fully and releasing. I only have Fanatec pedals direct via USB, not via a wheelbase as I have the T300, so your pedal mappings might be under your Fanatec wheelbase (if you're connecting to pedals via RJ12).

Then save and play.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×