Jump to content

G29 - game not playable

Recommended Posts

As title says, i have a G29 that works flawlessly with all other games. Here it's simply broken. FFB is awful, going from too soft and shabby to unbelievably strong and hard to turn. All the effects from asphalt, curbs and out truck causes the wheel to shake and tremble with an horrible noise, and the only solution is to tune them down to a level where they are almost uneffective. I have tried different settings and solutions with no luck at all.

In addition, my copy of the game is not provided with the slider to change the max wheel roration, as you can see in the screenshot, and this makes turning weird and unpleasant. being not mapped 1 to 1 by default.

Any other user is experiencing the same issues? Or do we know if codemaster is aware of this horrible situation and plan to fix it? 

 

 

 

20190626010747_1.jpg

Share this post


Link to post
Share on other sites

Same problem here. G29 on PC. Working great with AC, ACC, PC2 and DR2. However, there is no FFB in F1 2019. Some vibration and rumble, but no FFB. I reinstalled LGS and deleted old profiles from the registry. That didn't help. The wheel is detected, the RPM lights work but absolutely no FFB. Obviously I increased the FFB slider all the way to 150, did not change a bit. I hope this is just a bug that can be patched -soon-.

Also, no slider to change max wheel rotation......

Edited by mamorales33

Share this post


Link to post
Share on other sites

Firstly, remove wheel damping to zero, then drop ffb to 50 or 60, and then increase track effects where necessary. What you're getting is clipping, exacerbated by the wheel dampening.

  • Agree 1

Share this post


Link to post
Share on other sites
1 hour ago, Rallystu2 said:

Firstly, remove wheel damping to zero, then drop ffb to 50 or 60, and then increase track effects where necessary. What you're getting is clipping, exacerbated by the wheel dampening.

Really shouldn't have to do any of that. The G29 should be driveable out of the box (maybe not to everyone's liking) but then adjustable in a recognisable way.

Problem is, the G29 owners without an issue won't be looking here to suggest what's wrong. 

Share this post


Link to post
Share on other sites

I've not found a game yet that works well with wheels out of the box. 

 

The main problem is wheel damping. Its not a feedback feeling of any sort, it simply adds tons of unnecessary wheel weight, which can make it clip (particularly on the gear driven g29). Try lowering the ffb to 60 and wheel damping to 0.

 

 

Share this post


Link to post
Share on other sites

I asked David Greco on Twitter if he had any recommendations for settings with the G29 and here’s his response. Hope this helps...

I use default FFB but 50% strength on the Logitech. Also, I use throttle linearity around 20% and 360 to 400 degrees rotation, depending on track. If it is too sensitive, use 400, otherwise 360 is a 1 to 1 ratio with the ingame wheel.”

 

As others have said with last years game I had the Wheel Damping setting quite low (around 5 if I remember right) as it does add a lot of weight even with lower numbers. 

  • Like 1

Share this post


Link to post
Share on other sites

I've tried all suggestions here with no luck. Lowering the ffb strenght to 50% makes the wheel turn like it has no weight at all, and u can't feel anything FFB side. And i'm still not able to change the degrees rotation of the wheel, because the option is not present in my game. 

 

Anyone has found a solution to this? How is that even possible?

Share this post


Link to post
Share on other sites

Hi @BudStencer

I also play on PC with a G29. Also found the whole wheel behavior and feel massively different to 2018 and also to the beta. 

I'm still trying and I'm not 100% happy yet, but going from David Grecos suggestions improved the handling massively. 

I also always have to leave the LG software open and sometimes have to go back to it while F1 2019 is running to make the changes I did in LG software really happen in the game. Wheel rotation I change with the LG software. And also turning the wheel sensitivity down. 

When I'm at home tonight I will post my actual setting both in game and in the LG software. I think a lot of G29 users are experiencing the same atm. 

Cheers from Heidelberg /Germany 

Daniel 

Share this post


Link to post
Share on other sites

Logitech G29 here, as well. I am on the PC.

I had very serious problems with FFB in F1 2018 already. For me the solution was this:

* start Windows

* let LGS load

* manually close LGS

* manually launch LGS

* game works flawlessly

 

It's exactly the same with F1 2019. After starting LGS for a second time the G29 works perfectly with the game.

Share this post


Link to post
Share on other sites

hello, I have a ts-xw racer sparco p310 with F1 wheel I have the FFB 150 all the bottom except effect of the track has 75 and I is not a problem instead it is pure enjoyment.  I have no loss of FFB.  your steering wheel this is old

  • Disagree 4

Share this post


Link to post
Share on other sites

Hi, same problem here. Everything works fine, kerbs, grass, bumps, it all works as it should. The problem is the main force feedback, there's no communication between the wheel and the game. You have to apply the same force to turn when stationary than when you are at 300 Km/h. As i said, all the rest works as it should but the fact of not being able to counter-steer because you dont feel the car makes the game unplayable.

Share this post


Link to post
Share on other sites

Hi @BudStencer

these are my settings. tweaked it a bit. Not 100% there yet, but massive improvement to the very beginning. Perhaps I'm just getting used to this massive understeer ...

1820484274_Ingame1.thumb.jpg.583599c11c1c0ea80cb1a603d5f2a36c.jpg1318584411_ingame2.thumb.jpg.ef0c0a2a7f58bcaab184b2fe39ac6c80.jpg1753303741_logi1.thumb.jpg.fab18ad5d960c06b46f6ad7cc430af87.jpg791910497_logi2.jpg.98d2e60b48a5558d84bf3ba9bc5cd1f0.jpg

Share this post


Link to post
Share on other sites

I had some really weird FFB, etc. in F1 2018 after having fired up Project Cars 2. Turns out that game writes into the controller registry values for the G29 and the Codemaster games doesn't really like that.

I remember the fix suggested in this thread removed my problems at the time. Could be worth a try for you guys aswell.

https://steamcommunity.com/app/737800/discussions/0/1733210552686272214/ (fix in first reply)

Share this post


Link to post
Share on other sites

Been having a play around with some settings using the Logitech G29 on PS4 with the game. Got it feeling really good for me personally and definitely comparable to how the game felt last year at the very least.    

 

Here are my current settings. I used David Greco’s recommendations as a starting point and then tweaked a few options to taste...

 

Calibration: (All default 0 with the exception of two options...)

Throttle Linearity - 20 (David Greco suggested this I believe to soften the initial input on the throttle a little)

Brake Saturation - 5 (This is because I’m using the default G29 brake pedal with the rubber still installed and wanted the pedal to feel a little more responsive to input)

 

Vibration & Force Feedback:

Vibration & Force Feedback Strength - 50

On Track Effects - 30

Rumble Strip Effects - 40

Off Track Effects - 30

Wheel Damper - 5

Understeer Enhance - Off

Maximum Wheel Rotation - 360 (David did suggest upping to 400 if the steering feels too sensitive on some tracks)

 

I really hope these settings manage to help some that are struggling to find a good base setup on the Logitech G29 👍 

 

Edited by stephensmattlee

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×