Jump to content
  • 0

Game Crashing Randomly (not just at start up) [ZX]

Question

I5-3570k / 1070 430.86 driver / Win 10

Game crashes at start in DX12.

Game sometimes crashes at start in DX11

Steam Overlay turned off. Nvidia overlay off. MSI Afterburner closed.

Sometimes game starts, I went through driver creator, options, but when i went to customization and loaded the car liveries it crashes everytime.

Guess I can't play until hotfix?

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

Thanks, @steviejay69! I'll pass the info along to the team. Thanks!

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)
23 hours ago, Faya said:

Thanks, @steviejay69! I'll pass the info along to the team. Thanks!

So I even stripped down the GPU and applied new MX-4. Definitely not heat-related, but I do have concerns about the lack of lighting effect with the latest driver. It is supposed to be the official driver release for the game. If I can elaborate on the issue, the wheel goes to full left lock and vibrates against the stop until the game decides it's had enough.

Seeing as I can switch the rim, that's the next thing to check I suppose.

Edit: Still occurs with the F1 Rim but doesn't go into lock or anything.

Edited by steviejay69
Update

Share this post


Link to post
Share on other sites
  • 0

Why are you still posting here? You seem in great need of a reformat or someone to come help you with your hardware...

  • Haha 1

Share this post


Link to post
Share on other sites
  • 0
Just now, Sojourner said:

Why are you still posting here? You seem in great need of a reformat or someone to come help you with your hardware...

It's already a clean install of 1903. There are issues with the 19.6.3 driver, which is supposed to be the official driver with F1 2019 support.

It's DX12 related. I'm feeding back things I have tried, just so if anyone in a similar position can confirm/deny/rule out.

It's better than posting "My game doesn't work" with no specs, hardware or otherwise. You and I can both have a working game in DX11, but I prefer to help solve the DX12 issues. If no one highlights or mentions them then they don't get fixed. I'm not starting another thread as the issue is the same. I get random lock ups that I can "replicate" on this track in this game mode.

So if you've finished being facetious, you can unfollow the thread if you like.

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

OK, finally I have a handle on it. It's lighting.

I can reproduce the crash on Bahrain and Singapore on 'Official' Time (because it's a night race). I can reproduce at Monaco and Abu Dhabi because it allows 'Midnight'.

Some tracks are extra configurable as 'Dusk' and 'Midnight'. I'm doing more testing but I'm fairly sure any race that can be set at night (also 'Dusk') will crash. @Faya

Update: Singapore there is a lot of flicker (bright flashes). On 'Dusk' the game stuttered hard at Singapore and Monaco but didn't produce a crash report, maybe I just didn't keep going long enough.

I can see the lighting is wrong on all these tracks compared to DX11, there is no fogging (lighting glow) effect in DX12.

(If someone with an AMD card with 19.6.3 can replicate (in DX12) or anyone with a working Nvidia card can confirm or deny. The crash is after a random amount of time in the session from corner 1 to three or four laps in before the crash occurs.)

Edited by steviejay69
More information

Share this post


Link to post
Share on other sites
  • 0

Thanks @steviejay69! I believe we have a fix in test for the crash you're seeing. I'm not sure which patch the fix will go in, but I may poke you to test the fix once it's live. Thanks again! 

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
5 hours ago, Sojourner said:

Why are you still posting here? You seem in great need of a reformat or someone to come help you with your hardware...

He is a pc genius so I don’t think his pc needs maintenance.  He does this sort of thing for a living!  We are all lucky to have someone with his technical knowledge on here offering us advice and feeding back to Faya what he has tested.    

  • Agree 1

Share this post


Link to post
Share on other sites
  • 0
5 hours ago, Acerees said:

He is a pc genius so I don’t think his pc needs maintenance.  He does this sort of thing for a living!  We are all lucky to have someone with his technical knowledge on here offering us advice and feeding back to Faya what he has tested.    

I prefer genius to expert, so thank you 😉

  • Haha 1

Share this post


Link to post
Share on other sites
  • 0
10 hours ago, steviejay69 said:

I prefer genius to expert, so thank you 😉

I call it like it is 👍

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
On 7/3/2019 at 3:14 PM, steviejay69 said:

OK, finally I have a handle on it. It's lighting.

I can reproduce the crash on Bahrain and Singapore on 'Official' Time (because it's a night race). I can reproduce at Monaco and Abu Dhabi because it allows 'Midnight'.

Some tracks are extra configurable as 'Dusk' and 'Midnight'. I'm doing more testing but I'm fairly sure any race that can be set at night (also 'Dusk') will crash. @Faya

Update: Singapore there is a lot of flicker (bright flashes). On 'Dusk' the game stuttered hard at Singapore and Monaco but didn't produce a crash report, maybe I just didn't keep going long enough.

I can see the lighting is wrong on all these tracks compared to DX11, there is no fogging (lighting glow) effect in DX12.

(If someone with an AMD card with 19.6.3 can replicate (in DX12) or anyone with a working Nvidia card can confirm or deny. The crash is after a random amount of time in the session from corner 1 to three or four laps in before the crash occurs.)

OK, after today's updates I have not had the reproducible crash in Bahrain TT with 'Official' time.

There has been an update to .NET Framework, a Windows 10 Cumulative and I have updated the AMD Adrenaline to 19.7.1

I shall continue to monitor this, but it still does not fix the lighting issue seen in DX12 mode and highlighted a way back up this thread at this post. @Faya

I also feel the community need some kind of indication about a timescale for the next game patch to fix the multitude of issues.

  • Supported controllers (Fanatec, Logitech and Thrustmaster not working as expected when supported)
  • Car Performance issues and missing achievements
  • Multiplayer Spec car pitbox issues
  • Skill rating and disconnection from Event lobbies

Thanks for your efforts and I hope we can see progressive patching efforts soon.

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

OK the issue (Bahrain crashing) is back with 19.7.2

This time it was in Grand Prix mode rather than TT.

Crash dump attached @Faya

crash_dump#544587-20190719-161139-0.zip

Again, anecdotally it seems to me if the screen goes a funny colour during the driver install the game crashes and when it doesn't (19.7.1) it works.

Rolling back to test.

Edited by steviejay69

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×