Jump to content

F1 2019 graphics bug

Recommended Posts

This is the first time i  have bough an f1 game and I was really exited but when I started playing the screen went black and white when I was of the track, including in the garage. Because of this I can't do a race without the screen going all funny. Can some one please help me so I can play the game 

20190626175212_1.jpg

20190626175224_1.jpg

Edited by NeoCawte

Share this post


Link to post
Share on other sites

I am having the same problem but it's my fault. I didn't check the specs first.  No excuses.  I apologize to all especially to Codemasters.  Changing this post to reflect that. Purchased an AORUS RTX 2070 eGPU but won't get to it until the weekend.  System is a NUC 717BNKQ with 32 MB.  Again, my apologies to all for my misstep.

Edited by Kogsly
Didn't look before I lept

Share this post


Link to post
Share on other sites
2 hours ago, NeoCawte said:

I found out that in my case it is most likely cased by my PC not having the minimum specs.

Then it rather begs the question why you bought the game, but thanks for feeding back.

So the other two @Kogsly and @Joerd was this your issue too?

Share this post


Link to post
Share on other sites
On 8/18/2019 at 6:56 AM, steviejay69 said:

Then it rather begs the question why you bought the game, but thanks for feeding back.

So the other two @Kogsly and @Joerd was this your issue too?

I am guilty.  Changed my post to reflect that.

Share this post


Link to post
Share on other sites

I've had the same problem. When you open the game with steam you can choose between directx 12 and directx 11. When I tried the directx 11 the problem was solved. 

Share this post


Link to post
Share on other sites
5 hours ago, Piketje said:

I've had the same problem. When you open the game with steam you can choose between directx 12 and directx 11. When I tried the directx 11 the problem was solved. 

Then the PC is set up incorrectly. No reason why a W10 PC cannot run DX12 with relatively modern, inexpensive equipment.

Share this post


Link to post
Share on other sites

I have the same problem, but the thing is, that on Windows 10 I get this, but not on Windows 7, where I have exactly the same drivers installed. Even if I switch to Dx11 on Win10 it still has the same problem...

Share this post


Link to post
Share on other sites
16 hours ago, KulibobCZ said:

I have the same problem, but the thing is, that on Windows 10 I get this, but not on Windows 7, where I have exactly the same drivers installed. Even if I switch to Dx11 on Win10 it still has the same problem...

Ok, you've piqued my interest from lurking. 

Do you have an AMD system? Please post some specs, thanks.

 

Share this post


Link to post
Share on other sites

hey guys same thing is happening with me i bought f1 2018 a couple days ago and got this glitch and thought it was the game so I bought 2019 and the same thing is happening its very frustrating and I just want it to be fixed and my computer is way above the requirements to run the game can someone please help

Share this post


Link to post
Share on other sites

hey guys so i just purchased f1 2019 a few days ago and have put in probably a good 5 hours trying to fix this bug the sky has a bunch of lines that flicker a lot and the car is basically all white and is virtually unplayable  I was really excited to play the game but I am very disappointed. I have already tried updating my graphics driver and it is up to date I have also tried to uninstall and reinstall and using it on DirectX 10, 11, and 12 all of them don't work I've also tried verifying the game files with steam and have played around with the in-game settings. my computer is also well above the requirements for the game as I run pretty much every game at max settings and they all run fine. please, someone, help me I desperately need it and want to play this game as soon as possible.

Share this post


Link to post
Share on other sites

Hi everyone,

To add to what @steviejay69 said, if you are running into technical difficulties, more details will be needed. (A DXDiag would be useful)

Can you post your current system specs and the below information too. Without this, we cannot diagnose the issue

 

 

Platform you’re on (PS4, Xbox One, PC, Steam):

Game Version (Shown on the Start screen in the bottom left hand corner):

Game Mode, including if it was Single Player or Multiplayer (Time Trial, Career, Grand Prix, Custom Game etc):

If in Multiplayer, how many players and how many AI?

What happened in the lead up to the problem?

If you get an error message, the exact wording of the error message you're receiving:

Any accessories you are using (wheel, pad, etc):

If you have any videos or screenshots, please share them. If the video is long, please include a timestamp for when the issue appears:

Share this post


Link to post
Share on other sites

Hi @Spitz29,

I've merged your post onto this one, as it is about the same issue.

Moving forward, please aim to post in just the correct thread as it makes it easier for us to see how many people have this problem, and we can communicate with more people at the same time.

Many thanks.

Share this post


Link to post
Share on other sites

@BarryBL okay, I'm sorry about that and here is all the information you've requested 1. I'm playing on pc using steam 2. The game version is 1.18 3. I have only tried career mode but I think the problem happens on all modes 4. once the game loads into the race or the practice right away in the garage the top of the screen is bugging out and the car is almost all white 5. no error messages 6. I use a Logitech g29 racing wheel and pedals 7. 

Screenshot (1).png

Share this post


Link to post
Share on other sites
On 11/30/2019 at 4:21 PM, Spitz29 said:

@BarryBL hello? can someone plz help?

Hi @Spitz29,

Thanks for your information.

Just to double-check everything, please could you provide a DXDiag when possible. How to do that is here.

Share this post


Link to post
Share on other sites
On 11/30/2019 at 4:21 PM, Spitz29 said:

@BarryBLHi  hello? can someone plz help?

Hi @Spitz29,

Thanks for the DXDiag.

It looks like you are running some very old drivers on your graphics card. Another note is that your sound card drivers are old too and so is your of Windows, so these will be useful to check and update to potentially optimize performance.

Share this post


Link to post
Share on other sites

@BarryBLokay thanks but when I go to update my graphics driver it says it’s fully up to date and I will try and see if I can update my sound driver and did u mean to say I am running an old version of windows? And should I update my windows version ?

Share this post


Link to post
Share on other sites

Hi @Spitz29,

From the DXDiag you sent to me, your driver date is 23/04/2017, which may need to be checked for updates online. I'd recommend checking online as it looks later ones are available.

Share this post


Link to post
Share on other sites

@BarryBLthanks so much for your help like this whole last week basically i finally got it to work thanks so much ive been having a blast playing the game 

  • Like 1
  • Agree 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×