Jump to content

Help Please - F2 Scenarios Bug

Recommended Posts

Hi all!

With the release today (Anniversary Edition) I was eagerly waiting to play all day! Upon firing the game up, I started the Career mode. 

Now, to my surprise, the first scenario where you must decided to let Weber through or not did not include any engineer radio calls!? Having watched gameplay clips on YouTube I was aware that you’re presented with the choice to let him pass or not, but I completed the whole scenario with not a single radio call! I started the second scenario at Austria and the same appears to be happening. All audio settings are correct etc. 

Has anyone had this happen before? Seems like some sort of bug I assume? I’ll definitely restart Career mode but just wanted some input in case I’m missing something! 

Thanks 

Share this post


Link to post
Share on other sites

which platform are you playing on? which version does your game has?

It worked for me without any regrets, a lot of engineer calls who told me where Devon is at the moment.

Ps4 pro, gameversion 1.03

Share this post


Link to post
Share on other sites
On 6/28/2019 at 9:35 AM, AFROR34BOY said:

Hi all!

With the release today (Anniversary Edition) I was eagerly waiting to play all day! Upon firing the game up, I started the Career mode. 

Now, to my surprise, the first scenario where you must decided to let Weber through or not did not include any engineer radio calls!? Having watched gameplay clips on YouTube I was aware that you’re presented with the choice to let him pass or not, but I completed the whole scenario with not a single radio call! I started the second scenario at Austria and the same appears to be happening. All audio settings are correct etc. 

Has anyone had this happen before? Seems like some sort of bug I assume? I’ll definitely restart Career mode but just wanted some input in case I’m missing something! 

Thanks 

Did you manage to get this fixed? I’m having the same trouble. I have restarted the career mode multiple times and have even uninstalled and reinstalled the game, but this is still happening. I’m playing on Xbox one. 

 

Cheers. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×