Jump to content
  • 0

F1 2019 UDP Fuel laps not working correctly

Question

@Faya @Hoo

when in practice or qualifying sessions, the amount of laps on fuel is correct, just as on the MFD. I use Simhub so I can check the properties anytime i want.

When starting the race, that's where it's going wrong. In stead of let's say 17.1 laps it says 1.7 or another crazy low amount, in which your fuel delta is pretty much screwed too. 

It's a very weird issue, because in all other sessions it's perfect. Just the race is when it's wrong.

Share this post


Link to post
Share on other sites

11 answers to this question

Recommended Posts

  • 0
5 hours ago, BiohazardBGR said:

Yea the same problem was in 2018 and screwed one of my races!

Well, that can't be because CM only just released Fuel/laps in UDP this year so whats on MFD, can be on the steering wheel.

but i believe i have found the issue. When starting formation lap, it gives an amount on UDP, about 1.2 laps fuel. At the race start, UDP doesn't send the actual amount of fuel that you have. Then the data is completely wrong.

so it has to do with racestarts and difference in fuel amount between formation lap and race start.

Share this post


Link to post
Share on other sites
  • 0

The way we report the fuel in races is based on an estimated amount of fuel usage for the duration of the race (some thing like fuel amount - fuel burn rate * number of laps left). This give a +/- value to show you how much fuel you will have at the end of the race. In sessions where there is no end point, I think this just gives the number of laps of fuel left based on your current fuel burn rate.

During formation laps, we may be locking fuel levels to avoid throwing out players' total fuel amount for the race, so you may be seeing correct fuel readings only once the race session commences. Would this explain what you are seeing? 

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)
2 hours ago, Hoo said:

The way we report the fuel in races is based on an estimated amount of fuel usage for the duration of the race (some thing like fuel amount - fuel burn rate * number of laps left). This give a +/- value to show you how much fuel you will have at the end of the race. In sessions where there is no end point, I think this just gives the number of laps of fuel left based on your current fuel burn rate.

During formation laps, we may be locking fuel levels to avoid throwing out players' total fuel amount for the race, so you may be seeing correct fuel readings only once the race session commences. Would this explain what you are seeing? 

Thanks for the reply @Hoo, that's where the problem lies. I guess the UDP now sends fuel for 1 lap (formation), but doesn't change after the race actually starts. Even without Formation Laps, it always says around 1.2 laps of fuel. So my guess is that perhaps you locked the wrong value? Just guessing

 

it's only in the race, the rest is perfect! Just program the delta to be only visible in race. IF the fuel/laps amount is right offcourse🤣

Edited by AlexTT

Share this post


Link to post
Share on other sites
  • 0

Hi @AlexTT. We've taken a look at this here and can't repeat the issue. The fuel values seem to be recording correctly in different sessions. Was there a particular game mode where you were seeing this issue, or any other steps you did to get this problem to occur?

Share this post


Link to post
Share on other sites
  • 0

@HooIt only occurs when starting a race. 

Here's some screenshots from game and what the data over UDP shows.

As you can see, the MFD shows 17.6 and UDP shows 1.474166.

i tried with or without formation lap, different types of races, all the same.

9392F25C-5096-4B28-B89F-56BC69522D19.jpeg

FDF7A408-76D8-4CDD-B9FF-A2DF60E76100.jpeg

Share this post


Link to post
Share on other sites
  • 0

Hi @AlexTT,

The race hasn't started yet as you are still sat on the grid, so the values in the UDP data are probably stale. Once the start lights go out you should get the correct values. 

Cheers,
Hoo.

Share this post


Link to post
Share on other sites
  • 0

@Hoo, made some new pics so you can see before and after start.

 

These are before start:

93B8B310-5F45-448A-9AB8-D5DCA659D1A2.thumb.jpeg.dbf7f130017740ada6ec2b06d766d74c.jpegF6234F0F-1F78-416D-B1C2-B1B66B9594F8.thumb.jpeg.c0a4435bebf731473ffe6ee0f351c8fd.jpeg

then directly after the start as you described, it became slightly more, but not on par with the mfd.

6EF546D0-79A1-495B-BE72-FCDDEB9F318D.thumb.jpeg.dbbc95b1ee296a61e70f60ee81c56438.jpegFFBFABB4-935F-40E5-9E8F-8A279A3436E3.thumb.jpeg.066e8d8cc6eaab31e6a570ab71acef31.jpeg

Share this post


Link to post
Share on other sites
  • 0

Hi @AlexTT,

We've double-checked this here with our internal app and it is definitely reporting the correct values for fuel remaining. Are you able to check your app factor to ensure that the CarStatusData packet is being read in correctly using the latest spec (the one listed here)?

Share this post


Link to post
Share on other sites
  • 0
21 minutes ago, Hoo said:

Hi @AlexTT,

We've double-checked this here with our internal app and it is definitely reporting the correct values for fuel remaining. Are you able to check your app factor to ensure that the CarStatusData packet is being read in correctly using the latest spec (the one listed here)?

@Hoo

I'll send the one who designs simhub a mail, i'll come back to you!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×