Jump to content Jump to content

[PC] F1 2019 Throttle not calibrating to 100%


McBeardFace

Recommended Posts

Now that I have my throttle pedal being seen by the game it will not calibrate to 100%.  Even with saturation set to full, it will only register 75% throttle input.

I am using Heusinkveld pedals, Win 10 x64.

Is there a configuration file where I can manually adjust the calibration?

Thanks in advance for any advice.

Link to post
Share on other sites

Ok....so I found the file and looks like I might have some success...

If you go to "<install drive>:\SteamLibrary\steamapps\common\F1 2019\actionmaps" you will see a bunch of XML files.

I have Heusinkveld pedals as I mentioned.  If you look at the files "he_sim_pedals_v1.xml" and "..._V2" and "..._v3.xml" in notepad then look at the following line:

"<Axis axisName="di_z_axis" type="uniDirectionalPositive" deadZone="0.0" saturation="1.0" />"

Because my throttle was not reaching 100%, I adjusted the saturation value to "0.5".  Now mine looks like this:

"<Axis axisName="di_z_axis" type="uniDirectionalPositive" deadZone="0.0" saturation="0.5" />"

With some tweaking of deadzone and saturation in game my throttle now appears to map and calibrate correctly.

For reference I have included a screenshot of the calibration page adjustments I made to get it to work below.  There may be some fine tuning, but, it looks like a good place to start.  If I can figure it out, I will upload it to the steam workshop in case it could help others.

By way of feedback for codemasters, it shouldn't be this hard.  Several hours after downloading the game and I have yet to turn a lap.  GG.

 

Throttle_Calibration.jpg

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...