Jump to content
  • 0
Sign in to follow this  

F1 2019 Won't launch? [ZX]

Question

Hi,

I've just purchased F1 2019 for PC via Steam.

When I try to run the game, Steam pops up with that "preparing to start game"-dialogue, but from there nothing happens??

I've tried to upgrade my Nvidia-drivers to the latest 430.86, (and also tried disabling Steam-overlay pr. instructions), still no launch, and no error alert?
(Also just tried the 430.64, just to check)
I've even tried uninstalling it and re-downloading/installing it, still no launch!

My PC is running:
Windows 7
i7-3820 3,6 Ghz
16 gb ram
multiple 250 SSD's
680 GTX
Logitech G920

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Hi there,

I've moved this to the F1 Games Technical Assistance forum so that it's in the right place. 

First things first, could you try validating your game files?

  • Open Steam and go to the Library tab.
  • Right click on F1 2019 and select Properties.
  • Go to the Local Files tab and click verify integrity of game files.   

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×