Jump to content
Want to report an issue? Have a bug to report? Please look here first!!!! Read more... ×
Scheduled Updates and BETA Shutdown - 06/07/2020 Read more... ×

Logitech G29 Force feedback not working

Recommended Posts

So i pre-ordered the game on Steam and have played around 60 hours. After like 30 hours, my force feedback on Logitech G29 stopped working.

 

I have tried following things to fix it:

- Reinstalled Logitech Gaming software.

- Deleted drivers of the wheel through device manager and rebooted PC to reinstall them.

- Verified game files on Steam.

- Tried different USB port.

- Tried changing from PS4 mode to PS3 in wheel.

- From in game settings, reseted all to wheel settings to default.

- Tried different setting profile and tried increasing the FFB to 100%.

- Tried both DX11 & DX12 game.

 

And after all of that, it just doesn't work. Everything else on the wheel works correctly (buttons etc). Also my brake pedal is not working correctly, even with a smallest push it goes instantly to 100% so it's basically switch between 0% brake & 100% brake. 

I'm running Windows 10 1809.

 

Share this post


Link to post
Share on other sites
30 minutes ago, Ulma said:

So i pre-ordered the game on Steam and have played around 60 hours. After like 30 hours, my force feedback on Logitech G29 stopped working.

 

I have tried following things to fix it:

- Reinstalled Logitech Gaming software.

- Deleted drivers of the wheel through device manager and rebooted PC to reinstall them.

- Verified game files on Steam.

- Tried different USB port.

- Tried changing from PS4 mode to PS3 in wheel.

- From in game settings, reseted all to wheel settings to default.

- Tried different setting profile and tried increasing the FFB to 100%.

- Tried both DX11 & DX12 game.

 

And after all of that, it just doesn't work. Everything else on the wheel works correctly (buttons etc). Also my brake pedal is not working correctly, even with a smallest push it goes instantly to 100% so it's basically switch between 0% brake & 100% brake. 

I'm running Windows 10 1809.

 

You should only use the wheel in PS3 mode on PC.

Install the latest LGS and reboot. Uninstall using Geek Uninstaller, reboot.

Install LGS again, connect wheel as prompted and then restart, try game.

Share this post


Link to post
Share on other sites
1 hour ago, steviejay69 said:

You should only use the wheel in PS3 mode on PC.

Install the latest LGS and reboot. Uninstall using Geek Uninstaller, reboot.

Install LGS again, connect wheel as prompted and then restart, try game.

Tried it, did not work. I think it's game related issue since i have no issues in other games

  • Agree 1

Share this post


Link to post
Share on other sites
2 minutes ago, Ulma said:

Tried it, did not work. I think it's game related issue since i have no issues in other games

Verify your game files on Steam and try deleting your hardware_settings_config.xml

C:\Users\{Username}\Documents\My Games\F1 2019\hardwaresettings

Share this post


Link to post
Share on other sites
3 hours ago, steviejay69 said:

Verify your game files on Steam and try deleting your hardware_settings_config.xml

C:\Users\{Username}\Documents\My Games\F1 2019\hardwaresettings

Like said in the opening, i've already tried verifying game files. Neither deleting the hardware_settings_config.xml did work.

Share this post


Link to post
Share on other sites

I have a Logitech G29 and when i'm in the straight the car brake a little and all the times that i have the DRS open after a few seconds it close. (because the car brake a little). Do you have the same problem?

Share this post


Link to post
Share on other sites
2 hours ago, F1Alonso14 said:

I have a Logitech G29 and when i'm in the straight the car brake a little and all the times that i have the DRS open after a few seconds it close. (because the car brake a little). Do you have the same problem?

This is normally a dirty potentiometer. Basically you need to defluff your pedals and use a bit of electrical contact cleaner on them. Plenty of YT videos doing pedalset teardowns. You can verify it by looking at the readings in the LGS or possibly the Control Panel properties (sorry, been T300 a while; T300 lets G-pedals do 10-bit res instead of 8-bit and you can see the 'jumpiness' in the Thrustmaster CP).

All you need is a posi-drive screwdriver and a little patience.

If the pots are clean, then look at the mapped keyboard key for 'Brake' or if you have a controller connected (PS4/XB/Joypad) check the mapped button or trigger accordingly.

Share this post


Link to post
Share on other sites

Guys, it cannot be the game. If it was the game, every single user with the same hardware would have the same issue.

Share this post


Link to post
Share on other sites
42 minutes ago, David Greco said:

Guys, it cannot be the game. If it was the game, every single user with the same hardware would have the same issue.

Not an exact truth on PC @David Greco unfortunately. Not everyone has the same hardware apart from the wheel, before you introduce potential software conflicts, driver & OS versioning, etc. 

Share this post


Link to post
Share on other sites

Ok - I have found a solution to the issue - apparently if you have Project CARS 2 installed, and (I think) you use custom FFB files, it alters some registry values which cause this issue in F1 2018.

What I tried first: (none of these helped)

  • Uninstalling and reinstalling Logitech Gaming Software (on latest version), reboots in between.
  • Deleting hardware_settings_config
  • Verifying game files via Steam
  • Resetting all control defaults in F1 2018

What did work was this:

Using RegEdit

Go to HKEY_CURRENT_USER\System\CurrentControlSet\Control\MediaProperties\PrivateProperties\Joystick\OEM\VID_046D&PID_C24F

Check these values, and change if required -  it works for me:

  • OEMName: "Logitech G29 Driving Force Racing Wheel USB" must be instead of "G29 Driving Force Racing Wheel"
  • OEMData: 43 00 08 10 19 00 00 00 must be instead of 00 00 00 10 00 00 00 00 (or any other value)

Reboot your PC, and the FFB wil be back for G29 in F1 2018.

I'm still getting a bit of clipping so would really appreciate some of you posting your G29 settings here for F1 2018, both Logitech Gaming Software and in-game settings.

All the best, Merry Xmas to all

 

Andy

  • Thanks 1

Share this post


Link to post
Share on other sites

When I drive F1 2019 with my G29 from Logitech and Force Feedback, the wheel has Force Feedback on one side. So everytime when there is Force Feedback it turn just to the right. 

I tried to fix it with F1 2019 sterring settings, but this did not helped. I tried it also with G Hub but every time I changed something the sterring wheel was like undrivebal.

So does someone know how to fix this problem?

Share this post


Link to post
Share on other sites
3 hours ago, ahrenslukas10 said:

When I drive F1 2019 with my G29 from Logitech and Force Feedback, the wheel has Force Feedback on one side. So everytime when there is Force Feedback it turn just to the right. 

I tried to fix it with F1 2019 sterring settings, but this did not helped. I tried it also with G Hub but every time I changed something the sterring wheel was like undrivebal.

So does someone know how to fix this problem?

I have merged your post to the Technical section. In this topic you may find a solution to your problem.

Share this post


Link to post
Share on other sites
On 23.12.2019 at 13:10, studsr said:

Ok - Ich habe eine Lösung für das Problem gefunden. Wenn Sie Project CARS 2 installiert haben und (glaube ich) benutzerdefinierte FFB-Dateien verwenden, werden einige Registrierungswerte geändert, die dieses Problem in F1 2018 verursachen.

Was ich zuerst versucht habe: (keines davon hat geholfen)

  • Wenn Sie die Logitech Gaming Software (in der neuesten Version) deinstallieren und neu installieren, werden Sie zwischendurch neu gestartet.
  • Hardware_settings_config löschen
  • Überprüfen von Spieledateien über Steam
  • Zurücksetzen aller Steuerungsstandards in F1 2018

Was funktionierte, war Folgendes:

RegEdit verwenden

Gehen Sie zu HKEY_CURRENT_USER \ System \ CurrentControlSet \ Control \ MediaProperties \ PrivateProperties \ Joystick \ OEM \ VID_046D & PID_C24F.

Überprüfen Sie diese Werte und ändern Sie sie bei Bedarf - es funktioniert bei mir:

  • OEMName: "Logitech G29 Driving Force Rennrad USB" muss anstelle von "G29 Driving Force Rennrad" sein.
  • OEMData: 43 00 08 10 19 00 00 00 muss anstelle von 00 00 00 10 00 00 00 00 (oder einem anderen Wert) sein.

Starten Sie Ihren PC neu und der FFB wird in F1 2018 für G29 zurück sein.

Ich bekomme immer noch ein bisschen Clipping, daher würde ich mich sehr freuen, wenn einige von Ihnen Ihre G29-Einstellungen für F1 2018 hier veröffentlichen, sowohl die Logitech Gaming Software als auch die Einstellungen im Spiel.

Alles Gute, Frohe Weihnachten an alle

 

It is not working for me because everytime I start f1 2019 it calls it G29 Driving Force Racing Wheel back.

 

Share this post


Link to post
Share on other sites

Complete the steps to remove LGS as instructed earlier. Restart.

Use GHub to install the G29, connecting when prompted.

Test in the GHub to confirm correct operation of the wheel, pedals etc., regardless of the name it displays in Windows.

Delete the hardware_settings_config.xml

Launch the game, go into the controller config, delete all custom maps. Set the default map, then edit and save as your own custom map.

Let me know.

Share this post


Link to post
Share on other sites

Patch 1.22 and I have the same problems with the G29 in F1 2019 game. 

The car is simply uncontrollable. It won't stay still in a straight line, turning is completely horrible, the throttle is too sensible even with the FFB settings, and the car seems to have no traction control at all (even with full traction control option). However, when I go to F1 2018, it is 101% more playable and stable. When I put the same FFB settings in the F1 2018 game, the car responds perfectly, but in the F1 2019 game it's impossible.

Share this post


Link to post
Share on other sites
11 hours ago, Brefromace said:

Patch 1.22 and I have the same problems with the G29 in F1 2019 game. 

The car is simply uncontrollable. It won't stay still in a straight line, turning is completely horrible, the throttle is too sensible even with the FFB settings, and the car seems to have no traction control at all (even with full traction control option). However, when I go to F1 2018, it is 101% more playable and stable. When I put the same FFB settings in the F1 2018 game, the car responds perfectly, but in the F1 2019 game it's impossible.

Post your settings so they can be replicated.

Share this post


Link to post
Share on other sites

I have the same problem with my G29.

Neither on PS3 nor PS4 mode working anymore in F1 2019 latest update on steam.
Did all steps mentioned above with regedit and tried with Ghub and LGS.

I have some feedback on the wheel until the own control of the car kicks in in the game. No vibrations or feedback thereafter.

 

Share this post


Link to post
Share on other sites
11 hours ago, xTiMm_ said:

I have the same problem with my G29.

Neither on PS3 nor PS4 mode working anymore in F1 2019 latest update on steam.
Did all steps mentioned above with regedit and tried with Ghub and LGS.

I have some feedback on the wheel until the own control of the car kicks in in the game. No vibrations or feedback thereafter.

This is weird, the opposite problem that plagues the T300. No feedback unless you press the gas and pedal fully and turn the wheel to lock in the pitlane coming out of the garage. In no garage scenarios (like TT) if you hit a wall that can restore full function - or once you make a definite turn (often T1).

Anyway, this is made super hard as I don't have the G29 to test with (I used to have a G920).

Logitech's position is G-HUB is the software to use.

G-HUB and LGS may not co-exist well.

I correct my previous post in this thread. PS4 mode is to be used on PC (PS3 mode is for Thrustmaster wheels).

Here is a video which shows the steps to get G-HUB to recognise the G29. If users would like to try this and feed back it would be great.

So I would say, if you have LGS working fine, leave it.

If you get the pedal switch issue or no gas or no FFB, try this fix with G-HUB.

But it would appear that you either try with LGS OR G-HUB, not both. 

Geek Uninstaller is here. Logitech Wheel Driver Cleaner is here. G-HUB is here. LGS is here. (Install the software, restart, then use Geek to uninstall, restart, reinstall.)

Share this post


Link to post
Share on other sites
On 4/15/2020 at 4:20 AM, steviejay69 said:

Post your settings so they can be replicated.

I solved most of my problems, but the steering is still a little bit difficult.

Share this post


Link to post
Share on other sites
On 5/10/2020 at 12:34 PM, xTiMm_ said:

I have the same problem with my G29.

Neither on PS3 nor PS4 mode working anymore in F1 2019 latest update on steam.
Did all steps mentioned above with regedit and tried with Ghub and LGS.

I have some feedback on the wheel until the own control of the car kicks in in the game. No vibrations or feedback thereafter.

 

Exact same problem, 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×