Jump to content

Crew / Public performance issue

Recommended Posts

This problem has not been solved since the first version of the game. When you turn on high or ultra quality for the audience, the performance drops drastically in areas where there are many viewers, even with a good device such as an i7-8086k along with 32GB of memory, 1TB of NVME and a GTX 1080Ti. It happens even playing at 1080p. If we lower the quality of the spectators, the performance improves substantially. Please, fix it. Thank you.

image.png

image.png

image.png

image.png

image.png

image.png

image.png

image.png

image.png

image.png

  • Agree 1

Share this post


Link to post
Share on other sites
2 minutes ago, petersamelian said:

This problem has not been solved since the first version of the game. When you turn on high or ultra quality for the audience, the performance drops drastically in areas where there are many viewers, even with a good device such as an i7-8086k along with 32GB of memory, 1TB of NVME and a GTX 1080Ti. It happens even playing at 1080p. If we lower the quality of the spectators, the performance improves substantially. Please, fix it. Thank you.

 

Share this post


Link to post
Share on other sites

CM should add a radio button to Graphics menu to switch off completely to remove spectators from scenes to improve FPS or let players decide to use spectators with ON option

 

Share this post


Link to post
Share on other sites

I recall one of the developers noting this issue and that it seemed to be a definite bug (specifically with Nvidia cards IIRC) because it was hitting FPS way harder than on AMD cards. No idea what happened to fixing that at this point, though.

For reference, I have an overclocked 9900k and 2080 Ti (essentially a top of the line system) and I have to drop my spectator setting to medium to keep framerates high. Argentina has always been really bad in those areas that wind through a ton of spectators (on my PC, spectators on ultra combined with night driving drops my frames down to like the 40s... when it's otherwise 100+ fps.) Germany is also extremely bad in a few areas. It just goes from butter smooth to BAM, dropping framerate in half or more, and that's with medium spectator setting.

Share this post


Link to post
Share on other sites
19 hours ago, RallyLover19 said:

CM should add a radio button to Graphics menu to switch off completely to remove spectators from scenes to improve FPS or let players decide to use spectators with ON option

 

Hi @RallyLover19 you can actually do this by changing the Crowd setting to "Off" if you are on PC.

  • Like 1

Share this post


Link to post
Share on other sites

I think it's the crowd shadows that get turned on from medium and up that really hurt the performance.

  • Like 1

Share this post


Link to post
Share on other sites
On 7/9/2019 at 10:42 AM, chukonu said:

I think it's the crowd shadows that get turned on from medium and up that really hurt the performance.

Yess, agreed, but CM must solve the issue, cuz there are many users like me, thatwe  have a really powerfull machine for run our games in ultra or even high settings, and spectator settings ruines the game experience. I play with V-Sync with a 1080ti and in some areas, the fps drops from 60 to 38 ... that is crazy CM.

Share this post


Link to post
Share on other sites

Trees seem to have a similar issue. It's probably an interplay between trees, crowd and shadow settings but I haven't found a good combo yet. Turning down shadows isn't enough to solve the sudden drops and makes the game look dramatically worse so that isn't a real solution.

For now I have turned the crowd to 'low' so the world doesn't look entirely lifeless, trees on 'high' since there seems to be no impact between 'low', 'medium', 'high' fps-wise but I'm not very sure. My shadows are on 'ultra' but I've turned off the particle shadows in the config file. The FPS hovers around 60 which is my intention, but drops to around 40 in some situations. Performance isn't consistent across locations and weather unfortunately.

  • Agree 1

Share this post


Link to post
Share on other sites
9 hours ago, petersamelian said:

Yess, agreed, but CM must solve the issue, cuz there are many users like me, thatwe  have a really powerfull machine for run our games in ultra or even high settings, and spectator settings ruines the game experience. I play with V-Sync with a 1080ti and in some areas, the fps drops from 60 to 38 ... that is crazy CM.

While you may be right that crowds hurt your system, if you're dropping into the 30's or even being limited to 60fps you are doing something wrong.

 

My system is a 3770k, 16gb DDR3 @ 1600mhz, 1080ti - all powering a 3440x1440p @ 100hz 

 

Running crowds on medium or high I never drop below 90fps  except for the initial 10-20 seconds of Argentina where I might see drops into the 80s. After that I notice it isn't buttery smooth at 120fps like it is for most stages, but I never get anywhere close to 60fps. 

Share this post


Link to post
Share on other sites

Hi, I like to play at 1080p and 60 fps cuz my screen hasn´t freesync or gsync. Then I activate V-sync in settings and in some stages like Argentina or Germany, the fps drops from 60 to 50 easily with settings in Ultra except shadows that are in high and public are in high also. And... sometimes, for only a second, the game seems to be freeze with the las update (1.6) but it suddenly runs normally after that second. It happens once in 2~3 hours of gaming. Never happeed with other game or editing time, only with Dirt Rally 2.0.

I have an intel Core i7-8086k, 32GB DDR4 @ 3200Mhz, 1TB NVMe and a Zotac GTX1080 Ti AMP Extreme. More than enough for run Dirt Rally in constantly 60fps.

Also I have custom watercooling system, then my temps are really excelent. No temps issues.

Share this post


Link to post
Share on other sites
On 7/11/2019 at 7:59 PM, Mike Dee said:

While you may be right that crowds hurt your system, if you're dropping into the 30's or even being limited to 60fps you are doing something wrong.

 

My system is a 3770k, 16gb DDR3 @ 1600mhz, 1080ti - all powering a 3440x1440p @ 100hz 

 

Running crowds on medium or high I never drop below 90fps  except for the initial 10-20 seconds of Argentina where I might see drops into the 80s. After that I notice it isn't buttery smooth at 120fps like it is for most stages, but I never get anywhere close to 60fps. 

If I do not activate the vertical synchronization, I have more than 150 fps and I never drops below 80~90fps but if you activate V-Sync as I like to configure it, this is when these fps drops occur.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×