Jump to content
  • 0

DiRT Rally 2.0, Version 1.6: Bug Reporting Thread

Question

IMPORTANT: Read and understand this entire opening post before replying, as providing the right amount of detail will help out the team immensely in tracking and resolving any bugs that arise, thanks.

 

DR2_Lancia_DeltaS4 (3).jpg

 

Hello everyone.

Version 1.6 of DiRT Rally 2.0 is available now and contains a number of features and bug fixes based on community feedback. The full patch notes can be found here:

 

The DiRT team is always on the look-out for any bugs or issues that arise as a result of updates, so if you have come across any please post them in here. Your contributions to previous threads have been very useful in helping the team plan not only for version 1.6 but additional updates in the future.

 

Before posting, please make sure to follow these guidelines. Without adequate information the team will have trouble identifying and fixing bugs, so please provide as much info as you can:

  • Check if a bug has already been reported.
  • If a bug has been reported and you are experiencing the same issue, hit the image.png icon.
  • The more popular bug posts will have a better chance of catching the attention of the team.
  • If a bug cannot be reproduced, it cannot be fixed.
  • When you experience a bug, please try to trigger said bug again if you can, and show us the steps you went through to trigger it.
  • Text steps are good, video even better.
  • One post per bug (or one bug per post, to put it another way) please, for our tracking purposes. That way every bug gets its own URL for us to investigate.

 

Please also provide the following:

  • What platform you're playing on.
  • What your PC setup/build is like (if playing on Steam).
  • Whether you're a Standard or Deluxe user.
  • Whether or not you have any non-standard peripherals connected, like steering wheels, gaming mice etc.
  • Like 8
  • Thanks 1
  • Agree 2

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0
Posted (edited)
On 7/9/2019 at 12:52 PM, Riggs said:

 

HIGH

  1. A pacenote is missing in one of the Germany stages, "over crest, turn left", the "turn left isn't said. ( https://forums.codemasters.com/topic/37295-dirt-rally-20-v14-found-a-bug-post-it-here-update-v141/?do=findComment&comment=427767 ) NOTE: Confirmed in v1.6. https://forums.codemasters.com/topic/38591-dirt-rally-20-version-15-bug-reporting-thread/?do=findComment&comment=432147 )
  2. Spanish co-driver call is incorrect in Poland stage "Lejno" and "Zienki". Should say "izquierda uno" (left one) and not "derecha uno" (right one) ( https://forums.codemasters.com/topic/36317-dirt-rally-20-v13-found-a-bug-post-it-here/?do=findComment&comment=415733 ) NOTE: Needs confirmation in v1.6.

 

the bug in the spanish codriver still stay there in poland(lejno and zienki) after the 1.6, confirmed

Edited by elrojodp8

Share this post


Link to post
Share on other sites
  • 0

i found a 'bug' - the 2000cc Ford Focus still doesn't have a proper livery :classic_tongue:

even just a decent fake one would be good.

  • Like 1
  • Agree 1

Share this post


Link to post
Share on other sites
  • 0

On Xbox one x deluxe edition the Evo x has a manual gearbox and should be sequential and the Audi Quattro has a sequential gearbox when it should be manual   

Share this post


Link to post
Share on other sites
  • 0

On Xbox one x using thrustmaster tx the Audi Quattro, Sierra cosworth and escort cosworth have the wrong soft lock!! All 3 cars I’ve mentioned should be 720 yet they are 900

Share this post


Link to post
Share on other sites
  • 0

The setup bug in clubs is still there. Setup resets to default after one stage.

  • Like 2
  • Agree 1

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)
  • What platform you're playing on. 
  • - Steam, PC
  • What your PC setup/build is like (if playing on Steam).
  • - i7, 16GB RAM, GTX 750Ti 
  • Whether you're a Standard or Deluxe user.
  • - Deluxe
  • Whether or not you have any non-standard peripherals connected, like steering wheels, gaming mice etc.
  • - No

Bug:

In Bikernieki, Latvia the grids are the wrong way round, getting first place in a heat race will put you on the outside for the next heat race instead of the inside

Edit: The semi's and finals are correct however

Edited by MattyH1812

Share this post


Link to post
Share on other sites
  • 0

• PC, Steam user.
• Windows 7 professional 64 bit, Intel Core i5-3450 3.10 GHz, 12 GB RAM, Nvidia GeForce GTX 1060 3GB.
• Deluxe user.
• OSW Simucube (steering wheel), Fanatec CSS SQ 1.5 (Shifter), BU0836-LC Interface (Pedals), BU0836A Interface (Handbrake).

Bug:

Ford rs200 Evolution RX has the speedometer on board that doesn't work.

 

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

• PC, Steam user.
• Windows 7 professional 64 bit, Intel Core i5-3450 3.10 GHz, 12 GB RAM, Nvidia GeForce GTX 1060 3GB.
• Deluxe user.
• OSW Simucube (steering wheel), Fanatec CSS SQ 1.5 (Shifter), BU0836-LC Interface (Pedals), BU0836A Interface (Handbrake).

Bug:

Motor option #05 and #06 of Peugeot 205 T16 RX are wrong and inverted.

IMG_20190710_202125.jpg

IMG_20190710_202114.jpg

Edited by Deltone91
  • Like 3
  • Agree 1

Share this post


Link to post
Share on other sites
  • 0

PS4 Standard - Deluxe Version

I'm still getting this black flickering...

This one's taken from gameplay recording in a Club Event in  Viñedos Dardenyà inversa - Spain but it happens in other stages too.

I think it's mentioned on the current list for x-box but not PS4 and I've mentioned it a few times over the past versions bug threads.

Now, is it a bug? I think so - But since the statement made about if you're getting graphics issues with a std PS4 it won't be fixed, in the Roadbook June 28 I'm not too sure.

Could someone clarify...

Cheers

Jim 🙂

Thumb_Shot00019.jpg

  • Like 1
  • Thanks 1
  • Agree 1

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

Ps4, deluxe, portuguese version. The Subaru WRX STI nr4 is stated as having a 5 speed manual sequential gearbox, but when playing with "h+clutch or sequential" option, it has a H gearbox.

Edited by Opassac

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

German pace note error on Ascension bosque Montverd (PC version, 1.6)

In the second section the co-pilote says »Macht zu bei Mast« (tightens at mast/pylon), but there is no mast. I assume the pole is meant, but in German this a »Pfosten« while a »Mast« is something bigger for power cables for example.

pace-note-error.png

Edited by cirad

Share this post


Link to post
Share on other sites
  • 0

Silly save dialog (PC version, 1.6)

If you want to leave an event, you will get a warning message that unsaved progress will be lost. You cannot save your progress, so this message dialog does not make any sense.

Share this post


Link to post
Share on other sites
  • 0

Major graphic bug, especially in Spain on wet tarmac (PC version, 1.6, Windows 10 with Geforce, tested with 1080 Nvidia drivers 430.64 and 431.36; the bug already existed in 1.5)

From trees, bushes, stones, objects, white boxes are displayed downwards on the street. It’s obvious for a single tree, but most annoying for bushes, limbs, stones and grass on the roadside.

graphicbug1.png

graphicbug2.png

graphicbug3.png

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Hi everyone, since I have seen no fixed remarks or any updates regarding the adaptable trophy on PS4, I would like to bring up this problem once again.

After meeting the requirements for unlocking the trophy, it is not popping for me after finishing the events in all different weather conditions.

 

  • What platform you're playing on: PS4
  • Whether you're a Standard or Deluxe user: Deluxe owner
  • Whether or not you have any non-standard peripherals connected, like steering wheels, gaming mice etc: no, just regular equipment

It is the last trophy I need for platinum. 

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

Spare wheel doesn't work. You take it and can't change it after puncture.

Five months after release game have critical bugs in main features which destroy gameplay. In such expensive game.

This is UNACCEPTABLE,

 

Edited by Fanatyk91
grammar
  • Disagree 1

Share this post


Link to post
Share on other sites
  • 0

You mean you can't change the wheel?

No problems here, I'd say your attitude is unacceptable as you assume everyone has the issue.

  • Disagree 1

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

BUG:

When in cockpit view, with automatic windscreen wipers turned OFF, the wipers turn on at random points of the stage (sometimes straight after launch). It is incredibly distracting when trying to concentrate on the stage. I'm aware a workaround is to hold down the wiper button, but if a stage starts off very challenging, you often don't have time to do that (and shouldn't have to either as auto wipers off was already selected). This bug has been there since day 1 and i'm wondering if its been forgotten about. @PJTierney is anyone working on a fix for this?

PS4. Deluxe edition. G29 wheel. 

Edited by A-M-A-R-85
  • Like 4
  • Agree 1

Share this post


Link to post
Share on other sites
  • 0
4 hours ago, Fanatyk91 said:

Spare wheel doesn't work. You take it and can't change it after puncture.

Five months after release game have critical bugs in main features which destroy gameplay. In such expensive game.

This is UNACCEPTABLE,

 

I assume this problem is with Time Attack only? If so, I think it is the way it's meant to be, since times on Time Attack are uploaded to the server, thus stopping to repair a puncture would be "useless" for that mode.

If the problem is present in another game modes, well, it is the first time I hear about it, honestly.

Share this post


Link to post
Share on other sites
  • 0

PC steam. Windows 7. Deluxe edition.

Renault 5 turbo gearbox behaviour mismatch.

Behaves as sequential when using setting "manual H-pattern with clutch or manual sequential", but it's displayed as "manual" without sequential i.e. H-pattern in Garage. Driver animation and cockpit is also consistent with 3 pedal H-pattern controls.

Share this post


Link to post
Share on other sites
  • 0
10 hours ago, F2CMaDMaXX said:

I'd say your attitude is unacceptable as you assume everyone has the issue.

Yes, I have special build only for me, so nobody else have this issue. Yes, bugged repairs on the route are completly related to my hardware so person with different set of OS, CPU, GPU and RAM don't have this issue for sure. How many hours have you spent in this game since you are so impudence to tell me there is problem with my game only? There should be IQ tests to pass during registration.

 

8 hours ago, AyrtJ97 said:

I assume this problem is with Time Attack only?

 

No, problem exists for sure in clubs and rally championships (first option in section where are community challenges, I don't use english version so I don't know how they called it).

However, I presume this bug occurs in every gamemode where spare wheel option exists.

You are at service area before 1st stage and you take spare wheel. You finish 1st stage without puncture. On next stage without service area you get pucture and there is not option to change wheel. If you finish this stage with puncture and 3rd stage is also without service are, you will start this stage with pucture.

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)
4 hours ago, KoAStR said:

PC steam. Windows 7. Deluxe edition.

Renault 5 turbo gearbox behaviour mismatch.

Behaves as sequential when using setting "manual H-pattern with clutch or manual sequential", but it's displayed as "manual" without sequential i.e. H-pattern in Garage. Driver animation and cockpit is also consistent with 3 pedal H-pattern controls.

Similar situation with Peugeot 205 T16 Evo 2 RX Group B.

Described as "manual" in Garage. Input behaves as "manual sequential". 

Cockpit animation and other sources suggest it should be described as sequential.

Edited by KoAStR
BTW thanks alot for adding this much requested inputs setting! 🙏. Actually prefer this car as manual with clutch because sequential mode doesn't simulate flat shifting so boost drops.

Share this post


Link to post
Share on other sites
  • 0
15 hours ago, Fanatyk91 said:

There should be IQ tests to pass during registration.

However, I presume this bug occurs in every gamemode where spare wheel option exists.

You are at service area before 1st stage and you take spare wheel. You finish 1st stage without puncture. On next stage without service area you get pucture and there is not option to change wheel. If you finish this stage with puncture and 3rd stage is also without service are, you will start this stage with pucture.

There is a test, i don't know how you got in 😉

 

I can tell you that your first issue was with presuming anything.  As i said, you're the only one reporting this issue right now, so as unlikely as it seems, there is more likely to be something going on at your end.

I can confirm it's been running fine on my end, including the issue with 3 punctures with the 037 the other night... 😄 

  • Disagree 1

Share this post


Link to post
Share on other sites
  • 0
18 hours ago, KoAStR said:

Similar situation with Peugeot 205 T16 Evo 2 RX Group B.

Described as "manual" in Garage. Input behaves as "manual sequential". 

Cockpit animation and other sources suggest it should be described as sequential.

Same again with non RX version of the Peugeot 205. This one was definitely manual h-pattern in DR1 so not sure which is correct but description is mismatched.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×