Jump to content
  • 0
Sign in to follow this  

Throttle stuck at 100% (mapping Z-)

Question

Posted (edited)

Logitech G920 and the throttle is stuck at 100%. At first I thought my pedal was broken so I switched to PC2 and it works just fine there. I went back to F1 2019 and tried calibrating the throttle and it changed it from the pedal to Z- whatever that is. The brake and clutch pedals work just fine on this game and other games.

What I think happened was I was playing F1 last night, then switched to PC2 for a few races but had to reassign the throttle because the car wouldn't go, then today switched back to F1 and now the throttle is stuck wide open

I have tried unplugging the wheel and restarting computer. I also tried waiting until the game launched to plug in wheel. I tried creating a profile in logitech gaming software for this game. I have also uninstalled and reinstalled LGS and Nvidia experience. I also uninstalled PC2. None of these has worked. Any advice?

Edited by AFreakinEggo

Share this post


Link to post
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×