Jump to content Jump to content

F1 2014 - Won't launch on steam

Recommended Posts

Hi there,

Just bought the game yesterday, I know it's a little late with F1 2015 coming soon. The problem i'm facing is that it will not launch when I press the start button in Steam. It just gives me the message ''preparing f1 2014 to start'' and when it fades away there is a quick message ''synchronizing''. Further it does nothing. My OS is Windows 8.1. Someone has a solution for this problem? I just checked the internet and I can see that there are a lot of people facing this problem, but no solution?


Link to post
Share on other sites
  • 3 weeks later...
  • 4 weeks later...

I have the exact same problem. I have done all the update, .net, visual studio x86 x64 etc and still nothing. I get the error "The application was unable to start correctly (0xc000007b). Click ok to close the application".

I also can not get Dirt 3 to load from steam either.

I might as well burn my money as this is stupid. Please can someone help?

My OS is Windows 8.1 64 bit.

Link to post
Share on other sites
  • 1 year later...
i got the same exact problem with F1 2015.
Error 0xc000007b

It happened all of a sudden, the game worked "fine" for a year. I don't know what might have changed on my system but i tried everything i could. Followed every single guide on the internet i found but nothing. The only option i got left is a full format, but i'm not going to do something like that because one game (out of all the others i have installed, F1 2013 included) refuses to run.

PS: This problem is not related to Steam in any way
Link to post
Share on other sites
I finally fixed it.
So the problem in my case was a 32bit dll placed inside the windows\system32 folder (which should contain 64bit files only). The file name is not important since it may differ from case to case (but if you really want to know it was d3dcompiler_43.dll).
I used Dependency Walker to find out this problem, it's a very simple and free utility.

These are the steps to follow:

-Download Dependency Walker from here: http://www.dependencywalker.com/
-From D.W. hit open-> F1_2015.exe (locate it inside your installation folder)
-If the error message "Error: Modules with different CPU types were found." appears then you have the same problem.
-Scroll the list in the middle of the screen and look for the "CPU" column values, if something is highlighted in red, locate the corresponding file and replace it with the correct version.

In my case, since d3dcompiler_43.dll is a Directx file, i simply deleted it and ran the directx web setup to automatically reinstall it. Now i can finally play again :)

Hope this helps

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...