Jump to content

[PC][General] My Game Keeps Crashing

Recommended Posts

IDK what's going on, but it seems no matter if I run the game in DX11 or DX12 my game is going to crash. I've had it give me the Ego report box in DX12, was informed by other drivers to stop using DX12. Went to DX11. First time the game crashed with no further dialog boxes. Second time I got a D3D Device Removed error. Third time I got another Ego box.

I'm getting tired of trying to play career mode to have the game decide it wants to implode on me. I also don't want to be in the middle of an online race and the game can't handle itself. I can't even run it for longer than 15 minutes at a time without something going wrong. Why is this still an issue up until now?

  • Platform you’re on: PC
  • Game Version: 1.05
  • Game Mode:
    • Crash 1, 3, and 4: Career
    • Crash 2: Multiplayer, Friends only
  • If in Multiplayer, how many players and how many AI?: (Applies to DX11, 1 only) There were about 7 or 8 of us in a friends only lobby, no AI.
  • What happened in the lead up to the problem?:
    • First crash (DX12): Finished a practice program around Australia in practice, entered the pits, game died before I reached the pit limiter line and gave me an Ego Error report box.
    • Second crash (DX11, 1): In the middle of a qualifying lap around Silverstone with around 3 minutes to go, entering the second half of Maggots and Becketts the game just quit. No error boxes, no dialog boxes, no warnings. Just quit to Steam client. A crash dump file does not exist for this crash.
    • Third crash (DX11, 2): Coming out of the last corner of Bahrain to start the track acclimatization program (FP1), game just crashed with a D3D Device Removed error. A crash dump does not exist for this crash either.
    • Fourth crash (DX11, 3): Going into the pits in Bahrain after finishing the qualifying pace program (FP2). Reached the first hairpin in sector 2, game crashed with an Ego Error report box.
  • If you get an error message, the exact wording of the error message you're receiving:
    • Crash 1 and 4: "Your game has crashed"
    • Crash 2: No error/warning dialog
    • Crash 3: "D3D Device Removed"
  • Any accessories you are using (wheel, pad, etc): T150 with T3PA pedals
  • PC specs:
    • Ryzen 5 2600
    • 500 GB SSD (Game Installed here) + 1 TB HDD
    • EVGA Nvidia Geforce GTX 1660 Ti
    • 16 GB RAM (Overclocked to 2933 MHz)

If needed I can provide the crash dumps that do exist. I also verified the game integrity and Steam came up with nothing. What do I do here exactly?

Share this post


Link to post
Share on other sites

Solution found. Use Display Driver Uninstaller to remove drivers and then reinstall 431.36. I haven't had issues thus far.

  • Agree 1

Share this post


Link to post
Share on other sites

There is something strange then, maybe specific to a GPU implementation. I have a Gigabyte GeForce 2080 and the gate will not even start in DX12

Share this post


Link to post
Share on other sites
On 7/22/2019 at 7:11 PM, Taiecosell said:

Sabba, is your system running ok in DX12 now as well?

Haven't been around in a while but let's put it this way: I'm crashing during critical moments of a league race now. IDK what's going on but I'm going to have to try to figure this out.

Also don't use DX11 or you'll get D3D Device Removed errors. I find it excruciatingly frustrating when they're like "Use DX11" and I use it and the game breaks, "Okay well try x and use DX12" and I do that and the game either alt +f4s on me out of nowhere or I get a different crash error. IDK what to do at this point.

Share this post


Link to post
Share on other sites

It's a combination of several possibilities.

You need to look at PSU, AM4 platform initialization updates, UEFI uCode and memory / SSD compatibility updates (particularly if RAM is XMP rated, an Intel spec.)

If you have a 1070 or higher, you should be running a 550W 80+ certified PSU minimum, if you use a lot of USB devices or drives, you should aim higher.

Drivers, you need to be running W10 1803 minimum to run newer DX12 drivers. DX11 is really for W7.

All properly installed and updated W10 installations should use DX12. DDU your drivers and reinstall them if you have a crash. DX11 should work on W10 if it works on W7. If your system is misconfigured, it won't work that way either.

AMDs drivers are more stable than NVIDIAs (they seem intent on wrangling RTX/SUPER/16xx rather than optimising legacy product, yes that's 10xx and below).

I can't comment on Vega or RX 57xx as I don't think there's anyone using them here....

There are game bugs, but a lot of the problems here are misconfigured (not updated or badly updated/upgraded, crufted) machines.

 

Share this post


Link to post
Share on other sites

Hi All, just to round out my part of the thread. Nvidia released a new driver a week or so ago. I installed the driver using their tools (which uninstalled the original driver), and hey presto, the game runs really well in DX12!!!  There was nothing in the release notes that related to game crashes so I suspect that the simple act of reinstalling the driver using the Nvidia tools did the trick.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×