Jump to content

Archived

This topic is now archived and is closed to further replies.

Heading into season 4, no sign of SC

Recommended Posts

I’m in season 3 career mode, Abu Dhabi. And yet I’ve never seen a safety car yet and only one VSC on season 1. Totally untralistic

Share this post


Link to post
Share on other sites

WOW! after 3 Seasons???

Yeah, something is very wrong with that, but this Safety Car issue has been well documented at this Forum, so hopefully a fix will happen soon.

I'm halfway through Season 2 (100% Race Distance), and I've never seen the Safety Car deployed 😧

Share this post


Link to post
Share on other sites

I've had it once in my first season at Hockenheim although i did cause it to come out ( and then handily benefit from it afterwards )

Share this post


Link to post
Share on other sites

Had same issue till patch 1.5 reinstalled game started a new game and did get the sc a few times . Rember last years game every time a patch came out I would iether have a sc in game till the next patch then I wouldent have it again till another patch came out . It was wierd as the majority of patches didnt have anything to do with sc . It was a wierd one . Thinking its something to do with the game installs the files or something like that 

Share this post


Link to post
Share on other sites

I restarted my career in 1.05 and I'm now getting vsc's. I didnt have anything in my launch career of 2 seasons. 

Share this post


Link to post
Share on other sites
1 hour ago, SASColfer said:

I restarted my career in 1.05 and I'm now getting vsc's. I didnt have anything in my launch career of 2 seasons. 

Do any given patch fixes, changes or balances only take effect when starting a new career? 

Share this post


Link to post
Share on other sites
1 hour ago, NigelWeber said:

Do any given patch fixes, changes or balances only take effect when starting a new career? 

It's not supposed to but apparently has some effect. One thing that I remember is that for my first career I started it with the option for safety car off and changed it later on whereas my new one I made sure it was on. Dont know if that was the issue 

Share this post


Link to post
Share on other sites

×