Jump to content
DIRT 5 - Chat about the game and get support here. Read more... ×

Archived

This topic is now archived and is closed to further replies.

DiRT Rally 2.0: Version 1.7 VR Feedback

Recommended Posts

Hi I am having issues with the night stages. Running on Oculus with an Oculus headset.  Intel i7-9700K @ 3.6GHz processor. GeForce RTX 2080.  The shadows and night sky don't look right.  Any fixes? Setting recommendations?

OculusScreenshot1565655558.jpeg

Share this post


Link to post
Share on other sites
On 8/14/2019 at 2:29 PM, Ialyrn said:

Steam version keeps forcing the Oculus rift to activate ASW, even when hitting a constant 90fps in game. This is adding to the stuttering situation. To get around it, I have to use Oculus Tray Tool to turn ASW off.

I tried that, didn't make any noticeable difference at all for me.

Share this post


Link to post
Share on other sites

I am getting an annoying graphical glitch around trees and shrubs and it makes the scenery seemingly glitter when things are in motion. Its very distracting.  I have messed with all kinds of settings and can't seem to get it to go away.  Shadows and shaders at all levels or off multisampling at all levels or off, nothing seem to help.  I am using Oculus Rift S on Oculus platform with an Intel i7-9700K 3.60 GHz cpu with 32G RAM and a GeForce RTX 2080 graphics card.  I have a Fanatec steering wheel, shifter and pedals.

this is a photo from someone else, but shows exactly what I am getting. this was likely not VR but it is the same graphical glitch.  I am having trouble getting a good screen capture since the effect seems to go away when there is no motion.  Is there any way to make this go away?

 

1985636391_dirtrally2-2019-03-04-21-37-30-121.thumb.png.fb13099539072acdfb5e2bcf1d528fc4.png

Share this post


Link to post
Share on other sites
13 hours ago, Dytut said:

...

I'm getting heavy stuttering in game in the HMD, as if the tracking is completely out of whack. Framerates seem to be OK, been running really low settings to eliminate that.

Stutters are especially noticeable when looking around to the sides, when I do really small movements (I.E. looking straight forward on a long straight) the tracking seems solid, but any larger movements (going from straight forward to looking through the side window for example) causes the view in the HMD to stutter like hell, making playing it vomit inducing.

If I look at the monitor render of the game it doesn't look like it stutters at all, so it appears to be something that happens with the projection onto the HMD display rather than a tracking error in the headset

....

Yeah, good explanation. I've been finding it really hard to describe, and I've not seen anything like this before in other VR games...

When performance is an issue, I usually prefer driving games at 45fps with constant ASW, rather than turning everything down to try to hit 90fps but then having occasional judders if ASW kicks in.

But one odd thing I found while troubleshooting DR2.0 stuttering... I tried disabling ASW completely with the Rift (CTRL+1, or you could use the Oculus tray tool), and the framerate went over 45fps (as you would expect)... perhaps anywhere between 50-90fps for me, depending on my settings, I don't remember exactly. But there was that same constant "shuddering" of the head tracking as you move your head around (as you described above). It's almost like really poor tracking, or perhaps some sort of conflict between two things trying to set the view position/direction at the same time & stepping on each other's toes, sort of jumping backwards & forwards in time by a few frames' worth of head movement. This is not what I've experienced in other VR games when I disable ASW, even if the framerate can't maintain 90fps... usually it would of course get a little choppy (so of course I'd usually leave ASW on), but I don't recall games having this weird constant jittery view.

I wonder if Oculus ASW might be masking this jittery head tracking when it's enabled, or perhaps the game/SteamVR keeps accidentally force-toggling ASW even when I think it's disabled, as I saw someone else suggest (each time ASW turns on/off there's always a slight judder in every game, so I guess if that were happening constantly it could explain what we're seeing).

For anyone with Oculus & DR2.0 on SteamVR, try pressing "CTRL + Numpad 1" to completely disable ASW while in the car in VR, and then repeatedly shake your head left/right... perhaps other people out there get the same result... something's definitely not right with all that shaking that I'm seeing in the way the view moves, even with all the settings on the lowest & getting a good/consistent framerate.

Share this post


Link to post
Share on other sites
On 8/9/2019 at 8:48 AM, IISargeII said:

Hi,

Over the last day or so, I've been trying to figure out why the game is seemingly lagging when looking around in VR. My framerate is fine; steamvr is set to run at 90hz, and the game is holding a solid 90fps on medium to high settings. CPU usage is around 50 to 60%. As soon as the view changes from 2d in the cut scenes, to vr, I look around and the lag makes me feel quite ill. It's as if you look left or look right, and the screen movement is slightly behind or at times, the screen moves with you. This problem exists regardless of graphics settings, from ultra low to high. 

The problem is also noticeable when you pause the game. If you look at the menu and turn your head left and right, the menu partially moves with you to a degree. At first I thought the fov settings were wrong, but there's no way of changing it in VR that I could find. The option for fov does exist within the 2d mode, but changing it in that mode has no baring on the vr mode. 

While I'm at it, the view reset doesn't seem to work properly neither, it always sets me in a position that is too far away from the steering wheel... leading me to think that there is indeed problems with the fov. Whether this is the reason for the laggy feeling I get when looking around, I don't know. My pc specs are below. Thanks for your time.


Platform: Steam VR/Open VR
HMD: Valve Index
PC: RTX 2080ti, i7 6700, 32gb RAM
Deluxe User
Connected: Accuforce Steering Wheel, Heusinkveld Pedals, Handbrake and Shifter

I'm having the exact same problem, the game is lagging when looking around and my framerate is fine.

Platform: Steam VR/Open VR
HMD: Rift CV1
PC: GTX 1080, R5 3600, 16gb RAM
Deluxe User
Connected: Fanatec Csl Elite Wheel and Pedals, Logitech Shifter.

 

Share this post


Link to post
Share on other sites


I got it to be at least more playable last night even with somewhat high settings by going into task manager and changing the priority to REAL TIME for the Dirt Rally 2 task and Steam tasks as well.

Stillllllll, it's really disappointing that we have to go through all those hoops to get somewhat good performance and somewhat good graphics even on higher end systems because we are using Steam while ppl running Oculus are not experiencing those performance issues.

Just give us a way to launch in Oculus mode for us that bought in Steam and thts solved, just like Dirt Rally "1" and a bunch of other games have. Also a way to launch no vr. PLEASE!!!
 

Share this post


Link to post
Share on other sites

Guys I found the main problem with the 1-2 sec constantly lagging in vr even if you're using the lowest settings. (I tested steam version with vive)

If you have ANY usb controller device connecting to your pc what the game can recognise (use) Wheel, shifter, handbrake) the game will be lagging even if you doesn't use it.  If you have 3 three devices your lagging will be multiplied.

You can try  this even if you are playing, just disconnect the devices the game will be flowing. The xbox controller doesn't affect this. You can use it anytime.

So If you using with xbox controller, and other devices are connected, the game will be stuttering in vr.

I' didnt experienced this bug in dirt rally 1. 

So C'mon codemasters DO you job, fix this! I dont want to play a racing game without a wheel.

 

 

 

Share this post


Link to post
Share on other sites
On 8/9/2019 at 12:48 PM, IISargeII said:

Hi,

Over the last day or so, I've been trying to figure out why the game is seemingly lagging when looking around in VR. My framerate is fine; steamvr is set to run at 90hz, and the game is holding a solid 90fps on medium to high settings. CPU usage is around 50 to 60%. As soon as the view changes from 2d in the cut scenes, to vr, I look around and the lag makes me feel quite ill. It's as if you look left or look right, and the screen movement is slightly behind or at times, the screen moves with you. This problem exists regardless of graphics settings, from ultra low to high. 

The problem is also noticeable when you pause the game. If you look at the menu and turn your head left and right, the menu partially moves with you to a degree. At first I thought the fov settings were wrong, but there's no way of changing it in VR that I could find. The option for fov does exist within the 2d mode, but changing it in that mode has no baring on the vr mode. 

While I'm at it, the view reset doesn't seem to work properly neither, it always sets me in a position that is too far away from the steering wheel... leading me to think that there is indeed problems with the fov. Whether this is the reason for the laggy feeling I get when looking around, I don't know. My pc specs are below. Thanks for your time.


Platform: Steam VR/Open VR
HMD: Valve Index
PC: RTX 2080ti, i7 6700, 32gb RAM
Deluxe User
Connected: Accuforce Steering Wheel, Heusinkveld Pedals, Handbrake and Shifter

 

Yes i agree - I have a Valve Index, 2070 Super, OSW, Fanatec shifter. 
The FOV is definitely too small, the world and car feels shrunk down completely. It just isn't right. Feels like i'm sat in a toy car. 

I also experience the weird laggyness too. 

Share this post


Link to post
Share on other sites
On 8/10/2019 at 2:28 AM, deadsunrise said:

I've been testing a ton of combinations for about 5 hours with a Valve index, i9-9600k, rtx2080ti. All drivers updated for the wheel (TMX), headset, controllers, base stations and GPU/OS. I usually play with settings as ultra at 4k. 

Something is seriously broken in the OpenVR release.

Using the SteamVR beta doesn't work at all - black screen.

With the stable SteamVR release, After the second DR2 ~1.2Gb update, the game launches correctly as a seated game.  I've tried 90Hz, 120, 144. 100% resolution (150% resolution as suggested by steamvr). There's still a ton of problems. 

 

The juddering has something to do with steamVR's chaperone system. My driving rig is just outside the chaperone boundaries and every couple of seconds I can see steamVR trying to get the chaperone view to come through. Reseting the room and removing room-scale from SteamVR's setup fixed it a bit. 

Using OpenVR-AdvancedSettings to disable the chaperone system opens a whole new can of worms and bugs. 

 

Even with low settings there are performance issues. The few times I've managed to get a decent framerate, camera position, and settings, and tried to ignore the rest of the problems and get into the game it looks like it will be the most insane experience but it's super buggy at the moment.

 

In my opinion, it doesn't look like all bugs are on codemaster's side. I believe that some bugs in SteamVR mix with DR2 in a pretty nasty way and it will probably take a while to fix

 

I've just downloaded the game, on Valve+Wireless, I7-3770K(@4GHz), GTX1080. I notice very regular spikes which ruin the visuals as well during driving, and on a night drive when part of the view is properly dark I realised these are the 'lightning' background effects that are created in the distance when the 2D menu screen is up (before the game reverts to VR mode for the actual driving). It seems like these hill-vista+lightning-flash visuals aren't being turned off during the actual VR game and it's causing the problem for me. I'll disable the room-scale and see if that fixes things (I'm also sitting outside the room-scale chaperone boundaries). The hilly vista is a SteamVR thing to my knowledge, but I don't seem to be able to turn it off in the SteamVR settings.

Not related to this post, but I also found that turning off the bluetooth-base-station-management fixed the game launch issues that I was initially seeing. And the game won't launch successfully at all if SteamVR is running first. But I do have to have the Vive Wireless app running first (so the HMD is seen to exist). No idea how I'd get this game to load in non-VR mode though?

 

Share this post


Link to post
Share on other sites

Probably not only VR issue.

I succeeded to setup configuration to maintain constant 90fps in all location regardless a weather. But in Spain, when I go into a build-up area, fps drops even to 50. Looks like not well balanced with other scenes fps-wise.

  • platform: SteamVR
  • HMD: Vive
  • PC: i5@5Ghz, 16GB RAM, GTX1080Ti
  • Standard steam version
  • Peripherals: TX + T3PA Pro, G25 (shifter), Saitek Cyborg 3D Rumble Force (as for handbrake)

Share this post


Link to post
Share on other sites

Is anyone else having to reset the view between every stage (and sometimes in the middle of a stage) in VR?  I'm using a Rift S with the Oculus Store version of the game, generally everything is working very well, but the game seems to be defaulting back to a slightly random VR camera position between every stage at least.  It doesn't even seem to match the camera position I've set with Guardian!

Share this post


Link to post
Share on other sites

Another user reporting severe head tracking lag, using Vive Pro.  9900K/1080Ti.  Performance is actually really quite good, from an outright framerate and image quality perspective.  Better than I expected having read the initial reports.

But yes, despite hitting 90Hz there is a severe - and frankly bizarre - head tracking lag.

Same regardless of SteamVR branch.

Share this post


Link to post
Share on other sites

Hi
Third time lost 99% sound in stage, only left some stones hiting car body. after stage sound came back. 
2/3 lost sound in same stage (firts time i dont remember stage).
Stage: Taylor Farm sprint
car: all 3 times was different cars

  • Platform: STEAM
  • headset: oculus CV1 - audio from hdmi -oculus
  • PC: ecu 7700; gtx 1070ti, 
  • steam deluxe
  • G27 wheel

Share this post


Link to post
Share on other sites
17 minutes ago, Fregis said:

Third time lost 99% sound in stage, only left some stones hiting car body. after stage sound came back. 

Same here! not reproducible😕

 

Steam

Odyssey+

8700k/2080ti/32GB/SSD only

CSW2.5

Share this post


Link to post
Share on other sites
13 hours ago, MaXyMsrpl said:

Probably not only VR issue.

I succeeded to setup configuration to maintain constant 90fps in all location regardless a weather. But in Spain, when I go into a build-up area, fps drops even to 50. Looks like not well balanced with other scenes fps-wise.

  • platform: SteamVR
  • HMD: Vive
  • PC: i5@5Ghz, 16GB RAM, GTX1080Ti
  • Standard steam version
  • Peripherals: TX + T3PA Pro, G25 (shifter), Saitek Cyborg 3D Rumble Force (as for handbrake)

I narrowed it down to shader detail settings. It seems this setting has biggest impact. But looking at the scene I wouldn't expect it right here.
Unfortunately switching shader detail settings to low turns visual to '90 quality (road, car). I believe mentioned location can be optimized since the rest can can maintain 90fps.

And one more finding: screen space reflections quizzes fps down from 90 to 45. AFAIK this method of adding reflections should be very cheap performance-wise. But it seems it isn't.

Regarding snow-like-looking wet surfaces, screen space reflections helps partially. But also it seems that those wet surfaces reflects the sky too much (or are translucent not enough at the same time). Checking Fresnel's parameters could help.

Share this post


Link to post
Share on other sites

I Can manage the stuttering bug what is caused by some in-game usb device.

I remove all of them except my t300 wheel and keyboard. Starting the game in vr and the lagging is still there.

I plug in one of my pheripherials ingame like handbrake, the game still lagging.

I remove the pheripherials (what I've just plugged in) and the stuttering is gone!!! You have no quit from the race, the effect is instant!

Shame on you codemasters this is a known bug since DIRT 4.

 

Share this post


Link to post
Share on other sites

@PJTierney: Any idea of a timeframe of when the juddering view bug with Oculus Rift S and the Steam version of the game will be fixed? I bought the Rift S just to play DR 2.0, but right now your partnered device isn't working with the game so it's a bit embarrasing for both you and Oculus 😉 

Share this post


Link to post
Share on other sites
1 hour ago, Dytut said:

@PJTierney: Any idea of a timeframe of when the juddering view bug with Oculus Rift S and the Steam version of the game will be fixed? I bought the Rift S just to play DR 2.0, but right now your partnered device isn't working with the game so it's a bit embarrasing for both you and Oculus 😉 

I need to sit down with people this week and find out what exactly is the roadmap for VR improvements or implementations. When I know more I’ll see what I can tell people 🙂 

Share this post


Link to post
Share on other sites

OK, add me to the list of people where this periodic "every 2 second" judder seems to be related to USB/controllers.

This is a long post, but perhaps worth a read for anyone who gets the "every 2 seconds" judders in VR, but otherwise gets good framerates. I'm listing a few suggested workarounds (two of which I haven't seen anyone mention before). There might also be some useful feedback for the dev team in here, if the root of the trouble does end up being within the game itself...

Note: If I mention ASW below and you're not an Oculus owner, instead use your equivalent... I assume, the motion smoothing setting through SteamVR.

 

I'll start with the suggestions, for anyone short on time or who doesn't want to read my ramblings!!!

  • First, to make things easier, if you're an Oculus hardware owner, especially if your PC isn't on the high-end, make sure you try forcing ASW on all the time (either press CTRL+Numpad 3 within the game, or use eg. Oculus Tray Tool). Long-time Oculus users will know this, but this can eliminate any slight/occasional stutters you may get each time ASW auto-enables / disables itself if your framerate fluctuates around 45fps. A constant smooth 45fps can be preferable to *almost* being able to run 90fps constantly with occasional stutters as ASW kicks in! As a bonus, if you settle for 45fps you can turn up the graphics settings a bit! This won't resolve the "USB Device-Related" judders some of us get every 2 seconds, but it may improve your experience & make it easier to diagnose them, or tell if/when you've fixed them (also see my Steam VR Advanced Timing charts below for an example of what you're looking for).
  • Steam Library -> DR2.0 -> Properties -> Steam Input Per-Game Settings -> "Forced On". This is what I did the very first time I got rid of my "every 2 second" judders a few days ago. I was about to post about it here, but then I couldn't reproduce it again! It was the first sign I had that there was definitely some link between the issues & my controllers/USB devices, despite having previously tried the game with no USB devices other than keyboard connected! Worth a shot.
  • Launch DR2.0 in VR, then attach a new USB device/controller/keyboard, then unplug it. This seems so bizarre given that we're all talking about our suspicions that the game is causing CPU spikes because it may be polling our various USB devices, but ADDING ANOTHER USB device & then removing it seemed to cure the periodic judders for me today. I'm not sure if it was the adding or the removing, and I tried a couple of different USB ports before I got it to work. But then I rebooted to re-test, the judders came back & I couldn't solve it by doing this again... however I also set Steam Input back to "Forced On" for DR2.0 (which I had reverted to default setting when I couldn't get it to work again the other day), and the judders went away again! Unfortunately, it all seems a bit too indeterminate/flaky to me, so I've not got great confidence that the problem won't come back for me, but it seems ok for now, across a few reboots & game restarts.
  • Due to a Windows bug in v1903, make sure you have a folder (create it if not) at ' C:\WINDOWS\system32\config\systemprofile\AppData\Local\TileDataLayer\Database\'. A long-shot, but I have to mention this as I did this shortly before my first ever time getting rid of the judders! I really don't think this one is related, but I'm mentioning it due to the timing of things, just in case. I had noticed frequent errors in my Windows Event log related to Windows Start Menu / Tile Database, which I've solved by creating that folder. This seems to be related to Windows v1903, which I possibly updated to at some point shortly before DR2.0 VR update. So I guess it's a possible factor if those of you getting these periodic judders haven't yet updated to v1903. Read here for more details on the Windows bug: https://www.tenforums.com/windows-10-news/133041-known-resolved-issues-windows-10-may-2019-update-version-1903-a-2.html#post1638963

 

My setup: Steam / DR2.0 Deluxe / Oculus Rift CV1 + 2 sensors / i5-4460 + GTX970 + 16GB RAM / Logitech G29 + Shifter + Pedals (+ various other unrelated USB devices, joysticks, etc.)

In my case...

  • I only get these periodic judders with my headset connected in VR (never so far when playing on standard monitor)
  • The judders make your viewpoint briefly "shudder", as if your head has taken a slight knock, even if framerate is continuously good (eg. 90fps, or 45fps with ASW)
  • I'm referring to this as "USB Device-Related" judder in my notes below
  • These consistent brief judders are completely unrelated to any performance-related stuttering, which is best resolved by turning down settings to suit the hardware.
  • It felt to me that whenever I have "USB-Device Related" periodic judders, there was also a noticeable lag/delay to the headtracking keeping up with my head movements (which went away whenever the judders did)
  • I can *nearly* get consistent 90fps with everything on lowest, but I prefer consistent 45fps with ASW force-enabled & settings turned up a bit (somewhere between Medium & High for me on i5-4460 + GTX970)
  • I have various USB devices connected including wheel/pedals/shifter, and needless to say I have never experienced these periodic judders in any other game, VR or otherwise, including previous CM titles, with all those same devices connected.

I had no success before now, after previously trying various things suggested here plus a whole load of others (including the oft-suggested unplugging / disabling USB devices... I even tried with nothing connected but a keyboard to launch the game!). But thanks to everyone for continuing to post your experiences. I'm glad I persisted as I finally managed to get rid of those judders. I'm not confident enough to say they won't come back another day or a reboot though! I first thought I'd fixed it over the weekend, and was about to post my solution here, but upon re-testing I couldn't reproduce the results. Suffice to say, there's something a bit flaky going on with the game & it's interaction with USB hardware, and "every 2 seconds" (pretty much precisely) would appear to be the common theme. Anyway, I persisted & eventually made a bit of a breakthrough...

 

Here's what my SteamVR -> Developer -> Advanced Frame Timing looks like in various situations...

NOTE: For all my testing & results below, all graphics settings were turned down to their lowest (note that some settings have an even lower setting that can be changed manually even after selecting the lowest preset). Once I solved the CPU spikes/periodic judders, there's headroom in there for me to run at higher settings, it just made it easier to eliminate any possible performance-related stutters by running everything at the lowest to start with.

 

USB Device-Related Judders - Periodic Stutters (CPU spike every 90 frames with ASW @ 45fps = every 2 seconds)...
In a Time Trial, sitting on the start line...

733259797_IssueUSBdevice-related-TimeTrialStartLine-PeriodicStutters(CPUspikeevery90frameswithASW@45fpsevery2seconds).thumb.png.3d7975026f4b77855c89bda0a0207fea.png

On the Main Menu...

2072157841_IssueUSBdevice-related-MainMenu-PeriodicStutters(CPUspikeevery90frameswithASW@45fpsevery2seconds).thumb.png.a4daa17ff99e01e412903a26c1bb2632.png

 

ASW repeatedly auto-engaging/disabling periodically - Main Menu - Periodic CPU Pulses every 60 frames - ASW on auto/default (CTRL+4) giving perhaps 50fps average...

If you're seeing this, your occasional stutters can perhaps be solved by simply force-enabling ASW (or SteamVR/your headset's equivalent motion smoothing) all the time. For me, I'm not sure why the main menu doesn't seem to want to maintain 90fps when it's clearly capable of nearly 90fps on lowest settings while driving. But the main thing to note here is how the frame timing chart looks different to the more abrupt spikes in the previous chart which exhibits USB Device-Related judders. These "pulses" seem to be a sign that ASW is enabling/disabling, and indeed I could make them go away & return at will by forcing ASW on or auto with the keyboard shortcuts CTRL+3 or CTRL+4.

186794442_IssueASWauto-toggling-MainMenu-PeriodicCPUPulses@50fps(every60frameswithASWonautoCTRL4).thumb.png.198796e84b955ebc70965c69f05787c6.png

 

What it should look like if you have no periodic stutters / no CPU spikes... for me, with smooth 45fps & ASW=Forced On(CTRL+3)...

Time-Trial, sitting on the start line...

2098942239_NoIssues!-TimeTrialStartLine-Smooth(noCPUspikes)SteamInputForceOnplugunplug2ndUSBkeyboard.thumb.png.45f0963c2a9eb1f11b036829f45203b3.png

Main Menu...

600384325_NoIssues!-MainMenu-Smooth45fps(noCPUspikes)ASWForceOn(CTRL3)SteamInputForceOnplugunplug2ndUSBkeyboard.thumb.png.b871def698463e3135acdb5dc98ac717.png

 

As a reference, see my previous post on this thread for a lengthy list of other things I tried (without luck until now) to fix the periodic judders...

 

Hopefully there's something useful in there that helps someone 🙂

Hopefully the periodic judders don't come back for me (but I kind of expect they will at some point!)

Hopefully CM can reproduce the "every 2 seconds" judders / CPU spikes, or perhaps have already done so? And perhaps DR2.0 might receive an update which prevents/avoids those CPU spikes, which do seem to be related to USB devices/controllers in some way... whether it's the game constantly trying to detect the currently-connected controllers every 2 seconds, or something else along those lines.

Share this post


Link to post
Share on other sites

Update, Oculus user on Steam 

With the latest Nvidia drivers and latest Steam beta, I have very good frame rate on Oculus and 2070 Super however I still have the periodic stutter with ASW set on auto or off.
When I force ASW on at 45, windowed mode, I get no stuttering and played for hours with very high settings (including shaders and shadows on high.) It's not ideal but much better than before. 
Also, I have noticed almost no artifacts with ASW 2.0 compared to ASW 1.0

Share this post


Link to post
Share on other sites
  • What platform Steam
  • What headset you're using: Rift S
  • What your PC setup/build is like (graphics card, processor) I7 6700k 48GB Ram Nvidia 1080
  •  Deluxe user.
  • T300

For me it drives smoothly, no problems but:

NonVR DR2 at 90-140 fps and in VR keeps at 40 (almost at 80 range following the steamVR ms count headset app). With SteamVR and Oculus software at default, I downscaled resolution in the SteamVR settings for the game to minimum to speed up fps (100% says it a weird scale 1804x1944 for each eye while the Rift S has a 2560x1440 1 screen). The graphics are worse 🆗 but still 40fps. So 🆗 reverted to 100% and Game is driveable at 40 but Its a pitty NonVR can get 100 fps with same resolution 2560x1440 than the Rift S, and with headset, don't 

Mouse doesn't work wich is annoying cause T300 buttons show as numbers.. wich is wich is matter of try and error 

It would be better to have everything on the NonVR screen, so we can move easily with keyboard or mouse, edit setups, watching replays.. etc and just when in the car, move to the vr glasses.

And for those (like me sometimes) that loose sound, don't play the game for much time long. Restart it before playing too long. But when sound issue happens, just select another sound output and then again your default, and sound comes again..

Share this post


Link to post
Share on other sites
17 hours ago, Vakiwey said:

I downscaled resolution in the SteamVR settings for the game to minimum to speed up fps (100% says it a weird scale 1804x1944 for each eye while the Rift S has a 2560x1440 1 screen).

Checkout the settings in video tab. scale set for application applies over scale set in video section. looks like you have undersampling set globally 

Share this post


Link to post
Share on other sites
On 8/23/2019 at 11:45 PM, Vakiwey said:
  • What platform Steam
  • What headset you're using: Rift S
  • What your PC setup/build is like (graphics card, processor) I7 6700k 48GB Ram Nvidia 1080
  •  Deluxe user.
  • T300

For me it drives smoothly, no problems but:

NonVR DR2 at 90-140 fps and in VR keeps at 40 (almost at 80 range following the steamVR ms count headset app). With SteamVR and Oculus software at default, I downscaled resolution in the SteamVR settings for the game to minimum to speed up fps (100% says it a weird scale 1804x1944 for each eye while the Rift S has a 2560x1440 1 screen). The graphics are worse 🆗 but still 40fps. So 🆗 reverted to 100% and Game is driveable at 40 but Its a pitty NonVR can get 100 fps with same resolution 2560x1440 than the Rift S, and with headset, don't 

Mouse doesn't work wich is annoying cause T300 buttons show as numbers.. wich is wich is matter of try and error 

It would be better to have everything on the NonVR screen, so we can move easily with keyboard or mouse, edit setups, watching replays.. etc and just when in the car, move to the vr glasses.

And for those (like me sometimes) that loose sound, don't play the game for much time long. Restart it before playing too long. But when sound issue happens, just select another sound output and then again your default, and sound comes again..

Interesting. You have about the same setup as me. Don't you get the juddering view with the Rift S? 

Share this post


Link to post
Share on other sites

From the August 23 Roadbook:

 

 

As you all know, VR support for DiRT Rally 2.0 was added in Version 1.7, however we’re fully aware that some are enjoying it less than others due to technical performance. You’ve given us feedback, and we’ve been having many discussions internally about how to ensure you all have the best VR experience possible with our game.

 

First up, we posted a VR settings guide. If you haven’t seen it yet it’s here:

 

Next, we looked at what changes could be made in time for our next update. Version 1.8 is expected to release around September 3. Here’s a snippet of the Patch Notes (which we’re currently assembling) detailing what’s changing for VR:

  • Added option allowing players to choose whether to launch the game in 2D Mode or VR Mode.
  • Added support for separate graphics presets between 2D Mode and VR Mode.
  • Added support for “-novr” launch command.
  • Added ability to bind “Reset View” to a preferred buttons/keys.
  • Resolved issue where game would crash if no VR headset was plugged in.
  • Improved readability of UI text in VR Mode.

 

In addition to this, we are currently investigating what is required in terms of time and resources to implement Oculus SDK support into the Steam version of the game.

Adding Oculus SDK support to the Steam version is not a simple matter of flicking a switch, nor is it a case of copy/pasting code from the Oculus version. It’s also not something that can happen immediately or in a very short space of time. We’ll share more in the future once things progress.

 

As always, we’re grateful for the feedback you provide to us on all aspects of the game, whether it’s on our forums, Steam or social media. It’s through this two-way conversation that we’ll continue to improve the game and give you the best experience possible.

Share this post


Link to post
Share on other sites
  • What platform you're playing on (for PC also state Steam or Oculus).  OCULUS
  • What your PC setup/build is like (graphics card, processor etc.).   RTX 2080- I7 6700k  16 gb ram  Rift s

The nigth stages (and dark areas) have like max 64 colours. This is only on the oculus store version, works fine on steam.

Also the house areas in spain is a real fps killer. 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×