Jump to content

DiRT Rally 2.0: Version 1.7 VR Feedback

Recommended Posts

IMPORTANT: Read and understand this entire opening post before replying, as providing the right amount of detail will help out the team immensely in tracking and resolving any bugs that arise, thanks.

 

ALSO: This thread is for VR-related issues only. Head to the following thread for general bugs:

 

 

DR2_Oculus_Photo_2.jpg

 

 

Before posting, please make sure to follow these guidelines. Without adequate information the team will have trouble identifying and fixing bugs, so please provide as much info as you can:

  • Check if a bug has already been reported.
  • If a bug has been reported and you are experiencing the same issue, hit the upvote icon: 

    image.png
     
  • The more popular bug posts will have a better chance of catching the attention of the team.
  • If a bug cannot be reproduced, it cannot be fixed.
  • When you experience a bug, please try to trigger said bug again if you can, and show us the steps you went through to trigger it.
  • Text steps are good, video even better.
  • One bug per post please, for our tracking purposes. That way every bug gets its own URL for us to investigate.

 

Please also provide the following:

  • What platform you're playing on (Steam or Oculus).
  • What headset you're using.
  • What your PC setup/build is like (graphics card, processor etc.).
  • Whether you're a Standard or Deluxe user (Steam only).
  • Whether or not you have any non-standard peripherals connected, like steering wheels, gaming mice etc.
  • Like 1
  • Agree 1

Share this post


Link to post
Share on other sites
Posted (edited)

Steam/PC WMR Samsung Odyssey+ 2080ti 32GB RAM I7 8700k all @stock

 

1st thing I remarked while testing was the missing mouse-function. Do not know if it's wanted - but I miss it ...

Edited by Flens07

Share this post


Link to post
Share on other sites

Hi, my world scale is much to big. My steering wheel looks like a 40 cm diameter wheel.

 

  • What platform you're playing on (Steam or Oculus).

Steam VR

  • What headset you're using.

Lenovo Explorer

  • What your PC setup/build is like (graphics card, processor etc.).

2080Ti, 16 GB RAM, Core i7 4770k, Win 10 Pro. No overclocking or similar special. 

  • Whether you're a Standard or Deluxe user (Steam only).

Deluxe

  • Whether or not you have any non-standard peripherals connected, like steering wheels, gaming mice etc.

Doesn't matters in this case.

  • Like 1
  • Agree 1

Share this post


Link to post
Share on other sites
Posted (edited)

- Purchased from Oculus Store

- Oculus Rift CV1 (Oculus Home 1.40)

- AMD Ryzen 1800X, GeForce Titan X Pascal (driver 431.60), 32 GB RAM

- Standard user

- Thrustmaster TS-PC wheel and pedals

- Windows 10 Pro 1903 (18362.267), Spanish language

The game runs perfectly, but I'm getting no sound at all. It's the only VR game that does not produce any sound on my computer. Got Dirt Rally 1 VR installed alongside it and this one has sound, by the way. I've tried to change Windows sound device to my Rift, but still no sound. No sound from the Rift, no sound from my external speakers... just no sound.

I've attached dxdiag file. I noticed a report at the end of the file regarding Dirt Rally 2:

Windows Error Reporting:
+++ WER0 +++:
Depósito con errores 1834931075754348380, tipo 5
Nombre de evento: RADAR_PRE_LEAK_64
Respuesta: No disponible
Identificador de archivo .cab: 0

Firma del problema:
P1: dirtrally2.exe
P2: 1.7.128.4514
P3: 10.0.18362.2.0.0
P4: 
P5: 
P6: 
P7: 
P8: 
P9: 
P10: 

DxDiag.txt

 

EDIT: I went to My Documents\My Games and found the hardware_settings_info.xml file, after the graphics card info there is only one line about the audio card, it just reads <audio_card />, and after that there is another line </hardware_settings_info>. I attached the file too. However there is audio info on hardware_settings_config.xml.

 

 

hardware_settings_info.xml

hardware_settings_config.xml

Edited by JuanEtxeb
add hardware settings xml files
  • Agree 5

Share this post


Link to post
Share on other sites
  • What platform you're playing on (Steam or Oculus). Oculus (but Steam VR starts automatically when starting DR2.0)
  • What headset you're using. Oculus Rift
  • What your PC setup/build is like (graphics card, processor etc.). i7-7700k , 1080ti, 32GB, 512SSD
  • Whether you're a Standard or Deluxe user (Steam only). Deluxe user
  • Whether or not you have any non-standard peripherals connected, like steering wheels, gaming mice etc.  Fanatec DD1, Fanatec H shifter+handbrake and NLRv3 motion platform connected

===
VR performance is really poor. You have to turn down all graphic options to the lowest value to have a car run 'smooth' through a stage (tried, Australia, Germany, Wales and Monaco).
But with too low graphics it does not look that well . If you turn up to mid/high the graphics are obviously ok but the stuttering is massive and it becomes unplayable.

I start DR2.0 VR via Steam as I also bought it via Steam. Then it both starts SteamVR as well as Oculus home. 

 

 
  • Agree 6

Share this post


Link to post
Share on other sites
Posted (edited)

1. EDIT - this seems to be because of the 3rd party add-on, OpenVR Advanced Settings.  It works fine without the app.

The "Reset VR View" will reset to the center of my playspace (which faces in the OPPOSITE direction of my wheel), so I'm never in the car.  It seems to be resetting view to the playspace instead of current head position.  I tried setting up a seated playspace, but if I don't set my headset in the perfect spot when making the playspace, my view in the car will not be centered and it will not change according to my current head position.

2. Also, the chaperone grids won't go away unless I turn them off.  

 

3. Delayed head movement.  Could just be performance related but I didn't have time to check (used SteamVR 100% SS on Medium settings so I think I can help with lowering things like in DiRT 1 to help)

Steam

Valve Index

i5-4690K and GTX 1080Ti, 16GB DDR3 RAM(slightly higher clockrate than normal, forgot actual number, at work now). Game's installedon a crucial mx500 SSD.

 

Deluxe version

 

T300 RS GT with T3pa PRO and Thrustmaster Shifter.

Razer Chroma mouse, Razer keyboard (not chroma, black widow stealth I think) 

 

  • What platform you're playing on (Steam or Oculus).
  • What headset you're using.
  • What your PC setup/build is like (graphics card, processor etc.).
  • Whether you're a Standard or Deluxe user (Steam only).
  • Whether or not you have any non-standard peripherals connected, like steering wheels, gaming mice etc.
Edited by xcAzx
Figured out why Reset View didn't work

Share this post


Link to post
Share on other sites
Posted (edited)

Hi gents,

just installed VR update.. for a first few tries I was not able to run it. Now it works perfectly in VR. BUT Iam not able to run the game anymore in 2D.. what happened and how can I fix this pls?
WMR is plugged out

There are no commands in lunch options

Steam VR is off

 

For some reason the game now always wants to start in VR mode even if Steam VR is not running and WMD is not connected..

 

HELP PLEASE

Snímka.PNG

Edited by cibenopk
  • Agree 3

Share this post


Link to post
Share on other sites
  • What platform you're playing on (Steam or Oculus).
    Steam
  • What headset you're using.
    HTC Vive
  • What your PC setup/build is like (graphics card, processor etc.).
    Mobo: Intel DX79TO Extreme Series
    i7-3930K CPU @ 3.20GHz 3.20GHz
    RTX 2080 Ti Founder's Edition
    RAM 32GB HyperX 1600Mhz
    Logitech G29 wheel
  • Whether you're a Standard or Deluxe user (Steam only).
    Deluxe
  • Whether or not you have any non-standard peripherals connected, like steering wheels, gaming mice etc.
    Logitech G29 wheel

    =====================

    When I turn on in VR mode the game stops at the "push start to continue" screen.
    On this screen I can't do anything. No button works. Keyboard or steering wheel don't work.
    The sound doesn't work either.

Share this post


Link to post
Share on other sites
4 hours ago, Flens07 said:

 

1st thing I remarked while testing was the missing mouse-function. Do not know if it's wanted - but I miss it ...

 Yes, very unhandy with a VR on your head and trying to find a button on the keyboard because no mouse. I have the power shutdown button next to f12 so have to be carefull to hit f11...

Share this post


Link to post
Share on other sites

Steam

Vive Pro

i7 8700k, 1080ti, 16gb,

Deluxe

Game starts in VR to just a black empty display, I can hear the game music but nothing visible at all. All other VR games still working as normal.

  • Agree 1

Share this post


Link to post
Share on other sites
  • Steam version

    Oculus Rift

    i5-6600k rtx 2070 super, 16gb,

    Deluxe

    Game starts in VR with black empty display, if I remove headset I can see message VR Headset removed. Other Steam VR games run fine.

  • Agree 2

Share this post


Link to post
Share on other sites

I had this, but by mashing the enter button on my wheel I managed to load a stage with the Fulvia and it was visible in VR. I managed to complete the stage, but any of the 2D menus before or after the stage were black screen. I'm on the steam VR beta too. HP Reverb/WMR/SteamVR. 

i7-7700K/GigaByte RTX 2080/Win10 64bit/32Gb RAM/Asus Xonar DX+Beyer Dynamic DT990 Pro headphones/LG 34" UM65 @2560x1080/HP Reverb/Logitech G29+G25 shifter/DSD P2 button box

Share this post


Link to post
Share on other sites

Another issue, I now can't figure out how to start the game in 2D mode and bypass VR for the time being. Any ideas?

Share this post


Link to post
Share on other sites
25 minutes ago, JamesWhite said:

Another issue, I now can't figure out how to start the game in 2D mode and bypass VR for the time being. Any ideas?

Deinstall SteamVR then DR 2 will start in flat mode.

I had also the blank screen problem, deinstalled SteamVR changed the game to window mode, installed SteamVR and was able to see also tne menu. Could also be that's depending on the new SteamVR beta 1.7.2, atm on 1.6.10

  • Agree 1

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, JamesWhite said:

Another issue, I now can't figure out how to start the game in 2D mode and bypass VR for the time being. Any ideas?

In file ‘’hardware_settings_config.xml’’ 

Change value ‘’true’’ for value ‘’false’’

So it is now

<vr enabled=’’false’’ eyeDistanceMultiplier=’’1.000000’’ lockedOrientation=’’false’’>

Edited by Robytoo
rephrased
  • Like 1
  • Agree 3

Share this post


Link to post
Share on other sites
Posted (edited)

Can we get confirmation about whether it's possible to use the native Oculus SDK with the Steam version of the game? 

Many of us, myself included, bought the game on steam in anticipation of this patch. Now I seem to be unable to run the game in the best way for my setup (rift cv1). I really appreciate the effort that likely went into supporting openVR, we just need a command-line option or some other way to get the steam version running properly with Oculus. I much prefer having the game on steam given it's likely I may update my HMD in the future.

  • What platform you're playing on (Steam or Oculus).
    Steam
  • What headset you're using.
    Oculus Rift CV1
  • What your PC setup/build is like (graphics card, processor etc.).
    i7-6700k CPU @ 4.5GHZ
    GTX 1080  Founder's Edition
    RAM 16GB
    Logitech G29 wheel
  • Whether you're a Standard or Deluxe user (Steam only).
    Standard
  • Whether or not you have any non-standard peripherals connected, like steering wheels, gaming mice etc.
    Logitech G29 wheel
Edited by Seraph321
typo
  • Agree 11

Share this post


Link to post
Share on other sites
Posted (edited)
10 hours ago, Robytoo said:

In file ‘’hardware_settings_config.xml’’  

 

Change value ‘’true’’ for value ‘’false’’

 

So it is now

 

<vr enabled=’’false’’ eyeDistanceMultiplier=’’1.000000’’ lockedOrientation=’’false’’>

 

This solution works without removing steamVR, which would mean no VR games at all for me :classic_sad:. I changed to windowed mode in the same config file and still had the black screen/no menu issue with steamVR beta 1.7.2, I'll try rolling back to the previous version, that seems to be the issue.

 

edit: rolled back SteamVR to 1.6 and used windowed mode, headset display remained black, game loaded ok on screen and I could navigate menus on screen, but even when I got into 3D and the stage start it stayed black in the HMD. The view was visible on my monitor and I could drive the stage so long as I kept the Reverb on my head and peeped out below the visor. I'll forget DR2.0 VR for a bit and check back in a month or so, good luck guys, hope it starts working one day.

i7-7700K/GigaByte RTX 2080/Win10 64bit/32Gb RAM/Asus Xonar DX+Beyer Dynamic DT990 Pro headphones/LG 34" UM65 @2560x1080/HP Reverb/Logitech G29+G25 shifter/DSD P2 button box

Edited by JamesWhite
added more info.

Share this post


Link to post
Share on other sites
Posted (edited)

Please can we have an option on Steam to launch the game using a choice of: SteamVR, Oculus native SDK, or standard desktop/2D.

Thanks!

(Steam/Deluxe/Oculus Rift CV1) [Not a bug, so more details of setup irrelevant]

Edited by YorkyPudsy
Clumsy fingers!
  • Agree 2

Share this post


Link to post
Share on other sites
14 hours ago, bitola84 said:
  • Steam version

    Oculus Rift

    i5-6600k rtx 2070 super, 16gb,

    Deluxe

    Game starts in VR with black empty display, if I remove headset I can see message VR Headset removed. Other Steam VR games run fine.

the same with me ..

Share this post


Link to post
Share on other sites
Posted (edited)

Hi,

Over the last day or so, I've been trying to figure out why the game is seemingly lagging when looking around in VR. My framerate is fine; steamvr is set to run at 90hz, and the game is holding a solid 90fps on medium to high settings. CPU usage is around 50 to 60%. As soon as the view changes from 2d in the cut scenes, to vr, I look around and the lag makes me feel quite ill. It's as if you look left or look right, and the screen movement is slightly behind or at times, the screen moves with you. This problem exists regardless of graphics settings, from ultra low to high. 

The problem is also noticeable when you pause the game. If you look at the menu and turn your head left and right, the menu partially moves with you to a degree. At first I thought the fov settings were wrong, but there's no way of changing it in VR that I could find. The option for fov does exist within the 2d mode, but changing it in that mode has no baring on the vr mode. 

While I'm at it, the view reset doesn't seem to work properly neither, it always sets me in a position that is too far away from the steering wheel... leading me to think that there is indeed problems with the fov. Whether this is the reason for the laggy feeling I get when looking around, I don't know. My pc specs are below. Thanks for your time.

**Update**

I also have an Oculus Rift at hand to test with along side my Valve Index. I've had some interesting results. The stuttering on the Oculus is indeed caused by usb peripherals. Unplugging them while in game suddenly makes everything smooth and eliminates the stutter, however, doing this does not work with the Valve Index, the lag still persists. 

The issues could very well have something to do with usb devices, which is certainly the case with the Oculus headset. I have repeated the process every time successfully, both making the stuttering start, and stop. It may be a device limit, but I'm not 100% sure. 

 


Platform: Steam VR/Open VR
HMD: Valve Index and Oculus Rift CV1
PC: RTX 2080ti, i7 6700, 32gb RAM
Deluxe User
Connected: Accuforce Steering Wheel, Heusinkveld Pedals, Handbrake and Shifter

Edited by IISargeII
Update
  • Agree 9

Share this post


Link to post
Share on other sites
Posted (edited)
3 hours ago, JuanEtxeb said:

Found a couple of guys with the same no audio problem than me on Oculus version:

https://www.reddit.com/r/oculus/comments/cnx507/dirt_20_oculus_version_no_audio/

One of them purchased both Oculus and Steam versions of the game. Steam version has sound, Oculus version has no sound.

That was me, well one of them anyway. I'm OP.

I am comparing all config files etc as well, tried just copying them over, no change, so its not am XML issue.

I am about to replace everything from the steam folder and see if it launches. I have a feeling the .exe is compiled different, which might be the problem. (which we can't fix)

They have 2 different sizes so there is something different. 

Under the 'Game' folder the game.nefs is 2KB different as well. so something else has been changed in there.

Other than some differences in the the cars and locations folders (oculus having more in each for some reason) there is no differences except those files.

I will do some more testing and report back.

Edited by BigSlug
  • Agree 1

Share this post


Link to post
Share on other sites
Posted (edited)

What platform you're playing on (Steam or Oculus).

Steam Deluxe-Version

What headset you're using.

Samsung Odyssey+ (Supersampling 100%)

What your PC setup/build is like (graphics card, processor etc.).

2080ti, i7 8700K, 32GB RAM, SSD only

Whether or not you have any non-standard peripherals connected, like steering wheels, gaming mice etc.

Fanatec CSW2.5 + Porsche wheel + V3-Pedals connected @ base

All drivers up to date and no overclocking at the hardware

 

I made the same statement as @IISargeII .... In addition, it is noticeable that in an accident, the framerates also break down and then slowly recover.
Driving with motion reprojection (45fps) does not help, as the frames are sometimes drop to 25 fps - that is impossable to drive. And it doesn´t matter if it is on low or high gfx-settings!!!!

 

Edit: BTW: In motion reprojection is the graficcard  40-50% at work and the max-processor-core at 30%, nevertheless the framerates drops down

Edited by Flens07
  • Agree 1

Share this post


Link to post
Share on other sites
 
 
 
 
 
 
 
 
 
 
8
24 minutes ago, IISargeII said:

it always sets me in a position that is too far away from the steering wheel... leading me to think that there is indeed problems with the fov.

Same with oculus/OpenVR, I thought it was an oculus issue, everything seems too small.

  • Agree 1

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×