Jump to content
  • 0

DiRT Rally 2.0: VR Bug-Reporting Thread

Question

IMPORTANT: Read and understand this entire opening post before replying, as providing the right amount of detail will help out the team immensely in tracking and resolving any bugs that arise, thanks.

 

ALSO: This thread is for VR-related issues only. Head to the following thread for general bugs:

 

 

DR2_Oculus_Photo_2.jpg

 

 

Before posting, please make sure to follow these guidelines. Without adequate information the team will have trouble identifying and fixing bugs, so please provide as much info as you can:

  • Check if a bug has already been reported.
  • If a bug has been reported and you are experiencing the same issue, hit the upvote icon: 

    image.png
     
  • The more popular bug posts will have a better chance of catching the attention of the team.
  • If a bug cannot be reproduced, it cannot be fixed.
  • When you experience a bug, please try to trigger said bug again if you can, and show us the steps you went through to trigger it.
  • Text steps are good, video even better.
  • One bug per post please, for our tracking purposes. That way every bug gets its own URL for us to investigate.

 

Please also provide the following:

  • What platform you're playing on (Steam or Oculus).
  • What headset you're using.
  • What your PC setup/build is like (graphics card, processor etc.).
  • Whether you're a Standard or Deluxe user (Steam only).
  • Whether or not you have any non-standard peripherals connected, like steering wheels, gaming mice etc.
  • Agree 1

Share this post


Link to post
Share on other sites

Recommended Posts

  • 1

5 days and still no patch for no sound on oculus.. what the hell is going on.. effects about half the user base..

Share this post


Link to post
Share on other sites
  • 1

A fundamental question to @PJTierney:

Is any work for a hotfix of the significant bad VR-performance in progress?

  • Agree 2

Share this post


Link to post
Share on other sites
  • 1
Posted (edited)

Newest Version 1.7 has also the stutter bug reading the HID devices.

Version 1.7 / Steam / Win 10 (1903) / Fanatec Podium / I9 9900, RTX 2080TI / Valve Index

As you can see on the left side the frametimes are at 70ms level, which causes a lot of stutter, you can also see the stuttering fps drop

At the moment where I plug out my DS4 controller (which I only plug in to plug out in DR 2) the frametimes comes down to around 13 ms without any stutter.

DR2_framedrops_8_v1.7_VR.jpg.34043f0a82b7eb12f8719c7994b69882.jpg 

You could use more or less any HID device to plug in and plug out to remove the stutter e.g. the same happens with my TH8 shifter.

Edited by Peter Mathen
  • Thanks 1

Share this post


Link to post
Share on other sites
  • 1

Platform : Steam VR
Headset : Oculus Rift, 4 sensors
Setup : I7 7700K RTX 2080 16Go DDR4
Peripherals : many many ( G27 wheel, Thrustmaster Th8A and TSS handbrake, 2xUSB Hub, 4 sensors, bluetooth dongle, mouse, keyboard, wireless keyboard, Xbox controller...)

Game unplayable when I connect a G27 in VR mod. 
Stuttered every 5 seconds. Also in very low graphical setting.


No issue with a Xbox controller. 
Does not happened in Dirt Rally 1, AC, ACC, PCars2.

After investigate a lot I found that it is related to my usb peripherals.

My USB C to VGA connector connected to my nvidia RTX 2080 for my principal monitor make these stutters happened when I connect my G27 in VR mod..... While my screen is disabled in the nvidia setting panel... But a physical disconnection fixed the issue.

Can you fix this ? I do not want to disconnect my screen every time I want to play.

Beside that, thanks A LOT for your work, this game is really EXCELENT.

Sorry for my english I am french.

Regards,

Share this post


Link to post
Share on other sites
  • 1

Running deluxe DR 2.0 on steam, windows 10 1903, Oculus Rift S.

 

I'm getting heavy stuttering in game in the HMD, as if the tracking is completely out of whack. Framerates seem to be OK, been running really low settings to eliminate that.

Stutters are especially noticeable when looking around to the sides, when I do really small movements (I.E. looking straight forward on a long straight) the tracking seems solid, but any larger movements (going from straight forward to looking through the side window for example) causes the view in the HMD to stutter like hell, making playing it vomit inducing.

If I look at the monitor render of the game it doesn't look like it stutters at all, so it appears to be something that happens with the projection onto the HMD display rather than a tracking error in the headset.

All other VR games work flawlessly, so not issues with the HMD or the computer.

 

  • What platform you're playing on (Steam or Oculus): Steam
  • What headset you're using:  Oculus Rift S
  • What your PC setup/build is like : i5-7600K, geforce 1080, 16GB RAM
  • Whether you're a Standard or Deluxe user (Steam only): Deluxe
  • Whether or not you have any non-standard peripherals connected, like steering wheels, gaming mice etc. : T300RS
  • Agree 1

Share this post


Link to post
Share on other sites
  • 1
Posted (edited)
  • platform Oculus
  • headset Rift S
  • PC setup  1080ti, 32gb, 6-Core i7 5820K @4.3Ghz
  • non-standard peripherals TM T300RS, Fanatec CSL Elite Pedals with load-cell, Fanatec Handbrake, Fanatec H-Shifter, HyperX 7.1 Audio (USB)

 

I have the following issues concerning VR:

  1. Poor dark colors. The dark sky and the dark areas on the landscape and streets have something about 8 colors? It looks very strange and irritates while driving. A lot of bending. Awful. Any time, I get a dark stage, I think "Oh no, this is gonna be an ugly drive".
  2. No Hotkey for HMD-Reset. Really? Codemasters: It is really important to match the position of the car steering wheel with the real one. Right now, u have to match a blurred scenery, in the pause menue. This is... awful.
  3. No undistorted fullscreen single eye mirror output on screen while driving. Codemasters, how can I record my fun in DR2.0?
  4. No undistorted fullscreen single eye mirror output on screen while in the menues. My eyes are already stressed, when finally sitting in the cockpit. Pls mirror the menue on the screen.
  5. -> Not possible to operate the menues without wearing the HMD... Why? Pls make it working like in all many other racing VR-titles. Menues on screen, driving in VR.
  6. Sometimes the sound nearly disappears completely. Restart of DR2.0 solves this. Using additional headphones
  7. The autoexposure makes the scenery too bright in dark cockpit cars with small windows. Maybe only on the Rift S? Please give us hotkeys for adjusting the exposure... It is gonna so bright, I cant see the structure on the streets/ways anymore. When moving the head, it is very sensitve and changes all the time from darker to too bright.
  8. Not possible to play DR2.0 in 2D. VR only... That's bad. Steam-Users can drive in both modes, I think.
  9. No Ingame-Shop to buy the DLCs, which are already available on Steam.
  10. Replay not in "real" VR.

 

Kind Regards
Vannipo

Edited by Vannipo

Share this post


Link to post
Share on other sites
  • 1
On 8/9/2019 at 8:48 AM, IISargeII said:

Hi,

Over the last day or so, I've been trying to figure out why the game is seemingly lagging when looking around in VR. My framerate is fine; steamvr is set to run at 90hz, and the game is holding a solid 90fps on medium to high settings. CPU usage is around 50 to 60%. As soon as the view changes from 2d in the cut scenes, to vr, I look around and the lag makes me feel quite ill. It's as if you look left or look right, and the screen movement is slightly behind or at times, the screen moves with you. This problem exists regardless of graphics settings, from ultra low to high. 

The problem is also noticeable when you pause the game. If you look at the menu and turn your head left and right, the menu partially moves with you to a degree. At first I thought the fov settings were wrong, but there's no way of changing it in VR that I could find. The option for fov does exist within the 2d mode, but changing it in that mode has no baring on the vr mode. 

While I'm at it, the view reset doesn't seem to work properly neither, it always sets me in a position that is too far away from the steering wheel... leading me to think that there is indeed problems with the fov. Whether this is the reason for the laggy feeling I get when looking around, I don't know. My pc specs are below. Thanks for your time.


Platform: Steam VR/Open VR
HMD: Valve Index
PC: RTX 2080ti, i7 6700, 32gb RAM
Deluxe User
Connected: Accuforce Steering Wheel, Heusinkveld Pedals, Handbrake and Shifter

I'm having the exact same problem, the game is lagging when looking around and my framerate is fine.

Platform: Steam VR/Open VR
HMD: Rift CV1
PC: GTX 1080, R5 3600, 16gb RAM
Deluxe User
Connected: Fanatec Csl Elite Wheel and Pedals, Logitech Shifter.

 

  • Agree 1

Share this post


Link to post
Share on other sites
  • 1

Another user reporting severe head tracking lag, using Vive Pro.  9900K/1080Ti.  Performance is actually really quite good, from an outright framerate and image quality perspective.  Better than I expected having read the initial reports.

But yes, despite hitting 90Hz there is a severe - and frankly bizarre - head tracking lag.

Same regardless of SteamVR branch.

  • Agree 1

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

Steam/PC WMR Samsung Odyssey+ 2080ti 32GB RAM I7 8700k all @stock

 

1st thing I remarked while testing was the missing mouse-function. Do not know if it's wanted - but I miss it ...

Edited by Flens07

Share this post


Link to post
Share on other sites
  • 0

Hi, my world scale is much to big. My steering wheel looks like a 40 cm diameter wheel.

 

  • What platform you're playing on (Steam or Oculus).

Steam VR

  • What headset you're using.

Lenovo Explorer

  • What your PC setup/build is like (graphics card, processor etc.).

2080Ti, 16 GB RAM, Core i7 4770k, Win 10 Pro. No overclocking or similar special. 

  • Whether you're a Standard or Deluxe user (Steam only).

Deluxe

  • Whether or not you have any non-standard peripherals connected, like steering wheels, gaming mice etc.

Doesn't matters in this case.

  • Like 1
  • Agree 1

Share this post


Link to post
Share on other sites
  • 0
  • What platform you're playing on (Steam or Oculus).
    Steam
  • What headset you're using.
    HTC Vive
  • What your PC setup/build is like (graphics card, processor etc.).
    Mobo: Intel DX79TO Extreme Series
    i7-3930K CPU @ 3.20GHz 3.20GHz
    RTX 2080 Ti Founder's Edition
    RAM 32GB HyperX 1600Mhz
    Logitech G29 wheel
  • Whether you're a Standard or Deluxe user (Steam only).
    Deluxe
  • Whether or not you have any non-standard peripherals connected, like steering wheels, gaming mice etc.
    Logitech G29 wheel

    =====================

    When I turn on in VR mode the game stops at the "push start to continue" screen.
    On this screen I can't do anything. No button works. Keyboard or steering wheel don't work.
    The sound doesn't work either.

Share this post


Link to post
Share on other sites
  • 0
4 hours ago, Flens07 said:

 

1st thing I remarked while testing was the missing mouse-function. Do not know if it's wanted - but I miss it ...

 Yes, very unhandy with a VR on your head and trying to find a button on the keyboard because no mouse. I have the power shutdown button next to f12 so have to be carefull to hit f11...

Share this post


Link to post
Share on other sites
  • 0

Steam

Vive Pro

i7 8700k, 1080ti, 16gb,

Deluxe

Game starts in VR to just a black empty display, I can hear the game music but nothing visible at all. All other VR games still working as normal.

  • Agree 1

Share this post


Link to post
Share on other sites
  • 0
  • Steam version

    Oculus Rift

    i5-6600k rtx 2070 super, 16gb,

    Deluxe

    Game starts in VR with black empty display, if I remove headset I can see message VR Headset removed. Other Steam VR games run fine.

  • Agree 2

Share this post


Link to post
Share on other sites
  • 0

I had this, but by mashing the enter button on my wheel I managed to load a stage with the Fulvia and it was visible in VR. I managed to complete the stage, but any of the 2D menus before or after the stage were black screen. I'm on the steam VR beta too. HP Reverb/WMR/SteamVR. 

i7-7700K/GigaByte RTX 2080/Win10 64bit/32Gb RAM/Asus Xonar DX+Beyer Dynamic DT990 Pro headphones/LG 34" UM65 @2560x1080/HP Reverb/Logitech G29+G25 shifter/DSD P2 button box

Share this post


Link to post
Share on other sites
  • 0

Another issue, I now can't figure out how to start the game in 2D mode and bypass VR for the time being. Any ideas?

Share this post


Link to post
Share on other sites
  • 0
25 minutes ago, JamesWhite said:

Another issue, I now can't figure out how to start the game in 2D mode and bypass VR for the time being. Any ideas?

Deinstall SteamVR then DR 2 will start in flat mode.

I had also the blank screen problem, deinstalled SteamVR changed the game to window mode, installed SteamVR and was able to see also tne menu. Could also be that's depending on the new SteamVR beta 1.7.2, atm on 1.6.10

  • Agree 1

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)
2 hours ago, JamesWhite said:

Another issue, I now can't figure out how to start the game in 2D mode and bypass VR for the time being. Any ideas?

In file ‘’hardware_settings_config.xml’’ 

Change value ‘’true’’ for value ‘’false’’

So it is now

<vr enabled=’’false’’ eyeDistanceMultiplier=’’1.000000’’ lockedOrientation=’’false’’>

Edited by Robytoo
rephrased
  • Agree 3

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)
10 hours ago, Robytoo said:

In file ‘’hardware_settings_config.xml’’  

 

Change value ‘’true’’ for value ‘’false’’

 

So it is now

 

<vr enabled=’’false’’ eyeDistanceMultiplier=’’1.000000’’ lockedOrientation=’’false’’>

 

This solution works without removing steamVR, which would mean no VR games at all for me :classic_sad:. I changed to windowed mode in the same config file and still had the black screen/no menu issue with steamVR beta 1.7.2, I'll try rolling back to the previous version, that seems to be the issue.

 

edit: rolled back SteamVR to 1.6 and used windowed mode, headset display remained black, game loaded ok on screen and I could navigate menus on screen, but even when I got into 3D and the stage start it stayed black in the HMD. The view was visible on my monitor and I could drive the stage so long as I kept the Reverb on my head and peeped out below the visor. I'll forget DR2.0 VR for a bit and check back in a month or so, good luck guys, hope it starts working one day.

i7-7700K/GigaByte RTX 2080/Win10 64bit/32Gb RAM/Asus Xonar DX+Beyer Dynamic DT990 Pro headphones/LG 34" UM65 @2560x1080/HP Reverb/Logitech G29+G25 shifter/DSD P2 button box

Edited by JamesWhite
added more info.

Share this post


Link to post
Share on other sites
  • 0
14 hours ago, bitola84 said:
  • Steam version

    Oculus Rift

    i5-6600k rtx 2070 super, 16gb,

    Deluxe

    Game starts in VR with black empty display, if I remove headset I can see message VR Headset removed. Other Steam VR games run fine.

the same with me ..

Share this post


Link to post
Share on other sites
  • 0
21 hours ago, RagingBeard said:

Steam

Vive Pro

i7 8700k, 1080ti, 16gb,

Deluxe

Game starts in VR to just a black empty display, I can hear the game music but nothing visible at all. All other VR games still working as normal.

Try opting out of the steam vr beta. An update to beta broke this yesterday evening.

Share this post


Link to post
Share on other sites
  • 0
14 minutes ago, deadsunrise said:

I've been testing a ton of combinations for about 5 hours with a Valve index, i9-9600k, rtx2080ti. All drivers updated for the wheel (TMX), headset, controllers, base stations and GPU/OS. I usually play with settings as ultra at 4k. 

Something is seriously broken in the OpenVR release.

[...snip...]

The juddering has something to do with steamVR's chaperone system. My driving rig is just outside the chaperone boundaries and every couple of seconds I can see steamVR trying to get the chaperone view to come through. Reseting the room and removing room-scale from SteamVR's setup fixed it a bit. 

Using OpenVR-AdvancedSettings to disable the chaperone system opens a whole new can of worms and bugs.

Thanks for commenting @deadsunrise .  Funnily enough, I also happen to have my driving setup just near the boundary (one corner) of my defined play area... my head is just inside enough that it can be tracked properly by my 2 Oculus sensors/cameras. So maybe that is a possible cause of it, although I do have the boundary/Guardian disabled for driving. Kind of hard for me to move things around to test though!

It's actually reassuring in a way that this juddering is not an Oculus-specific issue with the Steam version. I've seen a few people on the Steam forums mention having similar stuttering with the Index too.

Like you say, it's probably something related to either SteamVR or CM's integration with it. Perhaps CM mostly tested the SteamVR edition on Vive & assumed all other headsets would work ok?

Sounds like the Oculus store version is fine for Oculus hardware, but I'm not willing to buy multiple copies of the game.

I'm hopeful this stuttering will be fixed for the Steam version, for both Oculus & Index users.

Share this post


Link to post
Share on other sites
  • 0

My current experience...

Non VR - boots up, things seem to work including steering wheel.

With VR - (when I get it to load properly, which involves making sure steam VR isn't running too) - my g29 steering wheel isn't recognised at all, nothing with VR controllers, managed to get keyboard to respond on a couple of occasions loading it - haven't managed to play anything yet. Bought game purely for VR side! 😞

- Oculus rift playing on Steam

- i7 6700 + 16gig ram, win10 pro, Radeon R9 290

- Standard steam user

- Logitech G29 (works in other software + appears in Logitech gaming software. Picked up by Dirt Rally 2 when VR was completely unplugged/disabled.

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)
2 hours ago, Babbage said:

- Logitech G29 (works in other software + appears in Logitech gaming software. Picked up by Dirt Rally 2 when VR was completely unplugged/disabled.

I have a G29 and so far no problems since the game came out.

I have VR problem with Oculus Rift. When I use High or Ultra settings then picture stutters when I move my head. When I use Medium settings then VR is playable and its really fun.

I use: Steam Deluxe, i5, 1080Ti, 16GB RAM etc.

Edited by ChLoNiCaL

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×