Jump to content
  • 3

DiRT Rally 2.0: Version 1.7 Bug-Reporting Thread

Question

IMPORTANT: Read and understand this entire opening post before replying, as providing the right amount of detail will help out the team immensely in tracking and resolving any bugs that arise, thanks.

 

ALSO: For VR-specific bug reporting, head here: 

 

DR2_Subaru_WRX_NR4-(2).JPG

 

 

Before posting, please make sure to follow these guidelines. Without adequate information the team will have trouble identifying and fixing bugs, so please provide as much info as you can:

  • Check if a bug has already been reported.
  • If you reported a bug in a previous version of the game, check your game first to see if it's been fixed.
  • If a bug has been reported and you are experiencing the same issue, hit the upvote icon: 

    image.png
     
  • The more popular bug posts will have a better chance of catching the attention of the team.
    Also, this thread allows us to sort comments by how many votes they have, so make use of that feature 🙂 
  • If a bug cannot be reproduced, it cannot be fixed.
  • When you experience a bug, please try to trigger said bug again if you can, and show us the steps you went through to trigger it.
  • Text steps are good, video even better.
  • One bug per post please, for our tracking purposes. That way every bug gets its own URL for us to investigate.

 

Please also provide the following:

  • What platform you're playing on (for PC also state Steam or Oculus).
  • What your PC setup/build is like (graphics card, processor etc.).
  • Whether you're a Standard or Deluxe user (doesn't apply to Oculus).
  • Whether or not you have any non-standard peripherals connected, like steering wheels, gaming mice etc.

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

Hi all, we now have a VR FAQ and performance guide.

Please have a read through and attempt these changes if you're having issues.

On our test rig we were able to increase framerates from ~60 FPS to 90 FPS+.

 

 

 

We've also for an general FPS fix for Steam players who have stuttering issues.

 

 

  • Like 1

Share this post


Link to post
Share on other sites
  • 6
Posted (edited)

PjTierney,

 

BUG: New patch reset Graphic Settings.

 

EDIT: Not only graphics reset. Also Sound settings reset. Difficulty settings reset. Some personal vehicle settings no longer present. Head cam position reset in some vehicles. 

 

I reverted to settings I was running before 1.7 update and I am now getting FPS drops that I was not experiencing before. Possibly related to V-Sync. I have to turn off V-Sync now. I have current driver for my graphics card (downloaded today). Also, contrast is much higher than before and changing brightness settings do not effect. I also tried changing contrast on my monitor and it didn't help. 

 

Now I have a poorly optimized game that ran perfect before.

 

PC on Steam(Deluxe)

GeForce GTX 1070

Driver version 431.60

Intel(R) Core(TM) i7-7700 CPU@3.60Hz

16 GB RAM

3440 X 1440, Hz60 (overclock 100Hz)

Logitech G29 w/shifter

Fanatec ClubSport Handbrake

 

-Joseph

Edited by JosephM635
  • Agree 3

Share this post


Link to post
Share on other sites
  • 6
Posted (edited)

Persistent bug from previous version: Sound Cut Out during stage. Work around was to unplug audio device (logitech G35 headphones), wait for windows audible device change notification, then replug headphones.

Today's occurrence was as follows:

  1. Enter Daily community event Group B 4WD @Spain.
  2. Select vehicle Peugeot 205 T16 Evo2
  3. Commence stage
  4. Sound cut out during stage approx mid-way
  5. Pause game
  6. Unplugged headphones
  7. Waited for windows audio device change notification
  8. Replugged headphones and continued to stage finish with sound.

System Details:

  • PC steam, monitor
  • RX580 GPU, i5 2500k CPU
  • Deluxe
  • Fanatec peripherals
Edited by KoAStR
Will update with other car/track combo's where this occurs: Daily Event Porsche GT @Spain (Ribadelles).
  • Agree 1

Share this post


Link to post
Share on other sites
  • 5
Posted (edited)
On 8/8/2019 at 3:07 PM, PJTierney said:

The more popular bug posts will have a better chance of catching the attention of the team.

To be honest if there are bugs they should be solved without a need to upvote it ... bugs are nothing where the "Like" philosophy is the right way to go on.

Riggs had invested a lot in summing up the bug lists and the teams should work them out.

After each version the same bugs even from version 1.0 are still in the game and each time when a new patch is rolled out the procedure with the same and some new bugs starts again.

Edited by Peter Mathen
typos
  • Agree 3

Share this post


Link to post
Share on other sites
  • 5

Running on PC, windows 10 1903 update.

Just wanted to report that I've started having the sound cutout bug in 1.7. Quite often, about every third stage. Never had it before on any version. Did update to Windows 10 1903 update just before 1.7 came out, if that will be of any help to you getting to the bottom of it. I can get the sound back by pausing the game, alt-tabbing to the desktop and choose another sounds source then switch back in windows, then alt-tab back into the game.

Share this post


Link to post
Share on other sites
  • 4
Posted (edited)

Persistent bug from previous versions: random wipers with wiper setting set to manual still present.

  • PC steam, monitor
  • RX580 GPU, i5 2500k CPU
  • Deluxe
  • Fanatec peripherals
Edited by KoAStR
  • Agree 1

Share this post


Link to post
Share on other sites
  • 4
Posted (edited)

Pacenotes:

There are multiple places where pacenotes need changes, even this far down from release. Monte Carlo for example, desperately needs some extra 'cautions'. For example in 'Route De Turini' you will encounter a '4 left'... which becomes a 1 right, and Mills will wait until you are entering it to tell you this. It's actually a nasty chicane with one of those low walls sticking up on the left, and it's absurd there is no 'caution' for it.

Further along the same stage (after the snow patches on the road start to appear) is '3 right tightens', which again needs a caution, there being again a low wall sticking up on the left. You know the type. You will be aimed straight at it.

Further along, there is a '4 right long, tightens 3'. This will see you collide straight into another of those low walls on the left (driving into the start of the wall as it sticks up), unless you really slow down. Again, needs a 'caution'.

Bizarrely, further up in the stage, there is a 'Caution' for a '4-right' which is entirely unnecessary.

 

Edited by Jake Cushing

Share this post


Link to post
Share on other sites
  • 4

PC / Steam / Win 10 / DR2 v1.7

Audio Cut Out bug in middle of stage -> this bug is here since beginning, when will this be solved?

To get the sound back (as often written), switch in Win sound settings the audio standard device to another device and back to the used device (HMD headset).

Share this post


Link to post
Share on other sites
  • 4
6 hours ago, JorritVD said:

You should make a video or screenshot.

Tried to upload a video but the file is too big. Here are two screenshots. Notice the car in front of the pack? This is a semi-final. After it goes to the in car view... the other car morphs into mine and causes critical damage.

 

any solutions? 

1CB09E97-2BA1-4B7F-958D-A5DCB7E75AF0.jpeg

604742F0-6AEA-497E-9492-E3FD73CB0D74.jpeg

  • Agree 2

Share this post


Link to post
Share on other sites
  • 4

There is no BOV sound on practically any vehicles if you are using pedals to drive around.   I am told the sound is there on some hand held controllers though.   Really sad as it sounds like a relatively easy fix and all the effects are on standby.

Edit: You can hear the BOV sound though using a keyboard.

Steam/Windows10/Fanatec V3 pedals.

 

Here is a video from @caerphoto showing an example 

 

Edited by bn880
  • Agree 1

Share this post


Link to post
Share on other sites
  • 3

Just some bad or late calls in Bjorklangen, this is on earliest settings

0:45 Late call for 3 left

1:17 WRONG call for keep middle over jump, should be keep right.

1:28 3 Left call is a bit late but is inconsistent with other 3's prior to it which are much faster, so should be called as 2 left.

 

re-reporting it here from Discord so it's not missed if notes are revisited.

Share this post


Link to post
Share on other sites
  • 3

Regression: Fanatec wheels keep showing the RPM/Shift LED's in reverse since 1.4 or 1.5.  NOT a Firmware issue. This happens without updating your Fanatec FW< and also apps like Fanaleds still work with the wheel correctly.

 

Edit: I just noticed another user reported this for CSL Elite, it also has some upvotes it seems.

Edited by bn880

Share this post


Link to post
Share on other sites
  • 2
Posted (edited)

Game has become unplayable due to graphics glitches (freezes every couple of seconds) introduced by this 1.7 update. Changes to graphics seems to make no difference whatsoever - even tried on ultra low settings and no luck! Please, please fix this Codemasters! Every new update seems to introduce new issues.

PC on Steam(Deluxe) 
GeForce GTX 1050 
Driver version 431.60 
Intel(R) Core(TM) i7-4790 CPU@3.60Hz 
8 GB RAM 
1920 X 1080, Hz60
Logitech G25 w/shifter 

After reading later posts uninstalled and reinstalled Logitech Profiler and game is now back to normal and playable again thanks to those who suggested link to Logitech wheel affecting graphics performance!

Edited by COL970
Problem solved

Share this post


Link to post
Share on other sites
  • 2
Posted (edited)

Persistent Bug from previous version: In some cases, items on lower part of repair list in "vehicle preparation" area (before launching an event) remain on "no fix" after pressing "recommended repairs" on default screen. Scroll down to bottom of list and reselecting "recommended repairs". Not sure if it's random or car/track specific.

Today's occurance was as follows:

  1. Enter Daily community event Group B 4WD @Spain.
  2. Select vehicle Peugeot 205 T16 Evo2
  3. Select "Repairs tab"
  4. Press button "recommended repairs"
  5. Scroll down repair item list and see some items still show "no fix"
  6. Press button "recommended repairs" again
  7. All items now show recommended repair option.

System Details:

  • PC steam, monitor
  • RX580 GPU, i5 2500k CPU
  • Deluxe
  • Fanatec peripherals
Edited by KoAStR
Will update with other car/track combo's and whether it occurs: Daily Event Skoda R5 @Monaro Australia

Share this post


Link to post
Share on other sites
  • 2
Posted (edited)

Bug reported with the released version 1.7 : all graphic setup disturbed (reseted ?), shadows (of car and movable objects) completely disappeared.  Graphics were already at the edge of quality, now it's really ugly (and new personalization setup trials did not lead to improvement in that regard anymore !!).  What were the possibly improved features with this new version ?

Processor : Intel Core i5-4440 CPU @ 3.10 GHz, 8.00 GB RAM

System : Windows 10 Home Edition

Graphic card : AMD Radeon HD 5800 Series / Intel HD Graphics 4600

Controller : Logitech Wingman

Deluxe edition

image.png

Edited by ledid

Share this post


Link to post
Share on other sites
  • 2

Csl elite bug

The revlights of the wheel and wheelbase works back to front (from blue to yellow) is it possible to let them work on the other way(yellow low rpm and blue high rpm) ? 

  • Agree 1

Share this post


Link to post
Share on other sites
  • 2
Posted (edited)
8 hours ago, JorritVD said:

You should make a video or screenshot.

Photo 1: Semi Final Line up grid... cars in front? 

Photo 2: My car slanted and destroyed at start.

A0D2D538-78F6-4165-85F1-73521DD90899.jpeg

22BECF45-34C7-42BA-8B3F-F6DF0D7871A6.jpeg

Edited by BlackCatMatt

Share this post


Link to post
Share on other sites
  • 2

AI BUG: Second to last corner in Estering RX circuit, the AI is way too slow (safety car like pace). They are actually faster going on the Joker Lap against themselves. At MAX difficulty the issue is still present.

Proof reference (a video I recorded. AI max difficulty):

They lose a ton of time on that last part of each lap.

GTX 1060
i5 4590
8gb RAM
System settings and drivers are irrelevant.

  • Agree 1

Share this post


Link to post
Share on other sites
  • 2

Bug of engine idle audio not playing, engine audio under physics load pulling up to the line.

load any stage, chance of getting engine audio playing under load instead of idle is about 85% - normally resumes correctly when the handbrake is pulled, sometimes doesn't.

 

 

  • Agree 1

Share this post


Link to post
Share on other sites
  • 2

On all rallycross cars and stages. When you change gear in dashboard view in turn driver is moving hand from gear to wheel back to gear back to wheel non stop super fast. It ruins the game for me. Pls fix this it was reported in 1.1..

 

PC/Steam/Xbox One controller/ Manual gears

Edited by VertuVertu

Share this post


Link to post
Share on other sites
  • 1
Posted (edited)

Audi Quattro, Sierra cosworth, escort cosworth have the wrong soft lock in the game these vehicles should all have 720 degrees.

xbox one x

deluxe edition

thrustmaster tx

Edited by Evo8uk

Share this post


Link to post
Share on other sites
  • 1

Car Unlock Glitch:

Just like with the C4 + Fabia you can glitch the game to unlock the 01 Focus + 01 Subi right now. Same method as before. I have DM’d PJ but if you need more details I can DM anyone from CM the details.

Share this post


Link to post
Share on other sites
  • 1
  • What platform you're playing on. 
  • - Steam, PC
  • What your PC setup/build is like (if playing on Steam).
  • - i7, 16GB RAM, GTX 750Ti 
  • Whether you're a Standard or Deluxe user.
  • - Deluxe
  • Whether or not you have any non-standard peripherals connected, like steering wheels, gaming mice etc.
  • - No

 

Bug:

  • The new "Consolidation Finals" elimination setting in custom RX events needs a toggle on/off in event settings rather than just being on regardless in order to allow us to play the way we want to, simulating Euro RX seasons for example where consolidation finals are not used
  • Agree 2

Share this post


Link to post
Share on other sites
  • 1

I'm getting quite bad stutters in the game now. Every couple of seconds it just freezes for a bit. Both in VR and on normal screen. It's quite jarring especially in VR rendering it basically unplayable. I'm on a 3700x with a 2080 super, so that shouldn't be an issue. Having these regardless of graphical settings.

  • Agree 2

Share this post


Link to post
Share on other sites
  • 1

Same issue as JellyD. No VR here, but even the menus are dropping down to 15-40fps at random and the inputs on the controller are no longer responsive. Inputs will be dropped or skipped and later multiplied. The game seems totally broken compared to the last version, and that's not even gameplay. During an actually rally / race there's a lot of new stutters and hitches and freezes, and that's with gsync active. Something is busted somewhere.

  • Agree 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×