Jump to content
  • 0

DiRT Rally 2.0: FPS & Stuttering Guide (Steam, non-VR)

Question

Posted (edited)

DR2_AstonMartin_Vantage (2).jpg

 

Over the last while we've seen issues where players on Steam report stuttering and general FPS issues, and after investigating it a bit further we wanted to put together a short guide to help with this.

 

WARNING:

Quote

 

Change these settings at your own risk and use common sense before committing to them. Some changes as some may adversely affect your playing experience.

Please also note that any graphics card setting changes will affect all of your games and not just DiRT Rally 2.0.

 

 

Windows PC users:

  1. Disable Game Bar in Windows Settings.
  2. Disable "Steam overlay while in-game" in Steam settings.
  3. Make sure "Compatability Mode" is disabled on the .exe file for DiRT Rally 2.0.
  4. Enable Vsync and verify that the Frame Rate setting is at 60hz.

 

If you're using an NVIDIA graphics card:

  1. In NVIDIA GeForce experience settings: Disable in-game overlay.
  2. In NVIDIA Control Panel > Configure Surround > PhysX: Select your graphics card in PhysX.
  3. In Manage 3D Settings: Find DiRT Rally 2.0 in programs (most likely under Steam) > [Add]
  4. In the settings for the program select the following:
    . CUDA - GPUs: [Use these GPUS] > Choose your graphics card model.
    . Maximum Pre-Rendered Frames: 1
    . Power Management mode: Prefer Maximum Performance
    . [Apply]
     

In-game:

  1. Graphics: Set [Crowd] to anything below [Ultra].
  2. Ensure that multisampling is set to an appropriate setting for your PC spec.

 

Additional tips:

  • Remove all non-essential USB devices (including wheels and VR equipment) before launching.
    Once the game is launched plug in the devices you wish to use.
     
  • Alternatively you can disable all non-essential USB HID devices through the following steps:
    Device Manager > Human interface devices
    Right-click on the relevant USB devices and select [Disable].

 

If you were having stuttering or FPS issues before this, please try the above and share your results in this thread.

 

Edited by PJTierney
Added USB Tips

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 2
Posted (edited)

Here are some quick results since the 1.7 patch using all those recommend settings on i7 4790k & Nv 2060, I'll type out what's different.

I had ran all these setups without the graphing first to be sure it wasn't an influence, and experienced pretty much the same results judging the stutters by my eyes. The afterburner graph just highlights what's happening and how often visually on the frametime and framerate graphs (ignore the big drops and spikes at the end, those are me alt-tabbing out to screenshot the graph). Generally the stutters are random, although sometimes they do occur at similar sections of the same routes. Sometimes they're tiny and sometimes they're huge. Sometimes they're very frequent, sometimes I'll only see a handful in a race.

I've really found no fool proof way to eliminate this random stuttering entirely, only lessen it. Pre-rendered frames set to 1 is worse than 2 or 3 in my experience. Vsync with framerate maxing refresh rate is generally the best, but still stutters, sometimes they're minor, sometimes major and can influence a run and even cause a wreck. Vsync unfortunately adds too much additional input lag, even with the pre-rendered frames set to 1. Gsync active and fps capped below refresh rate stutters just the same, the engine doesn't really seem to like framerate caps or variable sync technology all that much, although pre 1.7 I definitely had Gsync working a lot smoother in Dirt Rally 2.0 with nearly no stuttering most of the time as long as pre-rendered frames were set to 2 or 3 (1 introduced an insane amount of stuttering), and this was still better than vsync due to the input lag reduction.

Gsync generally smooths out minor framerate and frametime variances in all other games that I've tried, but here the stuttering shines through that as if variable sync isn't even active, but really the engine or game itself seems like it's struggling / hitching / hiccuping at random no matter what. On the graph they just look like simple frame drops and frame time spikes, but every one of those is like the game is skipping or dropping those frames entirely, causing the visible stutter, even with Gsync. Also worth mentioning that if I increase the resolution (downsample from 4k for example) and crank up the details so I'm actually not maxing the refresh rate or hitting the fps cap and the framerate is variable below, Gsync appears to be working since there's none of these frameskip type stutters or screen tearing, but this wildly variable framerate isn't an ideal way to play, and some sections of the events it will still reach the fps cap or refresh and resume the stuttering again.

Post 1.7 update, the game can also totally break down, this is what the graph looks like when that occurs @ 60hz & Pre-rendered frames 1 - when this happens, the contols become unresponsive in both the game and menus, and nothing I've tried fixes it outside of a full system reboot. Yet it can still be like that after a clean launch, it can happen after some time in game, it will likely happen if I play the game for some time, quit out, and reload it later, even an alt-tab out and back in can introduce it. This never happened to me before 1.7, and now it's happening more frequently than the audio drop out bug ever did. Something is seriously wrong somewhere! *I think I've nailed this down to a controller issue. Unsyncing and uninstalling my Xbox One pad and moving my bluetooth receiver to a different USB port seemed to rid the game of these occurrences, but only this game was afflicted with that issue when using the gamepad which is very strange and leads me to believe the game is still at fault there. If anyone is still experiencing similar breakdowns and unresponsive controls after 1.7, do try to completely reinstall your main input devices for this game.

Other minor observations: The game does not seem great with framerates above 60fps, but it still works where it counts to some degree. Running at my display's 75hz refresh certain things are no longer smooth, like looking around the cockpit with the right stick, the opening service area camera zoom in, as well as the finish line camera after an RX race. The car basically teleports along from that camera at 75hz while it renders smoothly at 60hz, and likewise the camera stutters a lot more at 75hz compared to 60hz when there's any movement to them, manually controlled or scripted, inside and out. Yet normal replays do not appear to exhibit this behavior. Another odd thing I've noticed is that the game will always stutter way more frequently after Windows10 has previously gone into sleep or hibernation mode and then woken, compared to a fresh reboot. I cannot make any sense of that as it's only game I'm currently playing which does this.

Edited by pyide

Share this post


Link to post
Share on other sites
  • 1

Updated with the following:

 

Additional tips:

  • Remove all non-essential USB devices (including wheels and VR equipment) before launching.
    Once the game is launched plug in the devices you wish to use.
     
  • Alternatively you can disable all non-essential USB HID devices through the following steps:
    Device Manager > Human interface devices
    Right-click on the relevant USB devices and select [Disable].

Share this post


Link to post
Share on other sites
  • 1
Posted (edited)

( EDIT: I just wanted to make clear, I had no noticeable stuttering when playing on a monitor before the VR update. My comments below are specific to me using the SteamVR version of the game after the VR update. I notice the "non-VR" in the topic title, so please feel free to move my post to the VR bug thread if it's more appropriate. However, a number of people have suggested that USB devices/polling could be the cause of the periodic stutters certain players are getting every 2 seconds, some on much more powerful hardware than me, so my comments seemed appropriate in light of these additional USB-related suggestions on this thread, especially since they didn't work in my case... )

1 hour ago, PJTierney said:

Updated with the following:

 

Additional tips:

  • Remove all non-essential USB devices (including wheels and VR equipment) before launching.
    Once the game is launched plug in the devices you wish to use.
     
  • Alternatively you can disable all non-essential USB HID devices through the following steps:
    Device Manager > Human interface devices
    Right-click on the relevant USB devices and select [Disable].

Thanks for adding those, but unfortunately neither help solve the periodic CPU spikes & judder for me. I even tried unplugging everything including keyboard, just leaving mouse to launch the game. I was hoping this might work around the problem for now, as several people mentioned a possible cause being USB devices being regularly polled or similar by the game.

The CPU spikes consistently happen every 2 seconds (pretty much exactly every 2 secs), as reported on the other VR bug thread, matching charts someone else posted of the same CPU spikes. I can see the CPU usage spikes/pulses on SteamVR's "advanced frame timing" graph, each pulse lasting for a fraction of a second (perhaps less than 0.2s, I didn't take too much notice of the duration, but the frequency is almost exactly 0.5Hz, so there's clearly something happening repeatedly at that frequency causing brief but heavy CPU usage.)

The CPU spikes happen even with all the game's settings on the absolute lowest... and on those settings I'm clearly getting very fluid motion, and the hardware is easily capable of rendering at higher settings... except every 2 seconds my view "shudders" slightly for a few frames during the CPU spikes.

I've tried various tweaks suggested by the community & guides here but haven't found anything which works yet. I've tried all these plus some others I probably forgot...!

  • close all unnecessary programs
  • temporarily switched to SteamVR Beta v1.7.4
  • force the game to use windowed mode for the VR mirror display instead of fullscreen by editing the hardware config xml
  • disabled (lowered to zero) in-game "head shaking", just in case it was a bug with that
  • disabled Steam overlay
  • lowered the game's settings to minimum, including AA (worth mentioning since it's in a separate section of the game's options)
  • unplugged all USB devices including my wheel (except for just mouse or keyboard to launch/navigate the game! I tried once with each left plugged in!)
  • disabled USB HID devices in device manager
  • updated to latest Nvidia driver & also tried latest hotfix driver
  • Nvidia max render-ahead frames for VR = 1
  • all different options for Oculus ASW (CTRL+1/2/3/4)... interestingly disabling it (CTRL+1) seemed to make the game exhibit a constant jitter/delay with the game's tracking of the HMD, even when the framerate was very good, which doesn't seem normal at all... perhaps that's hinting at some kind of "fighting"/conflict between SteamVR & the game, in determining the position of the head/view? Or some kind of out-of-sync / delay on the game determining the head position? I mention that because I've noticed the floating HUD elements seem to track with that same kind of delayed response (regardless of ASW setting), like they're slightly behind the HMD movement (maybe just a couple of frames, only just perceptible), so they move slightly independently of eg. the windscreen etc. as you look around, and then they catch up when you stop moving your head. I just wondered if it could be related?
  • reduced 'Application Resolution' in SteamVR, but it didn't seem to make a visible difference even at the lowest 20% (which I would have expected to be extremely blocky/blurry, but the resolution in the HMD looked the same, so either this setting doesn't work with Rifts, or the game is overriding something?)

I run a number of other VR games on the same hardware, all the usual suspects of driving games which I won't bother to name, including the original DR... all without any problems. I usually settle for 45fps with ASW enabled, because my hardware isn't up to consistent 90fps, but that is perfectly acceptable to me, so I'm not expecting wonders here. DR2.0 does also seem like it would be plenty smooth enough, if it weren't for these regular brief judders every 2 seconds.

Reading around the various forums (Reddit, Steam, here) I've seen a number of people having the same issue, not just with Oculus hardware but also with Valve Index & with WMR headsets.

It would be interesting to find out if this issue is specific to the SteamVR build, but until/unless the native Oculus SDK build is made available as an option on Steam, we can only rely on feedback from people who have purchased on both stores (whether they own Oculus headsets, or use Revive with different headsets).

...

ONE QUESTION: Have CM managed to observe or reproduce this regular/periodic (every 2 seconds) judder / CPU spikes ? Or at least taken note of the reports that it exists so they can investigate ?

Thanks!

...

Steam / DR2.0 Deluxe / Oculus Rift CV1 + 2 sensors / i5-4460 + GTX970 + 16GB RAM / Logitech G29 + Shifter + Pedals

Edited by YorkyPudsy

Share this post


Link to post
Share on other sites
  • 0

Hi,

I have the periodic CPU spikes which a lot of people are experiencing due to problems with the game and USB input devices. By testing all of the above and more, I have determined it is caused by my Arduino Micro handbrake which for some unknown reason Dirt Rally 2.0 doesn't like. It works fine in game and registers ok but whenever it's plugged in it causes periodic 2second CPU spikes. Without it plugged in I get good smooth gameplay and no CPU spikes. It's such a shame this is a problem in this game, I hope you can fix it. FYI my handbrake has never caused a problem or this kind of behaviour in any other game including Dirt Rally 1.0.

 

I'll keep my fingers crossed for a fix.

Share this post


Link to post
Share on other sites
  • 0

I was able to play this game at maxed out settings prior to the FFB update. Following that update I was unable to maintain even 30 FPS on the low preset. I was in contact with CM support for a couple months and all their recommendations did not fix the issue. After running the gamut of the solutions offered, the final solution was to run the game in "safe mode" and just live with the tiny window and horrible graphics, which still wouldn't yield me 60 FPS. Following this, CM completely ignored all attempts to my replies or any new tickets I opened. I was unable to receive a refund for the game (deluxe edition too) from steam. I somehow CM managed to completely break the game with an update and has been unable to resolve it through multiple updates. I have a 6600k, 1070, and 16GB of ram and using an official xbox controller. I just tried all the solutions from this post and it has not fixed my frame issues. This was my favorite game in the world, and it is such a shame this happened. I cannot fathom how on earth this has happened from the devs. I wish I could get my 80$ back already after watching all the additional content that I paid for being added and being unable to play this game. 

 

Edit: Interesting observation in afterburner hardware monitor: GPU usage is usually 90-100% but GPU power percentage never goes above 50%.

Edited by mattj96

Share this post


Link to post
Share on other sites
  • 0

Most people would be helped if you change the damn code for the crowd.
This was already in DR 1 and D4 only optimized for AMD cards, which is why Nvidia users should change this option to 'LOW'. (There isn't much visible difference, especially while driving - 'LOW' is important)

In terms of frame rate, it's like day and night. (But don't turn them off completely, because technically you still have a invisible crowd you can drive into)
The card doesn't matter as long as it is a nvidia card, be it with a 960 4G and a old i5 CPU or with a RTX2070 and a new i7, it's the same well-known problem with the crowd - and various DR 1 tutorials have already taken this up - and it's still the case. And because some like to underestimate this option. The crowd is not just at the beginning, the end and the U-turns. They stand every few meters in the woods, hills, between the houses etc. Actually, they are almost everywhere. Their code is so bad that it really matters.

Attention: The last update did a reset on this option! You have to set it back to low.

The game bar tips are ****. It sounds like a windows hate train.
If you want to disable something then disable the windows background recording. 

Edited by DessIntress

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×