Jump to content Jump to content

FPS & Stuttering (PC, non-VR)

Recommended Posts

On 9/10/2019 at 9:58 AM, nbates66 said:

Figured I'd add this here, had a constant stuttering problem on new ASUS Strix motherboard based system, ended up clearing when the specific USB input device in this picture is disabled.

My motherboard is an ASUS ROG Strix B-450-I but it's probably a safe bet that ASUS use the same AURA RGB controller on their ROG B350, X370 and X470 ITX boards, if you have a PC based on any of these boards see if disabling this device makes a difference, Entirely possible my system is just an edge case but anyone who finds that disabling a USB device clears the stutter please take note of the devices details here.


Great, I have tried it and so I have solved it.

Link to post
Share on other sites
  • 2 months later...

I'm just posting here because i fixed an issue that a lot of players has :

My game runs at 5/10 fps on very low altought i have a good computer ( RTX 2070super, i7 cpu, 18Gb RAM, thrustmaster t150 wheel etc). You might even have this report when your game crash :
 "access violation at address 0x2e1cc875 in module 'dirtrally2.exe' + 0x8dc875. dirtrally2.exe"

I'll make it short for you because i know you are prob tired of trying a lot of solutions :

1) go behind your computer

2) unplug your screen and search for another hdmi port BEHIND YOUR GRAPHIC CARD, it might be hidden behind a plastic cover.

3) Now your motherboard recognise your main graphic device as your GPU and not your CPU, and the game should run smoothly.


i hope this helps, good luck "

Link to post
Share on other sites
  • 2 months later...

I have a few hours in this game now and it used to run fine. Lately however my steering wheel has been causing the game to stutter every two seconds. I have tried changing the graphics along with the ideas already in this thread. Nothing has worked.


Thrustmaster TMX Forcefeedback

Thrustmaster TH8A Shifter

PC Specs:

Ryzen 5 1500x

Gigabyte b-350 gaming motherboard

MSI Geforece GTX 1060 6gb gaming X

16gb ddr4 ram

Link to post
Share on other sites
  • 4 weeks later...
Since a few days ago. I can't get dirt 2.0 to work.
I have all my drivers updated.
I tried reinstalling the game, downloading the graphics but nothing works.
being that my pc meets the minimum requirements by far.

Could it be something to do with AMD compatibility?
If so, I hope I can receive some help.
Thank you ....
Link to post
Share on other sites
  • 2 weeks later...

I've noticed the source of my problems: Vehicle Details setting. For some reason going over 'Very Low' kills my fps. Playing with the bumper cam also fixes the problem (because you don't see anything from the car model).

I've been trying EVERYTHING for months and today I noticed it by accident (by changing the camera view momentarily). 

Anyone else having this issue? Or know how to solve it? 

My specs are have an i7 9700, NVIDIA 2060 super (with lastest drivers), 16 GB RAM, and the game is installed in an SSD.

Edited by RafaTMQ
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...