Jump to content
Sign in to follow this  

G29 Not working

Recommended Posts

Hello,

So, few days ago, I got this problem with my G29 : I opened Project Cars 2 to play and I found out that my accelerator was my clutch and that my FFB wasn't working anymore. Then I tried on Assetto Corsa Competizione and F1 2019, and there was the same problem. So I went on Codemasters forums to find a solution. Tried everything : uninstalled completely lgs then reinstall it, get a new G29, etc... Nothing working.. Please help.....

Share this post


Link to post
Share on other sites
1 hour ago, AltragF1 said:

Hello,

So, few days ago, I got this problem with my G29 : I opened Project Cars 2 to play and I found out that my accelerator was my clutch and that my FFB wasn't working anymore. Then I tried on Assetto Corsa Competizione and F1 2019, and there was the same problem. So I went on Codemasters forums to find a solution. Tried everything : uninstalled completely lgs then reinstall it, get a new G29, etc... Nothing working.. Please help.....

Did you try my fixes? I really wish Codemasters would make my solutions sticky....

  • Sad 1

Share this post


Link to post
Share on other sites

I did.. I also tried to uninstall PCars 2 then F1 2019 to see if ACC was working and it wasn't. I used Geek to uninstall lgs, and still nothing worked. I feel so lost, like, nothing is working and I still don't know where the problem really come from

Share this post


Link to post
Share on other sites
Posted (edited)
4 hours ago, AltragF1 said:

Okay, so I used that https://steamcommunity.com/app/737800/discussions/0/1733210552686272214/ and it solved the problem.. Though, the wheel is still not feeling like before in my opinion. I mean, it feel quite stiff compare to before so yeah, it's better but still very strange problem

Sounds like a PC2 problem then.

I will make a .reg fragment for people to download and install and quickly try and then attach it to this message later.

g29.zip

Edited by steviejay69

Share this post


Link to post
Share on other sites

Update

Today, I've tested a new solution, more stable than changing the binary code of the wheel or whatever it was. So I went back on the 00 00 00 10 00 00 00 00 code, then tested my wheel on F1 to see if it was magically working, obviously it wasn't, so here is what I did from that :

(!!!Always use a USB 2.0 plug to connect the steering wheel!!!)

1) Uninstall Logitech Gaming Software using geek uninstaller

2) Access the Game Controllers test page in Windows:
- Start > Control Panel > Devices and Printers
- Find the G29 controller
- Right click > Choose "Game controller settings" > Properties > Test > You can now test and calibrate G29 manually (I tried to test it and calibrate it but it was way too complicated langage for me so I just went on > settings (left of "test") and I reset it)

- Now disconnect the wheel

3) Install the !!!GHub!!!, no the Logitech Gaming Software.

https://support.logi.com/hc/fr-be/articles/360025298133-Logitech-G-HUB

4) When GHub is running, connect your G29 (USB 2.0), set the profile as default if it's not

5) Normally, everything should be good again

My conclusion is that I don't know if it's the step 2) or 3) that made the difference. As I had already tested GHub and it was not wirking, I guess it's the 2) but we never know so I would advice you to stay anyway on Ghub and not LGS anymore.

I hope it will be working for you guys, if not, it's at least one more solution on the internet to this damn problem



 

   

 

  • Agree 1

Share this post


Link to post
Share on other sites
10 hours ago, AltragF1 said:

Update

Today, I've tested a new solution, more stable than changing the binary code of the wheel or whatever it was. So I went back on the 00 00 00 10 00 00 00 00 code, then tested my wheel on F1 to see if it was magically working, obviously it wasn't, so here is what I did from that :

(!!!Always use a USB 2.0 plug to connect the steering wheel!!!)

1) Uninstall Logitech Gaming Software using geek uninstaller

2) Access the Game Controllers test page in Windows:
- Start > Control Panel > Devices and Printers
- Find the G29 controller
- Right click > Choose "Game controller settings" > Properties > Test > You can now test and calibrate G29 manually (I tried to test it and calibrate it but it was way too complicated langage for me so I just went on > settings (left of "test") and I reset it)

- Now disconnect the wheel

3) Install the !!!GHub!!!, no the Logitech Gaming Software.

https://support.logi.com/hc/fr-be/articles/360025298133-Logitech-G-HUB

4) When GHub is running, connect your G29 (USB 2.0), set the profile as default if it's not

5) Normally, everything should be good again

My conclusion is that I don't know if it's the step 2) or 3) that made the difference. As I had already tested GHub and it was not wirking, I guess it's the 2) but we never know so I would advice you to stay anyway on Ghub and not LGS anymore.

I hope it will be working for you guys, if not, it's at least one more solution on the internet to this damn problem 

 

G-Hub was definitely not working for some earlier, but I don't have the G(920) any more.

That software build of G-Hub is newer (July 23 2019) than previous, so who knows? 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×