Jump to content

Will stuttering be fixed?

Recommended Posts

So i was amazed to discover the issue i was having is not a new bug related to vr but has been around since launch. See here

posted back in February.  

The suggestion to just unplug your devices is ridiculous. 

Are Codemasters ever going to fix this what for me is a game breaking bug anytime soon or will i have to sadly return it? 

 

 

 

  • Agree 2

Share this post


Link to post
Share on other sites

Hmmm... thanks for linking that vid. That is a little worrying if the "every 2 second" judders have been present so long without being resolved. I had previously assumed it was a recent problem and/or VR-specific...

The video does seem to demonstrate the same periodic judder that I have observed in VR. From my testing, CPU usage peaks for a fraction of a second during each "hitch", but GPU usage remains consistent. Except in VR, instead of a complete "freeze" during those short periods of high CPU usage, I assume that Oculus ASW (or SteamVR's equivalent for other headsets) is kicking in to try to maintain fluid motion for your head movement. But perhaps due to the heavy CPU load and/or inaccuracies in head tracking, we observe that as a few frames of "shuddering" (imprecise/laggy head-tracking) instead of a completely frozen image.

Even with all the settings on the absolute lowest (where the framerate otherwise seems great in VR, even on my very modest setup), those same periodic judders persist.

The strange thing is I never experienced this before the VR update, on the same system and with all the same peripherals, when playing on a standard display. And more importantly, if it is USB-related, and perhaps linked to me plugging in an extra device (the HMD), then I can't seem to resolve it even if I remove all extraneous USB devices, including my wheel/shifter/etc. And it doesn't help if I disable various HID entries in device manager, as was also suggested.

I've never observed these "every 2 second" judders/CPU spikes in any other games, including any previous CM games, nor in various other VR driving games where I use all the same USB devices & VR headset. So, it would appear to be more likely an issue in the game itself?

I've already given a report of the issue, setup & numerous things I've tried during my troubleshooting on the main VR bug thread.

Hopefully CM can commit to investigating & resolving this, as like you say, it's not really playable.

Share this post


Link to post
Share on other sites

Weird thing is it does it during the cinematic sequences too. I read in another thread that this issue was actually around in dirt 1 although i didn't personally have it then. It's a shame as like you say seems to run pretty well in VR apart from this constant tick. 

Share this post


Link to post
Share on other sites

I can confirm. Being in VR, having 90fps, from time to time (not measured, about 15 sec) I can see drops to 87fps for fraction of a second.And it's when a car is not moving at all.

Share this post


Link to post
Share on other sites

I didn't notice the framerate changing so much. I seemed to be getting constant 45fps with Oculus ASW enabled, which I tend to prefer for driving games, rather than turning everything down to maintain 90fps & getting occasional hitches if ASW kicks in. At 45fps with ASW I had plenty of CPU & GPU headroom (especially on lowest settings). But what I did notice was big spikes/pulses in the frametimes/CPU on SteamVR's Advanced Frame Timing chart, exactly every 2 seconds.... which obviously perfectly matched the brief regular "shudders" in the head tracking, despite the framerate being good & consistent.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×