Jump to content
Sign in to follow this  

Dirt Rally shared memory multiple telemetry feature

Recommended Posts

So now that this is now an all out simulation. Can there be more support for multiple output telemetry for the game?
I have a d-box and a simxperience GS-4 seat for example, and they don't seem to work well together. It's either one or the other. 
Once there's d-box, you can't use other motion or shiftlights devices with the game. It's like the dbox port only works by itself and doesn't share the telemetry output. 
These features work flawlessly with AC and PCARs, I'm pretty sure the vast majority of hardcore simracers out  there will want this basic feature to support motion and even the latest simxperience accuforce wheel that requires in game telemetry output for it to work properly. 


Share this post


Link to post
Share on other sites
I've been told by Yannick Gemme from d-box that for f1 2015, since D-box is natively intergrated with codemasters games that there will be an extra data channel provided for simxperience and other devices. Can anyone that knows about the development of this game confirm this? If anyone could help me out where would be the official channel for the developers to get this noticed?

Share this post


Link to post
Share on other sites

Hi guys, just created a vid to help you out a bit....

https://youtu.be/YL1P1JB0tgo


EDIT: Just noticed that you are using dbox, so it maybe hard cheese on the table, sorry!



Share this post


Link to post
Share on other sites
Thanks for that! Should prove exceptionally helpful for non d-box users. Appreciate the effort to create that easy to understand video mate.  I'll wait to see if Codemasters is going to offer a solution for d-box working with simcommander. Meanwhile, I'll still be using your tutorial for getting simcommander to work in dirt rally.

Share this post


Link to post
Share on other sites
Firstly, Great tutorial MrPix.  I didn't even know this Proxy app existed.

I have just got this setup with SimVibe 4, Fanaleds, and Dash Meter Pro, and hit a couple of snags, but i have it all working now so will outline it here in case it helps someone else.

Simvibe 4 now has a Dirt Rally profile and i found that by running this, it actually was modifying the "hardware_settings_config.xml" when i launched Dirt Rally from Simvibe 4.  I could not figure out how to stop this behaviour, so i had to leave the config file set to port 10001, and then in Simvibe 4, under Settings > Games > Dirt Rally (Steam) , set a UDP Forward to the port you have the CM Proxy app listening on, ie 20777.

Then in the CM Proxy app, remove the settings for Simvibe  (port 10001) as this will interfere with SimVibe and the game communicating.  I only have the CM Proxy outputting to Fanaleds and Dash Meter Pro, and all 3 devices are working fine now.

Also, note for Fanaleds, set the line in the "hardware_settings_config.xml" below the UDP, to  fanatec enabled="false", so the game will not try and use the fanatec display natively.

Share this post


Link to post
Share on other sites
I have the XML file setup properly and the AF and SimVibe work fine initially with DR. The issue is that SC4 stops working after the initial session; i.e., after I close DR and come back later, I have no FFB or Vibrations in DR.  The only way to get them working again is to reset the SC4 game profile for DR. Of course, that means losing all of the profile settings and starting from scratch.

I've tried exporting/importing the custom profile but, that does not work either. The profile must first be reset in order to work.  I also tried a complete uninstall/re-install of SC4 with no improvement.

Does anyone have any ideas?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×