Jump to content
Sign in to follow this  

Severe Drops in FPS with DIrt 2 Only during Multiplayer.

Recommended Posts

Hi all,
I was wondering if anyone could help me with this. I used to play a little Dirt 2 online when I first got the game and then after playing it for about 4 months the FPS would drop to 10-15 FPS only when I played online multiplayer. Most times as soon as the FPS drops it would lock up and I would have to shut down task from task manager. I can play single player all day long with 60+FPS consistently. This only happens when I try online multiplayer. 

I have made no changes to my PC. Windows 7 Pro, Using I7 with 6950 graphics and 12Gb of good Redline Ram. Steam install.

 I tried uninstall, re-install. No change. Tried uninstall, re-install GFWL files. No change. Tried using Dx9 , no change. Tried default bios settings on graphics card ( Dual bios with one overclocked that I used when I started playing Dirt 2. Tried it with my laptop instead of my desktop. No change. Tried bypassing my router and connecting directly to my cable modem. No change. (180 Mbps connection with cox cable) 

 I would love to be able to play D2 on occasion and switch between D2-D3 and eventually D4 :-)


Share this post


Link to post
Share on other sites
hello, you should clean up your pc especially the CPU fan and heatsink and clean everything from dust because the dust stifles the heatsink and results to overheating, you need your pc to be completely cleaned for a better ventilation!

Share this post


Link to post
Share on other sites
thanks for taking the time to respond but I don't think it's a overheating problem.. I clean out my PC on a monthly basis and I'm able to play other games just fine plus I can play dirt 2 single player without any problems its only online that I have the frames per second drop down.

Share this post


Link to post
Share on other sites
I consistently get 180 Mbps down and 25 up... I think it should be plenty of bandwidth. I play dirt 3 all the time without issues. But the fact that it only happens online does point to connectivity issue specific to dirt 2 and or GFWL. Thanks for suggestion.

http://www.speedtest.net/my-result/3496709890

Share this post


Link to post
Share on other sites
Hey cougar1981, 

Yes it happens every time. When I go to multiplayer lobby FPS drops down and can lock up in lobby or when I join an ongoing multiplayer game. I can play single player all the time without issues.

Share this post


Link to post
Share on other sites
Make sure that nothing is opened in the background that uses bandwidth like Browsers, Torrent porgrams, music players etc

Share this post


Link to post
Share on other sites
Nothing open in background. Have Bitdefender antivirus and put it into game ,mode. No change.. I feel it has something to do with GFWL due to the fact that it only happens in multiplayer mode. Like I said. I used to be able to play the game for about 4 months when I first got it. No changes to system other than critical windows update and suddenly it doesn't work with online. I have had this problem now for about 1 1/2 yrs and have found no solution. Again thanks for suggestion cougar.

Share this post


Link to post
Share on other sites
Try contacting Codemasters via this email address to see if they have a fix for GFWL

Custserv@Codemasters.com

Share this post


Link to post
Share on other sites
Try contacting Codemasters via this email address to see if they have a fix for GFWL

Custserv@Codemasters.com
Ok I recieved a GFWL troubleshooting link from codies email support and will be able to try with changes made to my router. IE Opened some ports for GFWL. I think I had this setup b4 but have had several updates to router firmware and software since then.. It may have blown those settings out of the water. Hope this works. Thanks again cougar1981.

Share this post


Link to post
Share on other sites
Try contacting Codemasters via this email address to see if they have a fix for GFWL

Custserv@Codemasters.com
Ok I recieved a GFWL troubleshooting link from codies email support and will be able to try with changes made to my router. IE Opened some ports for GFWL. I think I had this setup b4 but have had several updates to router firmware and software since then.. It may have blown those settings out of the water. Hope this works. Thanks again cougar1981.
Well following changes to my router, firewall and port forwarding settings per email from codemaster support I am sad to report that there is no change. The minute I click the online button in the game my FPS drops to 12-10 and screen starts to stutter. Will reply to support and see if they have anything else for me to try.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×