Jump to content

Game crashes regardless of what I do

Recommended Posts

Hey all,

my copy of F1 2019 on Steam seems to crash regardless of what I do. Running the game in DX11 or DX12 does not make a difference, crash on startup. -safemode also makes the game crash on startup. Also tried both verifying the game files aswell as reinstalling the game on seperate drivers, none of which helped.  My pc specs are quite up to date, and I'm currently using the GeForce Driver version 436.30.

Any suggestions?

Edit; The problem happened with other games aswell, so it's probably not at the F1 2019's end, but rather my screen settings? Using the Benq XL2740.

Thanks in advance,

Buggy

 

 

Edited by BuggyBee

Share this post


Link to post
Share on other sites

I am having similar issues as of today. Game worked fine yesterday (Win7 DX11) and I played for almost two hours. Today it was constantly crashing on start. I updated my Nvidia drivers, ran all the windows updates as I saw people suggest in other topics with no luck. I was finally able to get the game to start after turning off my Fanatec wheel. I can now consistently get into the game, but as soon as I power on my wheel, the game freezes again. The real puzzling part was this all worked fine yesterday.

Share this post


Link to post
Share on other sites
2 hours ago, EyebrowZing said:

I am having similar issues as of today. Game worked fine yesterday (Win7 DX11) and I played for almost two hours. Today it was constantly crashing on start. I updated my Nvidia drivers, ran all the windows updates as I saw people suggest in other topics with no luck. I was finally able to get the game to start after turning off my Fanatec wheel. I can now consistently get into the game, but as soon as I power on my wheel, the game freezes again. The real puzzling part was this all worked fine yesterday.

@BuggyBee could you report back to us by doing the same? If you're using a wheel that is.

Have you tried to remove the Wheel drivers and reinstalling those? Windows computers have a driver/device manager in which you can most likely find the drivers. It may be enough to just uninstall the Fanatec software you need in order to use the wheel (if there is any).

Wheel drivers are sometimes a bit buggy and cause crashes.

Share this post


Link to post
Share on other sites
3 hours ago, UP100 said:

@BuggyBee could you report back to us by doing the same? If you're using a wheel that is.

Have you tried to remove the Wheel drivers and reinstalling those? Windows computers have a driver/device manager in which you can most likely find the drivers. It may be enough to just uninstall the Fanatec software you need in order to use the wheel (if there is any).

Wheel drivers are sometimes a bit buggy and cause crashes.

Never used a wheel ever in any game. Using a PS4 controller at the moment, worked great untim the sudden crashes. 

Share this post


Link to post
Share on other sites

Sharing your PC specs, detailed OS versions and so on may help 🙂 I assume you're running Win10 as you've tried to run the game on DX12?

Share this post


Link to post
Share on other sites
3 hours ago, UP100 said:

Sharing your PC specs, detailed OS versions and so on may help 🙂 I assume you're running Win10 as you've tried to run the game on DX12?

Win 10 with DirectX 12, version 1903 (OS-build 18362.356

CPU: Intel(R)Core(TM) i9-9900K @ 3.60GHz

GPU: Nvidia GeForce RTX 2080Ti

RAM: 32GB

Don't know how relevant, but my monitor is a Benq XL 2740 with 240Hz available. Always used 240Hz

Tried running the game in both DX11 and DX12, none of which worked

 

Share this post


Link to post
Share on other sites

That's an unexpectedly high refresh rate. Could you try lowering it just as a test? Have you been updating the Windows version (or something) in recent times? Something that could, for god knows why, break games?

Share this post


Link to post
Share on other sites

Already tried lowering it. Launching any Steam-games result in a crash immediately or after a few minutes, regardless of Hz. I updated the GeForce Driver to version 436.30, but nothing else. I suspect Steam itself, because non-Steam games such as League of Legends worked perfectly. I also tried disabling the Steam Overlay in Steam Settings while in-game, but that did not work either.

Edited by BuggyBee

Share this post


Link to post
Share on other sites
4 minutes ago, BuggyBee said:

Already tried lowering it. Launching any games result in a crash immediately or after a few minutes, regardless of Hz. I updated the GeForce Driver to version 436.30, but nothing else. I suspect Steam itself, because non-Steam games such as League of Legends worked perfectly. I also tried disabling the Steam Overlay in Steam Settings while in-game, but that did not work either.

I believe G-SYNC is only possible over Display Port, that's how your screen is connected, right?

Share this post


Link to post
Share on other sites

I used the Display Port when the game crashed. I've now switched to a HDMI cable which is 5+ years old. Read online that older versions of the HDMI cable don't support such Refresh rates, but I doubt it hence I still had 240Hz in-game...  so I should use the Display Port regardless if it crashes or not?

Share this post


Link to post
Share on other sites
3 minutes ago, BuggyBee said:

I used the Display Port when the game crashed. I've now switched to a HDMI cable which is 5+ years old. Read online that older versions of the HDMI cable don't support such Refresh rates, but I doubt it hence I still had 240Hz in-game...  so I should use the Display Port regardless if it crashes or not?

For automatic enabling of G-SYNC, yes you should use DP. HDMI cables have been around in various guises for some time. Latest spec is HDMI 2.0, older cables will either work or not work but for the correct signalling you should use DP. Otherwise the G-SYNC won't work.

Share this post


Link to post
Share on other sites
11 minutes ago, BuggyBee said:

Ok cheers, will try and see if it changes anything.

I would DDU the driver, reboot then delete the hardware_settings_config.xml before launching the game.

Share this post


Link to post
Share on other sites

Update; Changed HDMI to DP. Restarted the pc, launched the game, immediate crash with the message "No signal detected". Thank you very much for the support, but affects other Steam-games aswell, not only F1 2019. Will DDU the driver as a last resort if you don't reveal any more magic tricks 😛 Thanks a lot though

 

Edit; Oh, my audio device seems to switch to my screen whenever I switch between DP and HDMI. Could there be any other switches that occur?

Edited by BuggyBee

Share this post


Link to post
Share on other sites

No signal detected isn't a game crash necessarily. It means the signal is out of range of the monitor (usually the handshaking is unsuccessful).

Share this post


Link to post
Share on other sites

It sounds from your reply like you have BOTH cables plugged at once. You should use only one cable at a time for each separate display.

Share this post


Link to post
Share on other sites

I would then refer you to the DDU advice and deleting the hardware_settings_config.xml

If audio sources are an issue, select a default audio device in Windows before starting the game once you've deleted the file.

Other general troubleshooting advice also applies. Lower the desktop refresh rate and make sure the game is detecting 1920x1080 and try lower refresh rates in game.

V-SYNC should be enabled for G-SYNC (or may even be greyed out) I'm afraid I'm Freesync.

Share this post


Link to post
Share on other sites

Hi @BuggyBee,

Please check out the post below and let us know if either of the workarounds helps resolve your stability issues in DX12 mode.

Thanks,
Hoo.

 

Share this post


Link to post
Share on other sites

WHAT SOLVED MY PROBLEM: Running Advanced System Care tools. Register Cleaner, Disk Cleaner and Driver Booster...restart pc and game is back to normal. DX 12 working 60fps and DX11 stuttering as hell haha 

Share this post


Link to post
Share on other sites
6 hours ago, MatheusPucci344 said:

WHAT SOLVED MY PROBLEM: Running Advanced System Care tools. Register Cleaner, Disk Cleaner and Driver Booster...restart pc and game is back to normal. DX 12 working 60fps and DX11 stuttering as hell haha 

I would uninstall all that junk and run Malwarebytes.

If any of them made you update a driver that was probably all you needed to do.

Posting what was updated would be more helpful.

  • Agree 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×