Jump to content
DiRT Rally 2.0 - New Player Guide Read more... ×

F1 2019 - DX12 Stability Issues

Recommended Posts

Hi All,

Some users have reported having stability issues when running the game in DX12 mode. This results in the game crashing at random points during play, typically after a few minutes of play. For any users experiencing this issue, please could you try the following and let us know if this helps at all:

  1. (NVIDIA users only) Please enter the NVIDIA Control Panel, set the "Shader Cache" option to "Off" and confirm the settings change. Relaunch the game and check whether this has improved game stability.
  2. If the above doesn't work (or for AMD users), please try running the test branch below and see if this improves game stability. The test branch is version 1.10 and should be compatible with the standard version 1.10.

To install the beta branch, please do the following:

  • Open up Steam library and “Right Click” on F1 2019
  • Select Properties
  • Select the “BETAS” tab
  • Enter the Branch Password into the box
  • Press the “CHECK CODE” button
  • Select Branch Name from the drop down box
  • Close the properties window
  • Click the “INSTALL” button in the Steam Client
  • Once the game has been downloaded the button will now display as “PLAY”
  • Click “PLAY” to launch the game

Branch: asyncdisabledtest
Password: sdh098GHY3156uicnfdCVB2907ghjswedfKLJH244

Note: to revert to the main branch, please re-enter the betas tab and select "None" as the branch.

 

Please let us know what system you are running and whether either of the above tests improved the stability of your game in DX12 mode.

Thanks.

  • Thanks 1

Share this post


Link to post
Share on other sites

Can this be tagged or announced? No feedback?

I've ran it but then I don't have the stability issues, just straight up game bugs (MP game crashes aside). 

  • Like 1

Share this post


Link to post
Share on other sites

This seems to solve the issue for me and I was having DX12 issues prior to following all the steps on here.  So to re-cap I did disable "Shader Cache" as it was previously enabled and I have updated to the patch version.  I will keep on trying to see if I get any issues as this feedback is after 30 minutes of playing (which is longer than I have been able to previously - except for one of the earlier builds that was mostly stable but did occasionally crash)

Edited by Acerees
  • Thanks 1

Share this post


Link to post
Share on other sites

Beta seems to work for me, at least in TT.

I’m AMD though.

Never had the problem of DX12 crashing, but good to know the beta branch doesn’t make things worse for me.

 

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

Yes I can definitely confrim that this beta patch works (for me!)  I have played for hours without any crashes now on DX12.  Thank you Codemaster dev’s for finding a fix 

Share this post


Link to post
Share on other sites

Hi @Acerees,

We'd love to know whether the disabling the shader cache or running the beta branch fixes the issue. Would you be able to check whether playing in the normal game branch (not the beta), but with the shader cache disabled fixes your stability problems? 

Thanks.

  • Agree 1

Share this post


Link to post
Share on other sites

Does 1.12 include the fix?

I can't tell, maybe you can @Acerees 

One thing I can say is the beta has 1.10 as a version and it looked pretty much like it may not work with 1.12 versions so there's not going to be any more testing.

  • Like 1

Share this post


Link to post
Share on other sites

The shader cache setting is in the NVidia driver settings, so is external to the game. Users can try this with the latest v1.12 and hopefully everything will work!

  • Like 1

Share this post


Link to post
Share on other sites
On 9/26/2019 at 1:01 PM, Hoo said:

Hi @Acerees,

We'd love to know whether the disabling the shader cache or running the beta branch fixes the issue. Would you be able to check whether playing in the normal game branch (not the beta), but with the shader cache disabled fixes your stability problems? 

Thanks.

Sorry only just seeing this.  Yes I will disable the beta tomorrow and let you know ASAP

  • Thanks 1

Share this post


Link to post
Share on other sites

I signed up to provide feedback on the suggested fix.

 

I'm running AMD & GTX 1080 on Nvidia 436.30.

I was having crashes which would reboot the PC randomly, a few minutes into the game.

I tried JUST turning off Shader Cache on Nvidia Control Panel and put in over 30 mins of game without any crashes.

Thank you,

  • Thanks 1

Share this post


Link to post
Share on other sites
2 hours ago, eLpisiko said:

Hi, none of these options works for me! Game keeps crashing after few mins in the game

564600-20190927-222017-0.zip

You restarted Windows after turning off the Shader Cache right?

DDU will properly nuke the driver for you. Try that if no progress.

Share this post


Link to post
Share on other sites

'Beta access code invalid'

E: Worked, didn't copy the whole text

Edited by H_pro1

Share this post


Link to post
Share on other sites
On 9/27/2019 at 3:09 PM, Hoo said:

The shader cache setting is in the NVidia driver settings, so is external to the game. Users can try this with the latest v1.12 and hopefully everything will work!

I opted out and updated and ran in a league race last night and it thankfully didn’t crash.  So it seems like the shaded cache setting was the issue for me.  Thanks 

Share this post


Link to post
Share on other sites
8 hours ago, eLpisiko said:

Ya game keeps crash in the career mode, I tried playing at DX11 and had no problem at all.

Shader cache is turned off in Nvidia.

Same issue here. Shader cache is turned off. I did the first race of my second career and cant get thru Barhein with out crashing.

egodumper.log

DxDiag.txt

hardwaresettings.zip

Edited by alex6463

Share this post


Link to post
Share on other sites
5 hours ago, alex6463 said:

Same issue here. Shader cache is turned off. I did the first race of my second career and cant get thru Barhein with out crashing.

egodumper.log

DxDiag.txt

hardwaresettings.zip

Disconnect your flight sim controller? Nice display BTW 🙂 Nice board, heck nice system.

But try the beta 1.10 asyncdisabledtest at the top of this thread.

There is a new UEFI BIOS for your board (1.60

MSI Dragon Center might be causing issues (LightKeeperService.exe) the Store is trying to download UWP apps and failing, might be driver related?

There possibly is / has been an issue with .NET Framework, maybe reinstall or repair the version you have (listed in Programs and Features in Control Panel)

There is an update to the Killer Networking driver and Realtek UAD Audio driver. Mishmash of NVMe drivers (not sure the Samsung one is wise given you have the WD drive as well).

Share this post


Link to post
Share on other sites

@steviejay69 Thank you very much !!! I've been able to play 45 min without crashing on version 1.12. More testing to come but looking good so far. I  did disconnect my flight sim hardware, updated the BIOS and killed (Lightkeeperservice) from task manager. 

  • Like 1

Share this post


Link to post
Share on other sites

When will u guys fix this ****? I try to lower everything, shadow cache is off, and still the game crashes after few mins! I ******* refuse to play on DX11!! Game is so heavy and laggy with DX11

  • Agree 1

Share this post


Link to post
Share on other sites
3 hours ago, steviejay69 said:

Personally I find it easier to make suggestions from a dxdiag. Can't be arsed to install the software to read crashdumps. I am not a programmer.

DxDiag.txt

 

Here you go.

Share this post


Link to post
Share on other sites
1 hour ago, eLpisiko said:

DxDiag.txt

 

Here you go.

As with @alex6463, you have MSI Dragon Center loaded this has an RGB service called Lightkeeper.exe that is crashing, please uninstall it.

Also you have a problem signature with Avast! Anti-Virus please remove it, Windows Defender is sufficient - I cannot recommend any 3rd party AV for use with W10.

Uninstall, then use the Avast! removal tool.

I cannot Identify your board beyond it is MSI with support for 9th Gen CPU, please indicate the model name.

I can then recommend UEFI and driver updates, but also I notice you are running 1809, newest drivers work best with 1903 @eLpisiko

Share this post


Link to post
Share on other sites
20 hours ago, steviejay69 said:

As with @alex6463, you have MSI Dragon Center loaded this has an RGB service called Lightkeeper.exe that is crashing, please uninstall it.

Also you have a problem signature with Avast! Anti-Virus please remove it, Windows Defender is sufficient - I cannot recommend any 3rd party AV for use with W10.

Uninstall, then use the Avast! removal tool.

I cannot Identify your board beyond it is MSI with support for 9th Gen CPU, please indicate the model name.

I can then recommend UEFI and driver updates, but also I notice you are running 1809, newest drivers work best with 1903 @eLpisiko

Okay thanks, I’ll check this out when I come home 🙂

 

and the board is: asus rog strix z390-f gaming

  • Thanks 1

Share this post


Link to post
Share on other sites
20 hours ago, eLpisiko said:

Okay thanks, I’ll check this out when I come home 🙂

and the board is: asus rog strix z390-f gaming

Will edit this post with updates when I get home 🙂

UEFI BIOS 1302

You don't appear to have the Intel iGPU enabled (I have found it helpful to use as an accelerator for OBS) this is the DCH driver

Realtek Audio Driver 6.01.8666 

LAN Driver doesn't appear to be listed in dxdiag this is the driver for 1903, you are currently on 1809 (as previously advised, you should upgrade).

Reference to MSI Dragon Center might also be applied to AURA Lighting Control.

Chipset drivers just generally tend to ID the components properly.

There is a ME firmware and updated driver if you find that kind of thing important. Found on the support page here.

Edited by steviejay69
Updated with....updates

Share this post


Link to post
Share on other sites
23 hours ago, steviejay69 said:

Will edit this post with updates when I get home 🙂

UEFI BIOS 1302

You don't appear to have the Intel iGPU enabled (I have found it helpful to use as an accelerator for OBS) this is the DCH driver

Realtek Audio Driver 6.01.8666 

LAN Driver doesn't appear to be listed in dxdiag this is the driver for 1903, you are currently on 1809 (as previously advised, you should upgrade).

Reference to MSI Dragon Center might also be applied to AURA Lighting Control.

Chipset drivers just generally tend to ID the components properly.

There is a ME firmware and updated driver if you find that kind of thing important. Found on the support page here.

Thanks mate, I'll try this and see if it works out.

 

Peace!

  • Like 1

Share this post


Link to post
Share on other sites
On 10/7/2019 at 5:11 PM, steviejay69 said:

Will edit this post with updates when I get home 🙂

UEFI BIOS 1302

You don't appear to have the Intel iGPU enabled (I have found it helpful to use as an accelerator for OBS) this is the DCH driver

Realtek Audio Driver 6.01.8666 

LAN Driver doesn't appear to be listed in dxdiag this is the driver for 1903, you are currently on 1809 (as previously advised, you should upgrade).

Reference to MSI Dragon Center might also be applied to AURA Lighting Control.

Chipset drivers just generally tend to ID the components properly.

There is a ME firmware and updated driver if you find that kind of thing important. Found on the support page here.

Well mate, thank you! All works fine for now ;)

 

peace!

  • Thanks 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×