Jump to content Jump to content

DIRT RALLY dont detect Thrustmaster TX


MANUTD

Recommended Posts

  • 2 weeks later...
I had the same problems as others, with the wheel not being recognised, i found a fix. I went to games folder \Steam\SteamApps\common\DiRT Rally\input and found the line with tm_tx.xml and changed the line at the top 

<ActionMap name="tm_tx" device_type="{B669044F-0000-0000-0000-504944564944}" priority="0">
to 
<ActionMap name="tm_tx" device_type="{B669044F-0000-0000-0000-504944564944}" priority="10">

Note: I changed the priority to 10 just like it is for the keyboard, and my wheel was recognized then 
I also did what ItsLaZo done as well afterwards to see if that made a change but worked for me 
I hope it works for others too good luck
Link to post
Share on other sites
I got exactly the same problem with my Thrustmaster TX Ferrari 458 Edition steering wheel which works perfectly in Project Cars..
Dirt Rally just can't recognize my wheel ! I have tried usb2.0 and XML file...but still cann't solve the problem
Link to post
Share on other sites
  • 4 weeks later...
  • 4 months later...
KD750 said:
I got exactly the same problem with my Thrustmaster TX Ferrari 458 Edition steering wheel which works perfectly in Project Cars..
Dirt Rally just can't recognize my wheel ! I have tried usb2.0 and XML file...but still cann't solve the problem
Exactly the same story here. I'm using Logitech G29 no success so far :(
Link to post
Share on other sites
Hi, i've noticed that i apparently have the same issue, but in my case it's caused specifically when having ShadowPlay enabled (or "Share" as it's now called).
Try disabling shadowplay or uninstalling the Geforce experience completely and see if your wheel works.
I've created a seperate thread on the specific issue with my thrustmaster TX and Shadowplay not playing nicely together with Dirt Rally:
http://forums.codemasters.com/discussion/28601/wheel-tm-tx-not-detected-after-turning-on-nvidia-share-previously-shadowplay#latest
Link to post
Share on other sites
  • 4 years later...

a bit late on the topic, but I just had to solve this problem and it was really frustrating.
So, in order to fix this go to dirt rally properties through library and in general change "Steam Input Per-Game Setting" to forced off

basically what happened, it was set to steam global and steam recognized my wheel as an xbox controller... therefore making it impossible for the game to recognize any further inputs. Hope it helps anybody

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...