Jump to content

DiRT Rally 2.0 - Version 1.9 Bug Reports

Recommended Posts

    IMPORTANT: Read and understand this entire opening post before replying, as providing the right amount of detail will help out the team immensely in tracking and resolving any bugs that arise, thanks.

     

    ALSO: For VR-specific bug reporting, head here: 

     

 

     

    DR2_BMW_M2_Competition_1.jpg

     

     

     

    Before posting, please make sure to follow these guidelines. Without adequate information the team will have trouble identifying and fixing bugs, so please provide as much info as you can:

  • Check if a bug has already been reported.
     
  • If you reported a bug in a previous version of the game, check your game first to see if it's been fixed.     
     
  • If a bug has been reported and you are experiencing the same issue, hit the ❤️ icon.     
     
  • The more popular bug posts will have a better chance of catching the attention of the team.
     
  • Also, this thread allows us to sort comments by how many votes they have, so make use of that feature 🙂      
     
  • If a bug cannot be reproduced, it cannot be fixed.     
     
  • When you experience a bug, please try to trigger said bug again if you can, and show us the steps you went through to trigger it.     
     
  • Text steps are good, video even better.     
     
  • One bug per post please, for our tracking purposes. That way every bug gets its own URL for us to investigate.     

     

    Please also provide the following:

  • What platform you're playing on (for PC also state Steam or Oculus).     
     
  • What your PC setup/build is like (graphics card, processor etc.).     
        
  • Whether you're a Standard or Deluxe user (doesn't apply to Oculus).     
     
  • Whether or not you have any non-standard peripherals connected, like steering wheels, gaming mice etc.     

Share this post


Link to post
Share on other sites

Windshield wipers are still bugged. They still constantly go on for no reason, whether automatic wipers are on or off. It's no game-breaking bug of course but it's a very blatant bug that you can't really miss and shouldn't be too difficult to reproduce, so I wonder why it does not get fixed

20191001140259_1.thumb.jpg.385125f3d8c24573590e2ad9f11ebca4.jpg

PC Steam, super deluxe edition. 120v3, GTX1070, 16gb, SSD, W10, SB Z, G920

  • Like 6

Share this post


Link to post
Share on other sites
  • What platform you're playing on. 
  • - Steam, PC
  • What your PC setup/build is like (if playing on Steam).
  • - i7, 16GB RAM, GTX 750Ti 
  • Whether you're a Standard or Deluxe user.
  • - Deluxe
  • Whether or not you have any non-standard peripherals connected, like steering wheels, gaming mice etc.
  • - No

Bug in Estering, if you leave your Joker to the last lap, your spotter doesn't tell you it's the last lap, noticed in custom event, same in heat races and finals

  • Like 5

Share this post


Link to post
Share on other sites
  • What platform you're playing on. 
  • - Steam, PC / Xbox
  • What your PC setup/build is like (if playing on Steam).
  • - i7, 16GB RAM, GTX 750Ti 
  • Whether you're a Standard or Deluxe user.
  • - Deluxe
  • Whether or not you have any non-standard peripherals connected, like steering wheels, gaming mice etc.
  • - No

Rallycross AI in wet conditions could do with a buff across the board, especially noticeable if an event has changing conditions, in the dry you can be struggling to beat the AI and in the wet you will be ahead of them by miles on the same difficulty (difficulty set to 92 in my case)

Noticed in WRX mode on Xbox and custom events on PC

  • Like 2

Share this post


Link to post
Share on other sites

Me again :classic_biggrin:

  • What platform you're playing on. 
  • - Steam, PC / Xbox
  • What your PC setup/build is like (if playing on Steam).
  • - i7, 16GB RAM, GTX 750Ti 
  • Whether you're a Standard or Deluxe user.
  • - Deluxe
  • Whether or not you have any non-standard peripherals connected, like steering wheels, gaming mice etc.
  • - No

The new "Consolidation Finals" elimination setting in custom RX events needs a toggle on/off in event settings rather than just being on regardless in order to allow us to play the way we want to, simulating Euro RX seasons for example where consolidation finals are not used

(Gonna keep bringing this up until I'm blue in the face 😂)

  • Like 1

Share this post


Link to post
Share on other sites

1284199445_floatingrearviewmirror.jpg.a86e4d1d0228463af495f643ca64069a.jpg

Floating rearview mirror in the Lancia Fulvia. This is in Spain, with damage to the front area to the car.

  • What platform you're playing on (for PC also state Steam or Oculus).     

PC Steam

  • What your PC setup/build is like (graphics card, processor etc.)

Win 10 1903, Ryzen 5 3600, Nvidia GTX 1070Ti

  • Whether you're a Standard or Deluxe user (doesn't apply to Oculus). 

Standard

  • Whether or not you have any non-standard peripherals connected, like steering wheels, gaming mice etc

No, wired Xbox One controller.

 

  • Like 2

Share this post


Link to post
Share on other sites

Hi Team,

Sunset still has morning hours shown on the loading screen for:

Greece

Monaco

Spain

  • Like 1

Share this post


Link to post
Share on other sites
  • What platform you're playing on. 
  • -Xbox
  • Whether you're a Standard or Deluxe user.
  • - Deluxe
  • Whether or not you have any non-standard peripherals connected, like steering wheels, gaming mice etc.
  • - No

I load into a stage or shakedown, but the countdown to start doesn't happen and I have no control of my vehicle. My co-driver doesn't make any calls either. I can load and drive in freeplay and rallycross just fine.

User error. Thank you for the mental reset.

Edited by SlicedCHEWY005
  • Like 1

Share this post


Link to post
Share on other sites

20191001203806_1.jpg?width=1092&height=6

 

new dashcam on fiesta r2

 

 

audio cut is still present, but only engin sound disappear this time ...........

  • Like 2
  • Haha 1

Share this post


Link to post
Share on other sites
  1. Changing gear when turning crazy hand bug is still not fixed in 1.9

  2. Developers don't listend to bug reports, whats the point of this topic?

 

  • Like 1
  • Disagree 1

Share this post


Link to post
Share on other sites

Sound cut out but this time game restart, PC restart does not help. Engine muted permanently. Ingame options I have all sounds at 100.  

Edit: As some people suggested, changing the view does indeed fix the sound. TY @piphil. 

  • What platform you're playing on (for PC also state Steam or Oculus).     
        PC, Steam
  • What your PC setup/build is like (graphics card, processor etc.).     
        RTX 2080, i7-7700k, 1903
  • Whether you're a Standard or Deluxe user (doesn't apply to Oculus).     
        Deluxe
  • Whether or not you have any non-standard peripherals connected, like steering wheels, gaming mice etc.   
        Not sure what you would qualify as a "non-standard peripheral".  
Edited by D1G
  • Like 7

Share this post


Link to post
Share on other sites

Audio bug

The car sound cut out in most races. It seems to be working fine in Dirt Fish map, but when i try to race in any other stage the car is muted. Tires, pacenotes, environment seems ok.

 

What platform you're playing on (for PC also state Steam or Oculus).     
PC, Steam

What your PC setup/build is like (graphics card, processor etc.).     
   GTX 1050, I7-7700HQ, 16Gb RAM, Windows 10 1803

Whether you're a Standard or Deluxe user (doesn't apply to Oculus).     
Deluxe

Whether or not you have any non-standard peripherals connected, like steering wheels, gaming mice etc.  

Logitech G29   (does it count as non-standard?)

  • Like 2

Share this post


Link to post
Share on other sites
4 hours ago, D1G said:

Sound cut out but this time game restart, PC restart does not help. Engine muted permanently. Ingame options I have all sounds at 100.  
 

  • What platform you're playing on (for PC also state Steam or Oculus).     
        PC, Steam
  • What your PC setup/build is like (graphics card, processor etc.).     
        RTX 2080, i7-7700k, 1903
  • Whether you're a Standard or Deluxe user (doesn't apply to Oculus).     
        Deluxe
  • Whether or not you have any non-standard peripherals connected, like steering wheels, gaming mice etc.   
        Not sure what you would qualify as a "non-standard peripheral".  

Having this same issue. Also on PC / Steam, using 1660 Ti on Windows 10. Trying to do the NR4 monthly in Monaco. First shakedown everything went fine to the end. Started 2nd shakedown and no engine sound.

  • Like 1

Share this post


Link to post
Share on other sites

All platforms, specification of NR4 EvoX is incorrect based on FIA rules for car/class as well as from previous title (Dirt4) which had the correct weight - Version in DR2 went on a laxative diet and thinks it's a GrpA car or didn't tell the FIA it was 4WD.

 

That a lot of weight lost and causes quite the issue between the only two cars in that category.

d4evox.thumb.png.26720439caf4c52591080ee416328fb3.png

 

DR2evox.thumb.jpg.002eac3312eddf0cb9e140a1c719e3ec.jpg

  • Like 2

Share this post


Link to post
Share on other sites

Turbo blow off sounds when using pedals is better, read works now (thankyou!!!) but still requires *very* quick release of throttle so does not play as often as gamepad or keyboard.

Using G27 pedals - time to go from full throttle to off throttle on pedals takes longer than keys and gamepads, needs a slight tweak to the fix employed for pedals in 1.9.

  • Like 4

Share this post


Link to post
Share on other sites

For the no engine sound issue - for me, changing the view fixed it. It may work for others?

Edited by piphil
  • Like 2

Share this post


Link to post
Share on other sites
15 hours ago, SlicedCHEWY005 said:
  • What platform you're playing on. 
  • -Xbox
  • Whether you're a Standard or Deluxe user.
  • - Deluxe
  • Whether or not you have any non-standard peripherals connected, like steering wheels, gaming mice etc.
  • - No

I load into a stage or shakedown, but the countdown to start doesn't happen and I have no control of my vehicle. My co-driver doesn't make any calls either. I can load and drive in freeplay and rallycross just fine.

It's quite infuriating because I just bought this game.

You have to hold the handbrake for the countdown to start.

Share this post


Link to post
Share on other sites
20 minutes ago, Lenman said:

I have used the new "Reset Racenet Data" function, which is described ingame to reset "any staff progress":
https://steamcommunity.com/sharedfiles/filedetails/?id=1878367766

However, the staff progress is not removed, all my staff is still at max. level:
https://steamcommunity.com/sharedfiles/filedetails/?id=1878367747

This issue has been logged. Thank you for the report.

Share this post


Link to post
Share on other sites
22 hours ago, MattyH1812 said:
  • What platform you're playing on. 
  • - Steam, PC
  • What your PC setup/build is like (if playing on Steam).
  • - i7, 16GB RAM, GTX 750Ti 
  • Whether you're a Standard or Deluxe user.
  • - Deluxe
  • Whether or not you have any non-standard peripherals connected, like steering wheels, gaming mice etc.
  • - No

Bug in Estering, if you leave your Joker to the last lap, your spotter doesn't tell you it's the last lap, noticed in custom event, same in heat races and finals

This will likely be resolved in 1.10 👍🏻

Share this post


Link to post
Share on other sites
16 hours ago, SlicedCHEWY005 said:
  • What platform you're playing on. 
  • -Xbox
  • Whether you're a Standard or Deluxe user.
  • - Deluxe
  • Whether or not you have any non-standard peripherals connected, like steering wheels, gaming mice etc.
  • - No

I load into a stage or shakedown, but the countdown to start doesn't happen and I have no control of my vehicle. My co-driver doesn't make any calls either. I can load and drive in freeplay and rallycross just fine.

It's quite infuriating because I just bought this game.

I'm sure you're already aware of this since RX is working fine for you, but are you holding down the handbrake at the start? Countdown won't begin until you do that.

We'll add it to the internal reports anyways, but just making sure.

Share this post


Link to post
Share on other sites
57 minutes ago, CM_Ads said:

This issue has been logged. Thank you for the report.

does it mean that all other issues without such remark are being ignored?

Share this post


Link to post
Share on other sites
15 hours ago, VertuVertu said:

Developers don't listend to bug reports, whats the point of this topic?

We review threads like this every day and add your feedback to internal tracking systems. Just because you don't see responses doesn't mean the team's not working on things.

In fact, them working on the various things you guys bring up is why they're not on the forums all the time 😉 

 

4 minutes ago, MaXyMsrpl said:

does it mean that all other issues without such remark are being ignored?

See above ❤️ 

  • Thanks 1

Share this post


Link to post
Share on other sites
14 hours ago, D1G said:

Sound cut out but this time game restart, PC restart does not help. Engine muted permanently. Ingame options I have all sounds at 100.  
 

  • What platform you're playing on (for PC also state Steam or Oculus).     
        PC, Steam
  • What your PC setup/build is like (graphics card, processor etc.).     
        RTX 2080, i7-7700k, 1903
  • Whether you're a Standard or Deluxe user (doesn't apply to Oculus).     
        Deluxe
  • Whether or not you have any non-standard peripherals connected, like steering wheels, gaming mice etc.   
        Not sure what you would qualify as a "non-standard peripheral".  

What camera angle are you using?

(non-standard items are things that aren't keyboard/mouse)

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×