Jump to content
Sign in to follow this  

Wheel issues

Recommended Posts

Hi, i have had my TMX for a year now and whenever i play for over about an hour my wheel will just randomly disconnect, even when its plugged in properly, drivers e.t.c are all installed. this happens on anything i play. i get no indication of if it’s going to happen, no weird sounds just cuts off and i have to do a mid race save and race later, 

it eventually comes back to life about 30 mins later, anybody know what my problem is?

Share this post


Link to post
Share on other sites

how high are your ffb settings, with my T150 if i was on a track with many turns and high ffb it would cut out (overheat), lowering ffb settings and circulating air helped.

  • Agree 1

Share this post


Link to post
Share on other sites

Then I guess it looks like a hardware faillure; it's getting too hot and turns off. You have other games to test it with, just to rule out its 2019 related?

Share this post


Link to post
Share on other sites

Update to the latest firmware on a PC.

https://support.thrustmaster.com/en/product/tmxforcefeedback-en/

should be version 7.

As suggested by @1512marcel try by lowering your FFB to 75%. There does not appear to be a 'forced fan' firmware setting like there is with the T300 (does the TMX even have a fan?!?!).

If it works for longer periods on 75% (you have to lower it to this to have any +ve effect on overheating) then overheating is the issue. If 75% works, try incrementing towards 100% until you find where it cuts out at the interval you have observed. I think if you can run it at 100% anything over that is asking for issues really.

Good luck!

Share this post


Link to post
Share on other sites

i run 90% ffb on f1, but it lasts longer on f1 than dr2.0, and when i do go on pc to play Asseto corsa and my wheel has never turned off on pc though, firmware is on v7. TMX also doesn’t come with a fan.

ill probably try to find the right ffb for all games, may be a bit of a pain as it takes over an hour for it to randomly turn off sometimes. Appreciate the help 😀

Share this post


Link to post
Share on other sites
6 hours ago, DylanWest2004 said:

i run 90% ffb on f1, but it lasts longer on f1 than dr2.0, and when i do go on pc to play Asseto corsa and my wheel has never turned off on pc though, firmware is on v7. TMX also doesn’t come with a fan.

ill probably try to find the right ffb for all games, may be a bit of a pain as it takes over an hour for it to randomly turn off sometimes. Appreciate the help 😀

Since installing my T300 I placed a small 120volt muffin fan with rocker switch immediately next to my wheel base. My wheel only gets warm to the touch when playing Dirt Rally. If the base feels warm when it kicks out I suspect it's overheating. Try finding a small fan to blow directly on the wheel base while racing and see what happens. I'm an industrial electrician by trade. Heat is the #1 enemy of electronics. I have extra fans blowing cool air on everything relating to my rig. Seven in total :classic_unsure:. A little paranoid, but I haven't had one failure. Dirt Rally used to overheat my Buttkicker faster than any other game though (until I added fans to the shaker and amp), so that's what makes me think it's heat related.

Edited by Gr8_Lakes
Spelling error
  • Haha 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×