Jump to content Jump to content

Dirt Rally 2.0 has stopped working, access violation in dirtrally2.exe


HoksuHoo
 Share

Recommended Posts

I have had three crashes in a short time, two before 1.9 and one after. It's always access violation in dirtrally2.exe, though the address code seems to vary. It only happens in My Team, never in Freeplay. I sent the error reports. If someone has suggestions what to do, I would like to hear it. I have added dirtrally2.exe as an exception in both AV and Windows firewall. I have validated files in Steam. I maintain my PC pretty carefully and I am used to games not crashing, ever

dgffdg.png.8fd1889c628dbe10c1f8973a2d1b3737.png

PC Steam, Super Deluxe edition. System specs: 1230v3, GTX 1070, 16gb ram, 512gb SSD, Windows 10, Sound Blaster Z, 436.30 Nvidia driver. 2560x1440 resolution, no VR. G920 steering wheel

 

btw, the FAQ link gives an invalid address: https://www.dirt4game.com/crashfaq

Edited by HoksuHoo
Link to comment
Share on other sites

Pretty ridiculous support system it seems, I have the same issue. I just paid a bomb for the game yesterday, installed it and played for a couple of hours only to wake up this morning and I am getting the same error as above. I’ve tried everything in all the other forums to fix it so I came here expecting a solution.....only to find that nobody has even answered this guys problem. Seems I have blown my cash

  • Agree 1
Link to comment
Share on other sites

  • 4 weeks later...

Happened again in career rally event.

fdsfdsdsf.png.0d95c83c87fc4eb6ec578b5667da44c3.png

I reinstalled the game not long ago, again, it does not solve the problem since it always starts happening again. Verifying files does not help, tried 10+ times. Game is not modified in any way, 100% unmodded. All DLC enabled.

Edited by HoksuHoo
Link to comment
Share on other sites

Contact support directly. I had the same crashes happening just 2 or 3 times but in like 4 months. It is not true there is no support. Through the forum it is a real pain but contacting them directly or even calling them straight sounds like a quicker way 

image.png.6515e0e19a50b78e806e37a280b1da00.png
 

Edited by koog2003
  • Haha 1
Link to comment
Share on other sites

  • 4 weeks later...

I had this Problem after changing from a RX 570 to a  RX 590 GPU. Testing several tips from the www (Wattman settings, erase MSI Afterburner, Steam Overlay.......), all needless. At least I renewed my PSU. Update from an, around 10 year old, OCZ ModXtreme Pro 500W to a modern Be Quiet Straight Power 11 550W(for sure, it could be any other modern PSU). After this "Tweak" the Problem is gone and my GPU runs stable at 1545Mhz(with old PSU it's jumping continious between 1100 and 1545) while playing without crashing the Game.

So I guess, in my case it wasn't the Game that made problems but the aged PSU was unable to deliver the needed/constant Power to the GPU. Maybe it's a trial for other people here to solve the Problem.

Edited by hampti
Link to comment
Share on other sites

  • 2 months later...
On 12/15/2019 at 11:44 AM, hampti said:

I had this Problem after changing from a RX 570 to a  RX 590 GPU. Testing several tips from the www (Wattman settings, erase MSI Afterburner, Steam Overlay.......), all needless. At least I renewed my PSU. Update from an, around 10 year old, OCZ ModXtreme Pro 500W to a modern Be Quiet Straight Power 11 550W(for sure, it could be any other modern PSU). After this "Tweak" the Problem is gone and my GPU runs stable at 1545Mhz(with old PSU it's jumping continious between 1100 and 1545) while playing without crashing the Game.

So I guess, in my case it wasn't the Game that made problems but the aged PSU was unable to deliver the needed/constant Power to the GPU. Maybe it's a trial for other people here to solve the Problem.

I doubt that was the problem because you were getting a Write Access Violation which is in the code of the game where it is trying to read from an invalid address. But still, I'm getting the error and yeah, this is fun.

Link to comment
Share on other sites

  • 2 weeks later...

Access violation at address 0xeaf576c7 in module 'dirtrally2.exe' + 0x 8a76c7.
dirtrally2.exe

I'm getting this error...seems the same thing. I can replicate every time I drive a rally section...

Sent in the error by the automatic sending window.

Will anybody from devs answer this or do I need to email directly?

Link to comment
Share on other sites

On 11/7/2019 at 11:32 PM, HoksuHoo said:

Happened again in career rally event. Download: Run 3 online.

fdsfdsdsf.png.0d95c83c87fc4eb6ec578b5667da44c3.png

I reinstalled the game not long ago, again, it does not solve the problem since it always starts happening again. Verifying files does not help, tried 10+ times. Game is not modified in any way, 100% unmodded. All DLC enabled.

Thanks a lot ! 

Link to comment
Share on other sites

  • 3 weeks later...
3 hours ago, PPyrex said:

Absolutely no tech support by the looks of it.

None whatsoever.

I actually got a PM from a developer saying he cannot assist me because I have modified my game. I had a few skin mods at the time. I told him the game was crashing constantly before I had ever installed any mods, and it continued to crash after I removed all of them and reinstalled the game. He did not respond to that at all.

Link to comment
Share on other sites

  • 2 months later...
On 10/2/2019 at 10:26 PM, HoksuHoo said:

I have had three crashes in a short time, two before 1.9 and one after. It's always access violation in dirtrally2.exe, though the address code seems to vary. It only happens in My Team, never in Freeplay. I sent the error reports. If someone has suggestions what to do, I would like to hear it. I have added dirtrally2.exe as an exception in both AV and Windows firewall. I have validated files in Steam. I maintain my PC pretty carefully and I am used to games not crashing, ever

dgffdg.png.8fd1889c628dbe10c1f8973a2d1b3737.png

PC Steam, Super Deluxe edition. System specs: 1230v3, GTX 1070, 16gb ram, 512gb SSD, Windows 10, Sound Blaster Z, 436.30 Nvidia driver. 2560x1440 resolution, no VR. G920 steering wheel

 

btw, the FAQ link gives an invalid address: https://www.dirt4game.com/crashfaq

Try this, it worked for me

"I'm just posting here because i fixed an issue that a lot of players has :

My game runs at 5/10 fps on very low altought i have a good computer ( RTX 2070super, i7 cpu, 18Gb RAM, thrustmaster t150 wheel etc). You might even have this report when your game crash :
 "access violation at address 0x2e1cc875 in module 'dirtrally2.exe' + 0x8dc875. dirtrally2.exe"


I'll make it short for you because i know you are prob tired of trying a lot of solutions :


1) go behind your computer

2) unplug your screen and search for another hdmi port BEHIND YOUR GRAPHIC CARD, it might be hidden behind a plastic cover.

3) Now your motherboard recognise your main graphic device as your GPU and not your CPU, and the game should run smoothly.

 

i hope this helps, good luck "

  • Haha 1
Link to comment
Share on other sites

  • 1 month later...

Same error here. 

I thought that was due to my old PC (i'm running an AMD FX8320 + Nvidia 770 GTX), but then I found this thread. In fact, the game is running very well (more than 70 FPS all the time), until I get the error. 

In my case, the screen freezes but the sound still works in the background. Then I enter to the tasks admin and that's when I get the error mentioned above.
 

 
 
 
Edited by AdrinRS
Link to comment
Share on other sites

  • 2 weeks later...
  • 10 months later...

For half year game was running smoothly and now i'm getting this error "Access......"

I haven't modified game files and no recent changes, just small Win10 x64 autoupdate, but possible i got errors earlier than installed this update.

Link to comment
Share on other sites

  • 1 month later...

Hi everyone.

This error happened to me constantly ... I changed my mouse, keyboard, I formatted my pc, I installed all the updated drivers, and there was no way, I always got the error.

One day by chance, I found a bug in the "System32" folder, the "config" folder was missing, but the PC did not show me any errors, only the Dirt Rally 2.0 error.

To fix it, run CMD as administrator and ran the following command line:

 

dism.exe /Online /Cleanup-Image /RestoreHealth

 

Once it finished, it told me that it had restored the system integrity damage. I rebooted my PC, and I verified that indeed the "config" folder was already inside y "System32".

Since then I have not had the problem with DR 2.0. The error disappeared.

This seems to happen on some PCs because a Windows update deletes the "config" folder.

Sometimes when we format and update Windows, to re-install DR 2.0 in a clean way, we do not realize that this folder has disappeared because of the update, and we think that the error is from the game.

If this is your case, I hope it is also your solution.

Greetings.

Link to comment
Share on other sites

Hi everyone.

I have uploaded NVIDIA driver, and started to have the same issue. Crashing all the time. But I guess that is not the reason why.

I am in the way to download it again from scratch (DiRT Rally 2.0), but download is extremely annoying. Basically is stopped.

Does anyone what's the deal with this issue?

Thank you

Link to comment
Share on other sites

  • 5 months later...

Hi, everyone. Perhaps this way of solving the problem can help someone. I experienced this problem while playing career mode. After several countries, I moved to the USA stage. First, the game just got stuck on the loading page. It was just loading endlessly. After restarting the game it crashed during loading that same stage with this error:

Access violation at address 0xaea9a87f in module 'dirtrally2.exe' + 0x8fa87f

I tried to find a solution on the Internet, but none of the solutions I could find worked. I decided to ask the customer service (custservice@codemasters.com) and their solution actually helped. After running the DxDiag file and trying to start the game in a safe mod (none of that helped), the customer service representative asked me to check the integrity files through Steam, which I did and it surprisingly helped. I guess this problem may be caused by some reasons that are different for different users, but perhaps this solution can help someone. 

Link to comment
Share on other sites

Hi, everyone. Perhaps this way of solving the problem can help someone. I experienced this issue while playing career mode. After several countries, I moved to the USA stage. First, the game just got stuck on the loading page. It was just loading endlessly. After restarting the game it crashed during loading that same stage with this error:

Access violation at address 0xaea9a87f in module 'dirtrally2.exe' + 0x8fa87f

I tried to find a solution on the Internet, but none of the solutions I could find worked. I decided to ask the customer service (custservice@codemasters.com) and their solution actually helped. After running the DxDiag file and trying to start the game in a safe mod (none of that helped), the customer service representative asked me to check the integrity files through Steam, which I did, and it surprisingly helped. I guess this problem may be caused by some reasons that are different for different users, but perhaps this solution can help someone. 

Link to comment
Share on other sites

  • 9 months later...

I was getting this error every game I played today. Happened 5 times.

I haven't tried the solution above but what I did do that worked for me as unplugging all of my other controllers (HOTAS & flight pedals). I then when into the game settings and deleted all controllers other than what I am using for this game: G920 and pedals. I have played 8-9 races now and no issues have arisen.

 

Link to comment
Share on other sites

 Share

×
×
  • Create New...