Jump to content

GRID2019 Doesn't detect monitor properly

Recommended Posts

UPDATE: Reproduction steps and workaround in thread.

 

GRID 2019 isn't detecting my monitors correctly.

I have a 2560x1440p 165hz monitor that's not allowing me to set above 60hz. But my second and third monitors (only 60hz) are allowing me to select above 60hz.. and above the resolution they allow.

The game detects all 3 but the settings are just not correct. Additionally, it's not detecting the native resolution properly. It's stuck at 

I've attached my DxDiag report.. would really appreciate some assistance here.

All drivers are up to date.

 

image.thumb.png.73121bae25b17c096f6ff13ebc56a9b7.png

DxDiag.txt

Edited by mojoe_x

Share this post


Link to post
Share on other sites

Bump.

I've had to manually edit the hardware_settings_info.xml and hardware_settings_config.xml files and set them to read only in my games folder for my monitor to even register the correct resolution!

Additionally, I'm unable to stream this game due to unbearable flicker on the recording footage.

What's going on here, CM? Can you please update? Is there going to be a nVidia game ready driver for this?

Share this post


Link to post
Share on other sites
13 hours ago, IconicJB said:

Additionally, I'm unable to stream this game due to unbearable flicker on the recording footage.

Does your hardware support DX12?

Share this post


Link to post
Share on other sites
Just now, UP100 said:

Does your hardware support DX12?

As you would see from my DxDiag, yes it does.

Share this post


Link to post
Share on other sites

Could you get us a video of the flickering? What recorder are you using, and does this happen with other recording software as well?

Share this post


Link to post
Share on other sites
28 minutes ago, UP100 said:

Could you get us a video of the flickering? What recorder are you using, and does this happen with other recording software as well?

It happens with OBS and Streamlabs. I haven't tried other recording software.

It occurs using x264 software encoding and NVENC.

Only with game capture. If I use display capture, it doesn't flicker. However, the performance is significantly worse using this method.

 

Video here: 

 

Share this post


Link to post
Share on other sites

What about Window Capture? I've always had problems (like since 2014) with OBS' Game Capture for some reason. Also could you try changing the resolution to something smaller and see if it makes a difference? If the game has a "Windowed Fullscreen" option, that could also help us narrow the issue down.

Share this post


Link to post
Share on other sites
18 minutes ago, UP100 said:

What about Window Capture? I've always had problems (like since 2014) with OBS' Game Capture for some reason. Also could you try changing the resolution to something smaller and see if it makes a difference? If the game has a "Windowed Fullscreen" option, that could also help us narrow the issue down.

Window and Display capture causes bad performance, like in most games.

Game Capture works on every other game I play. I'm not changing my display resolution, but I've attempted changing the output resolution and framerate to no avail. Windowed/Fullscreen/Windowed Fullscreen makes no difference.

It seems to be related to the issue I'm having where it cannot detect my monitors correctly, as if the game is running on another monitor it doesn't seem to happen.

It's only on the (primary) gaming monitor - the one that the game doesn't seem to like the settings for (1440p, 144+ hz).

 

Edited by IconicJB

Share this post


Link to post
Share on other sites
1 minute ago, IconicJB said:

Window and Display capture causes bad performance, like in most games.

Window Capture works on every other game I play. I'm not changing my display resolution, but I've attempted changing the output resolution and framerate to no avail. Windowed/Fullscreen/Windowed Fullscreen makes no difference.

It seems to be related to the issue I'm having where it cannot detect my monitors correctly, as if the game is running on another monitor it doesn't seem to happen.

It's only on the (primary) gaming monitor - the one that the game doesn't seem to like the settings for (1440p, 144+ hz).

 

I should be getting the game today (it took a 360km detour), so I'll check then and see if I can somehow recreate it. Most likely can't, but at least I'll try 🙂 

Share this post


Link to post
Share on other sites
Just now, UP100 said:

I should be getting the game today (it took a 360km detour), so I'll check then and see if I can somehow recreate it. Most likely can't, but at least I'll try 🙂 

Good luck. One other point - If I disable one or two of my other monitors it does seem to pick up the monitor settings correctly, but the flickering still occurs.

Share this post


Link to post
Share on other sites

Bump.

Any word on this issue? Is it a problem you've identified internally or can I receive some support to fix the issue?

To recap;

  • Monitor settings are not detected properly. Causes graphical and performance issues.
  • Horrendous flickering for recordings when using Game Capture in OBS or Streamlabs or any other software capable of capturing game output directly.

Share this post


Link to post
Share on other sites

UPDATE: I believe I've narrowed down the cause of the flickering issue (stream output) in OBS and Streamlabs.

 

I reset all settings to default (including the hardwaresettings folder in /My Games/GRID 2019/) and starting playing around.

 

First of all, my 165hz monitor is still reporting incorrectly in-game. It's only allowing a max refresh of 60hz. Whereas my 60hz monitor is reporting up to 165hz.

So for the 165hz monitor (in-game set to 60hz - the max) if I cap at 60fps, I get no flicker on Game Capture (stream output). If I set anything above or Unlimited on the frame cap, it flickers terribly.

 

The same issue occurs on the 60hz monitor. If I set the frame cap to anything above 60fps, I get awful flickering on the Game Capture (stream output).

 

I would really appreciate a response or update to this issue and whether it will be addressed.

 

Thanks.

Share this post


Link to post
Share on other sites

UPDATE 2: It's only ever when you uncap FPS or cap higher than 60fps. So there's that workaround for now. Just means I have to play the game at 60fps!

 

Also reproduction steps for monitor issue;

  1. Plug primary monitor into a different port on GPU so that Windows and Nvidia control panel registers it as "2", not "1".
  2. Set "2" as primary monitor in Nvidia control panel
  3. Launch game. Display "2" is your primary monitor, but taking secondary monitor settings (1).
  4. Display "1" is your secondary monitor, but taking primary monitor settings (2).
Edited by mojoe_x

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×