Jump to content
F1 2020 | KNOWN KEY ISSUES | READ ME!!! Read more... ×

Error mesagge -GRID 2019

Recommended Posts

I have the same problem: 

Illegal instruction at address 0xb4078215 in module 'Grid_dx12.exe' + 0x6f8215.
Grid_dx12.exe

 

GTX 970

AMD Phenom II X6 1100T

16GB ram

i mostly believe DirectX 12 IS the problem so blame on that.

Share this post


Link to post
Share on other sites

ok i have now bought a ryzen 2600 cpu a tomahawk max motherboard and had to buy new ddr4 ram the game now works,

i was using a phenom 955 be cpu  an msi 970 gaming board and ddr3 ram, still using my old gfx card gtx 760.

Share this post


Link to post
Share on other sites

Hey all,

We're tracking this so please follow our guidelines (in the pinned post on the Technical Assistance main page) so that we have as much information as possible to work off. Thanks! 

Share this post


Link to post
Share on other sites

I have the same problem, and i have a high spec machine too:

16gb ram

1060 gtx nvidia 6gb,

Intel(R) Core(TM) i7-6700HQ CPU @ 2.60GHz, 2601 Mhz, 4 Core(s), 8 Logical Processor(s)
 

I downloaded the very latest nvidia driver this morning, 

the game crashes and gves the exact same error being reported here, its easy to recreate, i just go to options and select 'video' then boom!!

my gfx card is powerful enuff to run dx12.. 

 

Share this post


Link to post
Share on other sites

Codemaster support - why has the review code been given dx11 versions and youve only released retails with dx12 version!! this is insane..

you need to add dx11 version back, bite the bullett, admit you where wrong and fix the issue for your paying customers!!

this is what causing all the problems in these threads!! 

while we your paying customers sit here waiting for you to fix this, not so nice people are playing cracked version wit dx11 on them!

how can that be fair!!??

 

  • Agree 2

Share this post


Link to post
Share on other sites

FIXED ISSUE ON MY GAMING LAPTOP .. hopefully this will work for you too.

I have literally spent all day tweaking every setting and trying every fix...

I Applied the fix posted by K0ng__ in the Steam forums to limit the usage of DX to 11.1, this did make a slight improvement but not much. (entitled fixing the game against developers will.. (forcing DX11 through Windows.)

I then saw in the crash logs that it was using my onboARD graphics , not my NVIDIA gfx card,

Then I setup a rule in nvidia control panel to use the nvidia card for the grid_12x.exe file , but this still caused the game to crash when i went into 'options | video'

when I cheked the crash log i saw it was still using my onboard gfx , not my nvidia card

Went back to nvidia control panel, created a global setting for EVERYtHING to use the nvidia card and at the same time I un-did everything in Kongs__ steam fix...

Then I launched GRID and it worked! 

I dont know if I needed to do both the global setting AND undo K0ngs__ settings.. but its working AND ITS WELL worth it!!

Good luck all , I  hope this helps you! 🙂

 

 

 

Share this post


Link to post
Share on other sites

Same for me, it occured in the second race of the first series, some details that may help the tech team below:

- I was using the Subaru WRX

- The error only occurs if i chose to do the qualification lap

- No patches, miraculous solutions or anything on Nvidia controll panel, all stock

- Drivers updated

 

GTX-760

I5-4460

8GB

Share this post


Link to post
Share on other sites
2 hours ago, Deliuk said:

 

Went back to nvidia control panel, created a global setting for EVERYtHING to use the nvidia card and at the same time I un-did everything in Kongs__ steam fix...

🙂

 

can you explain how to do this please Deliuk.

 

 

Share this post


Link to post
Share on other sites

Trying to play i discovered one more thing, the error only occurs for me when i try to practice on the FIRST race of a 2-round race, independent of the car, but i only tested in japan tracks.

Share this post


Link to post
Share on other sites

sure thing, this is how i did it Mcnab,

1. I went into the nvidia control panel

2. clicks on manage 3d settings

3. under the 'global settings tab' select the click on the drop down for the "preferred graphics processor" and select your card, as shown in  the img below.. 🙂

 

image.png.8bd64977e2322bc73ce815abd64443a6.png

 

Good luck mate

Deli

 

Edited by Deliuk
corrected img files

Share this post


Link to post
Share on other sites

Hi guys the game is rendered completely unplayable for me.  Runs the video intro for the introductory race and crashes with the DX12 error message every time no matter what I do.  Have followed all suggestions in the thread but no luck.  I'd expect an official response by now 😔🙁😖

Intel 4700k and RTX2080 Ti on windows 10 latest drivers.  I have other games running perfectly under DX12 so it has to be the codemaster implementation!!!!  Come on Codies you need to get this resolved quick.

Edited by UberScrew
Spelling

Share this post


Link to post
Share on other sites
3 hours ago, Deliuk said:

sure thing, this is how i did it Mcnab,

1. I went into the nvidia control panel

2. clicks on manage 3d settings

3. under the 'global settings tab' select the click on the drop down for the "preferred graphics processor" and select your card, as shown in  the img below.. 🙂

 

image.png.8bd64977e2322bc73ce815abd64443a6.png

 

Good luck mate

Deli

Hi deli i do not seem to have that option in my 3d settings any ideas?

 

Untitled.png

Untitled 1.png

Share this post


Link to post
Share on other sites

I get this error " Access violation at address 0xbeec2999 in module 'Grid_dx12.exe' + 0x182999.
Grid_dx12.exe"

it always happens at the end of a race when the lap time screen appears without saving the results of the race , and seems to be very random , can do 5-6 events and then boom the game closes with this error ??

very annoying , all drivers are up to date GPU is Nvidia 1080ti

Share this post


Link to post
Share on other sites

@mcnab.. thats very strange mate.. looks like a different version to mine, when you click on help | about whats the version number u see?

mine is ...

image.png.b24ae09f1ae4598205d8747e790113ed.png

 

if its the same version as yours it might look different because im on a gaming laptop.. not a desktop.

Share this post


Link to post
Share on other sites

 

On 10/11/2019 at 10:29 AM, ChrisGrovesMCM said:

Hey all,

We're tracking this so please follow our guidelines (in the pinned post on the Technical Assistance main page) so that we have as much information as possible to work off. Thanks! 

Hi @ChrisGrovesMCM

Can you please provide us an update on how your investigation is going?

Deli

Share this post


Link to post
Share on other sites

"Access violation at address 0x5aec8a2c in module 'D3D12.dll' + 0x8a2c.
D3D12.dll"

  • GPU: sapphire R7 265 (2gb) with latest AMD drivers (19.10.1 ver)
  • CPU: AMD FX-6300 4,2Ghz
  • RAM: two 4gb DDR3 sticks
  • Game is running through Steam with low-ish settings in full screen mode with TAA antialiasing. Playing on dualshock 4 controller connected via usb cord.
  • Game installed on separate SSD
  • I'm using two monitors with game running on one of them in 1920x1080 resolution

I played couple of races in career mode before updating my gpu drivers from stable release to newest ones (19.10.1) which add support for GRID. After updating drivers i tried playing with textures set to High instead of low and after selecting a car in a race - game would just load infinitely before closing without any error messages (tried 3 times with infinite loading each time). After that i selected low textures and game would load the race in less than a minute. After that game would work fine without crashing for couple of races after which game crashed with the same error as above. Now when i start the game and get to main menu - game repeatedly crashes with same error. I can record video of the crash if you need.

  • Update: "0xbb4a771b in module 'Grid_dx12.exe' + 0x69771b. Grid_dx12.exe" crash happened during singleplayer gameplay after reverting to 19.9.2 WHQL drivers

DxDiag.txt

f9908503-2ac3-4e82-9589-d2b4854b8002.zip

Edited by Hilt85

Share this post


Link to post
Share on other sites
8 hours ago, mcnab said:

Hi deli i do not seem to have that option in my 3d settings any ideas?

That is because you do not have onboard gfx, just a GPU card, so the control panel only sees your GPU.

Same for my PC

 

I am guessing Deliuk has a laptop.

 

 

Share this post


Link to post
Share on other sites
On 10/11/2019 at 11:58 AM, Deliuk said:

Codemaster support - why has the review code been given dx11 versions and youve only released retails with dx12 version!! this is insane..

you need to add dx11 version back, bite the bullett, admit you where wrong and fix the issue for your paying customers!!

this is what causing all the problems in these threads!! 

while we your paying customers sit here waiting for you to fix this, not so nice people are playing cracked version wit dx11 on them!

how can that be fair!!??

 

Quoting this post because I think it's very relevant, also there's been a lot of videos showing DX11 vs DX12 performance comparisons with DX11 out-performing DX12 by as much 20%.  Sorry Codemasters this is unacceptable, please add DX11 support back into the game in a future update.

  • Agree 2

Share this post


Link to post
Share on other sites

Cannot launch Grid Ultimate edition. no error, nothing in event vwr, no logs... steam just showes starting, hourglass, syncing, thats it.
Full re-installed on C: didn't change anything. Grid2 & Autosport running perfect.

i7-3770k + 980gtx, 16gb, w10

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×