Jump to content
Sign in to follow this  

DiRT Rally - Hanging/Stuttering in the first rally in a session (with video)

Recommended Posts

The issue that I have is that the first rally stage that I do when I start playing the game hangs and stutters all the way through. All subsequent stages are fine, though there is a freeze here and there they are much rarer and I can deal with them for now. 

I am supplying an unlisted youtube video here http://youtu.be/lXU3SEk-x1E. These stutters happen similarly both when recording and when playing with nothing else in the background. The driving is poor and careless but mostly because I know it'll be a waste of time anyway. 

In the video it starts to get particular bad from 4:30 onwards with numerous stutters all the way to the end of the stage. 
There are two other stages in there for comparison. In the second one there is one stutter that I recall, and in the third there is only a stutter when the car is totalled at the very end. 

Spec
------
Nvidia GTX 660 (drivers updated)
Intel i5 3570K (no overclocking)
8gb RAM
120Gb SanDisk SSD (Where Rally is installed)


Displayed on 1920x1080p monitor with a second 1280 x 1024 monitor. Using DisplayFusion as my multi monitor software

Software running in background at time of test
Chrome, Foxit PDF, Spotify, and in the case of recording Open Broadcast Software

Steps to Reproduce
---------------------------
Start Dirt Rally > Any Game Mode > Any Stage > Any Car  > Chase camera 1 > variable distance into stage
No recent history since it's just after the game starts

Graphics settings on Ultra

Dxdiag





Share this post


Link to post
Share on other sites
Hi thanks ilborga, I played around with Vsync(it was already off in game) but unfortunately it had no impact on the frequency of hangs/stutters.

Share this post


Link to post
Share on other sites
It's solved? beacuse i try with vertical sincronization ; enabled, adapotative, and when i drived half of track the game start to take some stuttering and input lag was big. any trick for that?

Share this post


Link to post
Share on other sites
It's solved? beacuse i try with vertical sincronization ; enabled, adapotative, and when i drived half of track the game start to take some stuttering and input lag was big. any trick for that?
This is not solved, the issue remains. I have not got any fixes. 

Share this post


Link to post
Share on other sites
Have you tried a single monitor? As in disable your other monitor, shutdown display fusion, and game on one.  Also thats not a bleeding edge card, and you will probably struggle gaming in 1920x1080 as the card doesn't have enough ram to carry it. It looks to me like it's swapping the textures in and out of the videocard memory. Dropping texture settings and turning off AA would be my first port of call. You could also try lowering resolution. Also ensure you have the latest Nvidia drivers installed, they look at least 2 years out of date to me.

Share this post


Link to post
Share on other sites
You've not got the newest drivers, newest driver came out 13/04/2015 version 350.12 http://www.nvidia.com/download/driverResults.aspx/83819/en-us

Share this post


Link to post
Share on other sites

Have you tried a single monitor? As in disable your other monitor, shutdown display fusion, and game on one.  Also thats not a bleeding edge card, and you will probably struggle gaming in 1920x1080 as the card doesn't have enough ram to carry it. It looks to me like it's swapping the textures in and out of the videocard memory. Dropping texture settings and turning off AA would be my first port of call. You could also try lowering resolution. Also ensure you have the latest Nvidia drivers installed, they look at least 2 years out of date to me.

Ran on a single monitor, DisplayFusion not running and running on ultra low. Drivers are 350.12.

Still have the same issue but still it only ever happens on the very first stage that I run. 

Share this post


Link to post
Share on other sites
Do you have the Geforce Experience installed? I did and mine stuttered on a GTX770, removed it and it was gone, now getting a good 70FPS on mainly ultra settings

Share this post


Link to post
Share on other sites
Do you have the Geforce Experience installed? I did and mine stuttered on a GTX770, removed it and it was gone, now getting a good 70FPS on mainly ultra settings

I removed geforce experience and there does seem to be an improvement. It still hangs two or three times in a small chunk about 1-2 mins into the first rally, but there was almost none after that so that's a big change so good advice!

If I can eliminate those last few stutters I'll be golden. 

Share this post


Link to post
Share on other sites
Could I please get some dev input on this it makes the game completely unplayable. It happens all the time on the new Pikes Peak map. This is very disappointing. 

Share this post


Link to post
Share on other sites
Nvidia released a new driver for their cards today. It renames the DiRT 4 folder to DiRT Rally and changes the games refresh rate from 100fps to 60fps, my game runs prettier and smoother now

Share this post


Link to post
Share on other sites
It isn't the Witcher3 one, it came out after. Apparently, it was the Witcher3 driver update that caused the incorrect fps settings, this one changes the name of your DiRT4 profile in your Nvidia Control Panel to DiRT Rally and resets your fps.

Mine



ilborga70s
ilborga70 said:

Check your Nvidia Control Panels 3D Settings to see which version yours has


Share this post


Link to post
Share on other sites

My game did the very same thing to me a while back... it was due to my GPU overheating. My solution was to open up the PC and point a stationary fan to the graphics card.

Sorry if heat isn't the issue, but your stutters are very similar to the ones I had... just a thought. Hope you get it sorted.

Share this post


Link to post
Share on other sites
Hey guys, so it appears my problems were likely caused by the replays writing to my SSD. I followed fixes one and two here http://steamcommunity.com/app/310560/discussions/1/617335934132920537/ and I haven't had any stutters yet! Will report back if it turns out to be luck

Share this post


Link to post
Share on other sites
I have a razer mouse and I turned off the Synapse program and the stuttering is still present.
I tried even this  <threadStrategy workerMapFile="system/workerMap4Core.xml"/> and the stuttering is still present  :(

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×