Jump to content

All USB devices gone, post here as requested

Recommended Posts


Support request regarding post in general discussions regarding all USB devices gone.

Game was working great with all my devices showing up and being assignable. Simucube, Aiologs shifter and handbrake, Heusinkveld pedals, etc. They all worked great.

I made no changes (perhaps there was a Windows update?) but suddenly my devices were just listed as Direct Input with a symbol beside them like an oval with a line through it. Clickon one weirdly highlighted them all white together. The only option it gave me for each device was to delete. I tried deleting and reloading, they didn't come back. I have completely uninstalled the game and reinstalled, it only shows Keyboard as a device, nothing else is listed at all. All my devices still work perfectly in Windows and other games.

Windows 10 64 bit.

I do not see a game version in the bottom left at all, but I am on the latest version on Steam.

Game mode is irrelevant here.

No known lead up, went to play it and this had occurred.

No error messages.

Simucube wheel, Heusinkveld Spint pedals, Fanatec Clubsport 1.5 SQ shifter, Aiologs shifter, Aiologs handbrake (as I say all were recognised and working fine before).


Please help, I paid a lot for the Ultimate Edition and so far not had the chance to play much 😞


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now