Jump to content

DiRT Rally 2.0 - Version 1.10 Bug Reports

Topic will be automatically locked at 00:00

Recommended Posts

On 11/15/2019 at 1:08 AM, Tranzitive said:

I'm still getting the rain nails. This just happened to me today in the Group A weekly in New England. Stage 8, North Folk Pass Reverse. 

If it helps the dev team work out what the problem is, this seems to happen exclusively when starting a stage in an interior view. I've had the game since launch and not once had it happen to me when using an exterior cam. Picture was just taken from bonnet cam as I switched to bonnet cam after starting the stage in cockpit cam to try and see better. 

System is PS4 Pro, game is installed on an internal Samsung 860 EVO SSD if that info makes a difference. 

@PJTierney

20191114_220212.jpg

Hi @PJTierney and @Tranzitive

Have had the LASER RAIN OF DESTRUCTION AND DEATH happen to me 3 times in last couple of months since I last commented here on the problem. Twice in dailies. Most recent was a daily in NZ a week or so ago. 

Haven't had it happen in monthly or weekly events of late but I always quit out of event only at service or finishing the event. Not sure if this really works or I have just been lucky.

@Tranzitive  I only drive with bonnet cam so it is causing chaos with that exterior camera angle as well.

The other time it happened  was in Career but luckily I was at service. Going back to menu and back in again reverted it to normal rain. I don't play career much either. I mainly do dailies, weeklies and monthlies. So IT IS happening in Career (rally)

PS4 standard with NO fancy internal Samsung 860 EVO SSD

Deluxe Edition plus Seasons 3 & 4 (see I support you guys even though I rarely play rallyx)

Love the game and cheers

  • Like 1

Share this post


Link to post
Share on other sites
On 11/15/2019 at 2:13 AM, Tranzitive said:

So i ran the stage after the one reported above, which i think was North Folk Pass (normal, not reversed). 

Since i finished the previous stage in bonnet cam the game started the next stage in that cam, and no rain nails at all even though it was still raining. Everything was fine. 

Not exaggerating when i say i've literally never had it happen to me at all when playing the game in exterior views in 10 months of owning the game. 

Wouldn't be surprised if the issue is somehow connected to the rain rendering when using interior cams as some of the lighting etc looks a bit different in the interior cams. 

BTW the car I was using was the Mitsubishi Lancer Group A, in case it's maybe car related too. 

 

Hi again @PJTierney and @Tranzitive

Like I said in my previous post, it is happening to me driving with bonnet cam (the only one I use)

It's not car related either because it has happened to me with numerous car classes (RWD, FWD and AWD) 

And it has happened to me in daily, weekly and monthly events as well as once in career (which I hardly play)

I even tried a RWD daily a few months ago that someone posted on reddit they had the rain problem with, and it was fine for me

Seems completely random. Not even sure if its just a PS4 problem or other platforms have it (I have seen posts on steam forums about the problem)

And most times the rain is fine.

There was an initial patch that fixed the dodgy rain that was in the game at launch. There was a second patch after that which refined those changes.

I started getting the Death Rain not long at all after that second patch to refine the rain

Hope that helps

Cheers

  • Agree 1

Share this post


Link to post
Share on other sites
On 11/17/2019 at 9:08 PM, Samuel Dodee said:

I unlocked Watch the DELTA here, but I couldn't unlock Living the Dream.

I bought Audi four times and every other car twice: still 4 out of 5.

Unlocked today!
All Gr. Bs were already in my garage, so I bought Peugeot, Lancia and Ford. When I bought the last one, I got the achievement.
I'm sure Ford was counted when I bought it the first time so it's odd.

Share this post


Link to post
Share on other sites
On 11/6/2019 at 4:43 AM, Tigron said:

Version 1.10.1 - Steam - Super Deluxe Edition

What is going on with headlights? Is it a bug, or it is legitimate in game "unexpected" event to make the stage harder?

Also the following video illustrate my previous post about replay camera problem.

 

As mentioned already, this is intentional.

 

On 11/9/2019 at 8:38 PM, HoksuHoo said:

In Ford RS200 the texture between dashboard and bonnet is very blurry and low-res

20191108193311_1.thumb.jpg.b5f9befc8295e99e6bed2d2702e9e13d.jpg

  • What platform you're playing on: Steam
  • What your PC setup/build is like (graphics card, processor etc.).: 1230v3, GTX 1070, 16gb ram, SSD, Sound Blaster Z, Windows 10     
  • Whether you're a Standard or Deluxe user (doesn't apply to Oculus). : Super Deluxe   
  • Whether or not you have any non-standard peripherals connected, like steering wheels, gaming mice etc. : G920 steering wheel+shifter

What graphics settings (related to cars) are you using?

 

On 11/9/2019 at 8:59 PM, HoksuHoo said:

Virtual rear-view mirror cannot be used in cockpit view, this makes no sense at all. Some RX cars do not have a mirror, and playing with narrow FOV you can't see it with the ones that have. It should be available in cockpit view as well

  • What platform you're playing on: Steam
  • What your PC setup/build is like (graphics card, processor etc.).: 1230v3, GTX 1070, 16gb ram, SSD, Sound Blaster Z, Windows 10     
  • Whether you're a Standard or Deluxe user (doesn't apply to Oculus). : Super Deluxe   
  • Whether or not you have any non-standard peripherals connected, like steering wheels, gaming mice etc. : G920 steering wheel+shifter

Can you post screenshots with your normal FOV settings applied?

 

On 11/12/2019 at 6:17 PM, Deltone91 said:

• PC, Steam user.
• Windows 7 professional 64 bit, Intel Core i5-3450 3.10 GHz, 12 GB RAM, Nvidia GeForce GTX 1060 3GB.
• Deluxe user.
• OSW Simucube (steering wheel), Xin-Mo Controller (Shifter), BU0836-LC Interface (Pedals), BU0836A Interface (Handbrake).

Bug: Bad texture Opel Adam R2 internal

1757084125_OpelAdamR2.thumb.jpg.080f93b690df7f3462312de38620b797.jpg

What graphics settings (related to cars) are you using?

 

On 11/12/2019 at 6:19 PM, Deltone91 said:

• PC, Steam user.
• Windows 7 professional 64 bit, Intel Core i5-3450 3.10 GHz, 12 GB RAM, Nvidia GeForce GTX 1060 3GB.
• Deluxe user.
• OSW Simucube (steering wheel), Xin-Mo Controller (Shifter), BU0836-LC Interface (Pedals), BU0836A Interface (Handbrake).

Bug: shifter light Opel Corsa RX s1600

1082642456_OpelCorsaRXS1600.thumb.jpg.c32d3044d5ac05bd4c5267c9ef022cda.jpg

What graphics settings (related to cars) are you using?

 

On 11/16/2019 at 10:23 AM, AUTOPELI said:

I bought a new GPU and now the game resets graphic settings every time I start it. This is very frustating issue. Please fix ASAP! Deleting the 'hardwaresettings' folder doesn't help nor checking file integrity on Steam. Steam Cloud is also not the issue since the settings which the game resets to are the very default settings.

EDIT. I realized there are no files in the folder I deleted and which was recreated. Why verifying files doesn't download the .xml file? I disabled and enabled Steam cloud, but it doesn't download anything. There is no file with the settings now (.xml), could somebody send me this file please?

EDIT2. Okay it seems the 'hardwaresettings' folder is write protected, so you can only read files in there. The problem is when I untap the option of read only and hit apply, after checking again the read only option is enabled again. How is this even possible? Codemasters fix your messy game please.

EDIT3. This is a common and old issue across many Codemasters titles. Why is this not issued?

https://www.google.com/search?biw=2226&bih=1118&ei=Q03QXdHEGeuFmwWrr5r4BQ&q=codemasters+settings+reset+default+site%3Aforums.codemasters.com&oq=codemasters+settings+reset+default+site%3Aforums.codemasters.com&gs_l=psy-ab.3...5506.6414..6495...0.0..0.67.469.8......0....1..gws-wiz.nRCD-BAyk2k&ved=0ahUKEwiR8sf3uu_lAhXrwqYKHauXBl8Q4dUDCAo&uact=5

What PC specs do you have?

 

On 11/18/2019 at 10:04 PM, michciu1907 said:

Was reported at the time and is still on the tracking sheet. updated to show it's still in 1.10.1 🙂 

  • Thanks 2

Share this post


Link to post
Share on other sites
2 hours ago, PJTierney said:

Can you post screenshots with your normal FOV settings applied?

Polo S1600

20191120164745_1.thumb.jpg.98474c51ad2cf9732288284a505dbdcc.jpg

Lancia Delta S4 RX (has a mirror but not visible at all)20191120164923_1.thumb.jpg.5d083c0ccd80159da863c1dfd922f3f7.jpg

Audi S1 RX. Mirror is behind rollcage padding, modeling error?20191120165113_1.thumb.jpg.d5fdfe6015331feb12379073399f8040.jpg

Peugeot 208 RX

20191120165213_1.thumb.jpg.27394ee79a4fe2aea324d9b40165cf7c.jpg

How about adding a third option for virtual mirror. Off, on (except cockpit view), on (all cameras).

Also if it was possible to change the look back feature. Some cars don't have a very good visibility though the rear window, like the crosskart for example20191018163853_1.thumb.jpg.5cccc7f23b870a40f4701181262d2ce0.jpg

2 hours ago, PJTierney said:

What graphics settings (related to cars) are you using? 

Vehicle details ultra, texture detail ultra

Edited by HoksuHoo

Share this post


Link to post
Share on other sites
On 11/19/2019 at 10:13 AM, mickjack said:

Hi again @PJTierney and @Tranzitive

Like I said in my previous post, it is happening to me driving with bonnet cam (the only one I use)

It's not car related either because it has happened to me with numerous car classes (RWD, FWD and AWD) 

And it has happened to me in daily, weekly and monthly events as well as once in career (which I hardly play)

I even tried a RWD daily a few months ago that someone posted on reddit they had the rain problem with, and it was fine for me

Seems completely random. Not even sure if its just a PS4 problem or other platforms have it (I have seen posts on steam forums about the problem)

And most times the rain is fine.

There was an initial patch that fixed the dodgy rain that was in the game at launch. There was a second patch after that which refined those changes.

I started getting the Death Rain not long at all after that second patch to refine the rain

Hope that helps

Cheers

just to update this: a few days ago i got the bug for the first time where parts of the car don't render properly from the outside view. this also happened when i started the stage from an interior view. this was also the first time i'd experienced this bug. when i posted about the rain nails bug, that was also the first time i'd experienced it.

the similar factor here for me is using interior view. i recently picked up a wheel so have been using exclusively interior views for the last few weeks. previously i used to use exclusively chase cam as i was playing with a controller, and hadn't encountered either bug at all in 10 months.

so i would say that the rendering of 'exterior/added' objects when starting the stage from interior and/or bonnet cam might be worth looking into. both the car itself and rain are basically 'added' objects in that i'd assume they're added/rendered onto the stage.

it may be stage specific. unfortunately forgot to note down the stage the 'broken up' car bug happened for me. i'll try make notes on the stage + event + game mode these bugs happen on if i encounter them in future. but yes it does seem to be a bit random, which probably explains the difficulty they've had fixing it completely.

Edited by Tranzitive

Share this post


Link to post
Share on other sites

@PJTierney My specs are:

Ryzen 1700

16 Gb RAM

Radeon 5700 XT

Windows 10 x64

Game is installed on SSD on the system drive and has been never moved anywhere. After I swapped GTX 1070 to 5700 XT I got this problem. I first used DDU, then installed Radeon driver version 19.11.1 and haven't updated or installed any other version since then. To be clear the graphic settings have not remained with the Radeon card installed ever. Is this a driver issue or the game behaving wrong?

Share this post


Link to post
Share on other sites
9 hours ago, PJTierney said:

What graphics settings (related to cars) are you using?

Vehicle details: High

 

Share this post


Link to post
Share on other sites

@PJTierney I use PS4 to play Dirt and the bug with parts all over the car keeps on happening. It looks like I get it more often than before. It is hard to guess how it occurs, because Subaru and Peugeot were in Clubs but Polo R5 was in Weekly Challenge. I am pretty sure that I also got this in my career mode. 

It happens when the car is brand new and also when I slightly touch something so it is always different situation. Thankfully it does not affect any of driving physics, lighting etc. It just looks awful from the outside and on cockpit camera it seems to be working okay. 

 

 

IMG-3757.JPG

IMG-3756.JPG

IMG-3715.JPG

Edited by Snoopy43
  • Like 1
  • Agree 1

Share this post


Link to post
Share on other sites

@Snoopy43 Yes, I also had this bug on the PS4 Pro recently with the new version of the game 1.10 The problem occurs very rarely. I don't know what is triggering it, but you can stop the race before the countdown and then restart it again.

Share this post


Link to post
Share on other sites

We’ve known about that bug for quite a while, seen plenty of screenshots.

Share this post


Link to post
Share on other sites
6 hours ago, PJTierney said:

We’ve known about that bug for quite a while, seen plenty of screenshots.

Yes, I know. But it seems that I am now getting it everytime I play it. It is occuring more often. Until last week I got it once or twice. But now 4 times 🙂 

Share this post


Link to post
Share on other sites

Interesting bug, i also have a PS4 Pro, but in all the hours I played, I only had in once in the service area with the Pug 208 WRX. 

Share this post


Link to post
Share on other sites
On 11/22/2019 at 12:04 AM, Snoopy43 said:

I use PS4 to play Dirt and the bug with parts all over the car keeps on happening. It looks like I get it more often than before.

PS4 Pro

Had this few times, it was months ago when last saw this bug but at yesterday when played monthly it happened at last stage of last event (Greece).
No rainbug for months.

Anyone else have soundcuts with PS4 ?
First months with this game, there was zero problems with sounds but now sound cuts at every day :classic_unsure:
(PS4 Pro DD5.1-->LG OLED77C9 DD5.1-->Denon X4000-->2ch stereo to Sennheiser RS 170)

Share this post


Link to post
Share on other sites

Steam - Super Deluxe Edition

Window on Ford Fiesta OMSE SuperCar Lite does not get fixed even after full body repair.

Screenshot 2019-11-25.jpg

  • Like 1

Share this post


Link to post
Share on other sites

Having this error during CTD's while playing at least RallyCross

Access violation at address 0x650d2b18 in module 'dirtrally2.exe' + 0xe72b18.

dirtrally2.exe
 
W10, i7-3770k, 8gb ram, 1060 6gb.  The game runs smooth and all that, just suddenly pops out.  Mostly at race start and end. 
  • Like 1

Share this post


Link to post
Share on other sites

• PC, Steam user.
• Windows 7 professional 64 bit, Intel Core i5-3450 3.10 GHz, 12 GB RAM, Nvidia GeForce GTX 1060 3GB.
• Deluxe user.
• OSW Simucube (steering wheel), Xin-Mo Controller (Shifter), BU0836-LC Interface (Pedals), BU0836A Interface (Handbrake).

Bug: BMW M2 R-GT screen

Hawkes Bay, (Waimarama Sprint Reverse), (night, light showers, wet). 

I haven't tried other night conditions or other stage.

1013838925_BMWM2R-GT.thumb.jpg.9014ff5027f5459f2c9a0261441f38c4.jpg

 

Share this post


Link to post
Share on other sites

btw look at a distance the road surface is lit. It's too short for rally beams. I would say it's shorter than street low beams

Edited by MaXyMsrpl
  • Like 2

Share this post


Link to post
Share on other sites
2 hours ago, MaXyMsrpl said:

btw look at a distance the road surface is lit. It's too short for rally beams. I would say it's shorter than street low beams

I said it already couple of times in different places and I completely agree with you! My Focus has got better lights than light pods used in game and it is quite frustrating. I loved night stages in first Dirt Rally but in 2.0 I don't enjoy them that much unfortunately. The lights are simply not strong enough. I really hope that it can be fixed. 

  • Like 1

Share this post


Link to post
Share on other sites

- Steam, Windows 10 x64

- Core i5 7500, GTX 1650, 16 GB RAM

- Standard

- Xbox One controller

 

On every track with wet conditions chromed trim looks as it's just painted, not actually chromed. Changing graphics settings has no effect unless you choose 'Shader detail: Low', in this case chrome reappears but playing with low shaders is not an option for me. Game files Integrity check shows OK.

 

ERROR.jpg

Share this post


Link to post
Share on other sites

Hello there! Loving the game, played more then 700 hours since release (I still suck at it do).

 

PC, Steam user.
• Windows 7 professional 64 bit, Intel Core i5
-4670K, 8 GB RAM, AMD Radeon R9
• Deluxe user.
TM-TX wheel.

 

Since version 1.10 came out progression in weekly and monthly events seem not to be working for me. If I drive a stage and then go back to the main menu that stage I drove will be marked DNF, in the case of the AI events all the times are reset to some kind of nominal time or something, does anybody know what is going on?

 

This situation means that for instance a weekly AI RX event must be completed in on go, or else all of my progression on that event will be lost.

Edited by Sint78

Share this post


Link to post
Share on other sites

Hello DiRT Team,

I am writing this because I've come across a bug and/or issue with DiRT Rally 2.0 at the time of writing this.

The issue I have is that I have two accounts, one with all the DLC installed, and another one with no DLC on it. In order for me to use the DLC on the account that doesn't have DLC, I have to have the account that does have the DLC signed in when I'm playing the game. The issue is that I can't purchase any of the DLC vehicles because the game thinks I do not have any DLC active on the game, but I can still use the DLC cars in Time Trial. If the team can help with fixing this so I can use the DLC cars in the Events, that would be great!

Thank you,

Matthew Z (GamerLogicFTW/LSEM GamerLogic).

Xbox One S

Deluxe Edition Player

Controller

Edited by LSEMGamerLogic

Share this post


Link to post
Share on other sites

Audio is reversed, left is right and right is left. I noticed this at replays, then i bought third party headphones and put them on my head wrong side and everything is correct now. Reversed audio wasn't only on replays but while driving too, this caused lot of misinformation and broke immersion, but i didn't realize until i tested with new headphones.

 

SteamVR version of dirt rally 2

Edited by Jeq
specified vr version

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×