Jump to content

DiRT Rally 2.0 - Version 1.10 Bug Reports

Topic will be automatically locked at 00:00

Recommended Posts

    IMPORTANT: Read and understand this entire opening post before replying, as providing the right amount of detail will help out the team immensely in tracking and resolving any bugs that arise, thanks.

     

    ALSO: For VR-specific bug reporting, head here: 

     

     

    DR2_Peugeot_206_1.jpg

     

     

     

    Before posting, please make sure to follow these guidelines. Without adequate information the team will have trouble identifying and fixing bugs, so please provide as much info as you can:

  • Check if a bug has already been reported.
     
  • If you reported a bug in a previous version of the game, check your game first to see if it's been fixed.     
     
  • If a bug has been reported and you are experiencing the same issue, hit the ❤️ icon.     
     
  • The more popular bug posts will have a better chance of catching the attention of the team.
     
  • Also, this thread allows us to sort comments by how many votes they have, so make use of that feature 🙂      
     
  • If a bug cannot be reproduced, it cannot be fixed.     
     
  • When you experience a bug, please try to trigger said bug again if you can, and show us the steps you went through to trigger it.     
     
  • Text steps are good, video even better.     
     
  • One bug per post please, for our tracking purposes. That way every bug gets its own URL for us to investigate.     

     

    Please also provide the following:

  • What platform you're playing on (for PC also state Steam or Oculus).     
     
  • What your PC setup/build is like (graphics card, processor etc.).     
        
  • Whether you're a Standard or Deluxe user (doesn't apply to Oculus).     
     
  • Whether or not you have any non-standard peripherals connected, like steering wheels, gaming mice etc.     

Share this post


Link to post
Share on other sites

New error messages, but the same types here:

Type 1 CTD (Crash To Desktop):
179185801_DesktopScreenshot2019_10.30-14_38_15.jpg.8cd464587b5bc4385d174a1bd2883066.jpg

Type 2 (Racenet Error😞
182375128_DirtRally2Screenshot2019_10.30-12_07_24.thumb.jpg.2bd97efd6819b5af612c5a18eb319f82.jpg
PC / Steam

 

  • Like 1

Share this post


Link to post
Share on other sites

The topic you link to for VR bugs is actually closed..

On 1.10, when loading the service screen (setup, tires etc.) My headset freezes every time. 
I get that I won't get the same support afforded to oculus and vive users, but I'm using a psvr headset with iVRy driver.
It's supposed to let steam VR treat it as an oculus or index, worked pretty well in the last update; which I'm wondering how to downgrade to, so I can at least use custom events.

Lol my bad, actually it's crashing in any mode, in flat screen I think I hit start stage, I hear all the sound loading, but the screen is somehow stuck on communicating with racenet. lovely update guys. Any idea when I'll be able to use the product I paid money for again?
As someone pointed out in one of these threads back in august, ****** updates wouldn't be an issue if you utilised the steam beta function to enable reverting to a version of the game that works. Instead we have this dodgy roulette, where maybe the update will make the game better, or maybe some things will get worse. 
In this case, It made my game completely unplayable, it broke it. 

Maybe you're just focussed on the cycle of fixing the bugs caused by one update in the next, but you need to listen to the community and let us pick which version we want.
I remember several versions making it worse where I would have decided to stick with the one I had, and skipped an update. That is NOT difficult to allow through steam, please spend the few man hours it would require. 

drt1.PNG

Edited by Tallis161
additional bugs

Share this post


Link to post
Share on other sites

Something isn’t right with the sound, when Lifting off the throttle the engine noise disappears rapidly, also the lift of turbo noise, also the gravel noise. No car noise when car stops after stage finish. This wasn’t before 1.10, played on Xbox, cars tested so far Audi s1 and Impreza 01’. Especially those two cars had lot of noise after downshift and lift of throttle.

edit: all cars. It’s like the engine is stalled when lift of, very disturbing for the driving rhythm. Hope you will fix this

Edited by iwoban
  • Like 3
  • Agree 1

Share this post


Link to post
Share on other sites

Games crashed randomly, and at the same time Racenet wasn´t available

 

Dirt 2 incl. all DLC @Steam

RTX2080ti, 32GBRAM, i7 8700k, SSD only, Valve Index

Share this post


Link to post
Share on other sites

salut

 

Je ne peux pas continuer les défis mensuels actuels dans le menu "mon équipe". J'ai un message "Connexion échouée, le serveur Racenet n'est pas disponible ..."

Steam

i7 7700k ; 1080ti ; ssd ; 32GB ram

version Deluxe

steering wheel fanatec

Nouveau_document_RTF.rtf

Edited by Cebri0404

Share this post


Link to post
Share on other sites

 

I play the game on xbox one s.standard version.Such disturbances as seen in the screenshot in the game appear regularly.About the second the screen doubles.it repeats every 1-2 minutes.

111.jpg

  • Like 2

Share this post


Link to post
Share on other sites
  • What platform you're playing on. 
  • - Steam, PC / Xbox
  • What your PC setup/build is like (if playing on Steam).
  • - i7, 16GB RAM, GTX 1650Ti 
  • Whether you're a Standard or Deluxe user.
  • - Deluxe
  • Whether or not you have any non-standard peripherals connected, like steering wheels, gaming mice etc.
  • - No

Recently I'm noticing that in Rallycross races, if an AI driver gets into the lead off the start, they will always go to the joker lap on lap 1 which is not very realistic, could this be looked into?

Noticed first in custom events on PC, then WRX mode on Xbox and My Team on Xbox, it is the same on all RX tracks

  • Like 2

Share this post


Link to post
Share on other sites
  • What platform you're playing on. 
  • - Steam, PC / Xbox
  • What your PC setup/build is like (if playing on Steam).
  • - i7, 16GB RAM, GTX 1650Ti 
  • Whether you're a Standard or Deluxe user.
  • - Deluxe
  • Whether or not you have any non-standard peripherals connected, like steering wheels, gaming mice etc.
  • - No

The new "Consolidation Finals" elimination setting in custom RX events needs a toggle on/off in event settings rather than just being on regardless in order to allow us to play the way we want to, simulating Euro RX seasons for example where consolidation finals are not used.

Pleeeeeaaase can an option be added? Words cannot describe how much I hate this setting. I know it's a little thing and I bring it up every time there's a new patch but I'm desperate 😂

  • Like 1

Share this post


Link to post
Share on other sites
  • What platform you're playing on. 
  • - Steam, PC
  • What your PC setup/build is like (if playing on Steam).
  • - i7, 16GB RAM, GTX 1650Ti 
  • Whether you're a Standard or Deluxe user.
  • - Deluxe
  • Whether or not you have any non-standard peripherals connected, like steering wheels, gaming mice etc.
  • - No

The information for the following 2 stages in Greece seem to be replicated in the menus displaying the exact same length and elevation changes, meaning one of them is incorrect

Noticed on Steam version

1.jpg.c33639e267697b16efbb541cc79ecf06.jpg2.jpg.54c3279bbac1844949b4cbdcad866ace.jpg

  • Like 2

Share this post


Link to post
Share on other sites
22 hours ago, chukonu said:

This bug persists.

 

Codemasters, what are you doing? This gets reported time and time again, probably wouldn't be a very big task to add an option to disable it or at least turn it off when using the manual wipers setting, but yet for some reason this remains. You ask us to report issues, you claim that "DiRT Rally 2.0 is a title that is constantly evolving based on your feedback and how people play the game" but you don't fix windshield wipers despite umpteen requests and reports. What is going on?

Edited by HoksuHoo
  • Like 3
  • Agree 2

Share this post


Link to post
Share on other sites

Speaking of windshield wipers, in Porsche 911 SC RS they are wrong. They stop at about 45 degree angle instead of going all the way, leaving a large area unwiped in front of the driver. Not only unrealistic but it makes the car really difficult to drive in rain since you have to take left-hand corners half blind20191030210608_1.thumb.jpg.142fd3d4e0a0e525e3e11c92cec69901.jpg

Here is a photo of the real car, you see they are level on the driver side.Porsche_911_SC_RS_001.jpg

  • What platform you're playing on: Steam
  • What your PC setup/build is like (graphics card, processor etc.).: 1230v3, GTX 1070, 16gb ram, SSD, Sound Blaster Z, Windows 10     
  • Whether you're a Standard or Deluxe user (doesn't apply to Oculus). : Super Deluxe   
  • Whether or not you have any non-standard peripherals connected, like steering wheels, gaming mice etc. : G920 steering wheel+shifter
  • Like 5

Share this post


Link to post
Share on other sites

Renault 5 Turbo has the wrong gearbox. GUI says it is manual but it is erroneously sequential when you drive it. This was reported in the two earlier bug report threads, probably before that too, and still not fixed.

  • What platform you're playing on: Steam
  • What your PC setup/build is like (graphics card, processor etc.).: 1230v3, GTX 1070, 16gb ram, SSD, Sound Blaster Z, Windows 10     
  • Whether you're a Standard or Deluxe user (doesn't apply to Oculus). : Super Deluxe   
  • Whether or not you have any non-standard peripherals connected, like steering wheels, gaming mice etc. : G920 steering wheel+shifter
  • Like 5
  • Thanks 1
  • Agree 1

Share this post


Link to post
Share on other sites

When using the lowest FOV, in Lancia Stratos the cockpit view clips through the rollcage. The default position is too much forward (same problem with a few other cars as well, such as Porsche 911 SC RS) and you can't move it backwards. Why can't you move the view backwards from the default position?

20191030210506_1.thumb.jpg.d732ff4bf6f8351e9bf1de84fd9ed4c2.jpg

  • What platform you're playing on: Steam
  • What your PC setup/build is like (graphics card, processor etc.).: 1230v3, GTX 1070, 16gb ram, SSD, Sound Blaster Z, Windows 10     
  • Whether you're a Standard or Deluxe user (doesn't apply to Oculus). : Super Deluxe   
  • Whether or not you have any non-standard peripherals connected, like steering wheels, gaming mice etc. : G920 steering wheel+shifter
Edited by HoksuHoo
  • Like 2

Share this post


Link to post
Share on other sites

Steam

Windows 10 Home + i5-9600K + RTX 2070

Deluxe user

Fanatec CSW V2.5

 

In Time Trial mode, if you don't turn on your best time's ghost, you won't see the gap in any split times.

  • Like 2

Share this post


Link to post
Share on other sites

seconded - the split times vs your own personal best behavior has changed. I liked having my ghost turned off so I don't get distracted by it, but still being able to see the split comparisons to my own personal best. This no longer works, it just shows all green with a time that is my current stage time just like i am doing a stage for the first time, all the time. Not helpful at all.

  • Like 2

Share this post


Link to post
Share on other sites

Steam

Windows 10 Home + i5-9600K + RTX 2070

Deluxe user

Fanatec CSW V2.5

 

There are many wrong pacenotes in italian language (in Spain, in Greece and so on). Not bugs, in my opinion, but lack of checking. Sadly, I don't think you will check them now.

  • Agree 1

Share this post


Link to post
Share on other sites

Played Through: Steam, no VR

OS: Windows 7 64bit

CPU/GPU: i7-3770 / GTX 1070 GTX RoG Edition

Game Version: Deluxe Version, currently v1.10

Controls: Logitech Mouse and XBox360 Controller

 

I'm thinking this is a mismatch thing, but, I started a monthly rally (The Community Events Monthly Challenge, RWD H3 Class) and am currently in Monaro, Australia. I started this while in v1.9, and after the version 1.10 update, I get this message when trying to continue:

 

CONNECTION FAILED

Progressing to the main menu will result in you losing your progress

Error Code: 3d9d11debbaec10-cd3417a4-40-58

**Retry**

**GO TO MAIN MENU**

**BACK**

 

The strange thing is, it will let me load into that event, and even run shakedowns, however, when I try to go to the *START* option and begin the actual run, that is when I get the CONNECTION FAILED error message and code listed above. It has happened 100% of the time out of easily 15 to 20 tries. That includes attempted fixes like rebooting the PC, restarting Steam itself, and closing/reloading DR2.0.

 

Thanks in advance for your help! I hope I can get back to it soon!

 

EDIT: After trying the other races (a combination of Daily Challenges and Weekly Challenges, it would seem that the Monthy RWD H3event that was in progress is the only one affected. I would like to NOT lose the progress I've made, especially since I completely reset my account recently (my choice, no fault on your part), every credit counts!! LOL! Anyways, if the only way to fix this, is to retire from that event, I'll do that. A fix, however, would be MASSIVELY appreciated. Also, the reset I performed made me lose my 'My Team' M2 BMW for the first set of World Series qualifiers. I'm hoping that will re-appear in my garage soon, especially since I participated in round 2 of the qualifiers. And, if you wanted to be extra generous, I was a part of the launch day RaceNet issues where you were kind enough to offset those problems with some credits. Anyways, I'll give this a few days, and tackle the other challenges. Thanks again for the great game, and for any help you can provide!

 

Wishing you all smooth, clean runs! Thanks!

Edited by Nytefyre
Updated Info
  • Like 1

Share this post


Link to post
Share on other sites
12 hours ago, HoksuHoo said:

Renault 5 Turbo has the wrong gearbox. GUI says it is manual but it is erroneously sequential when you drive it. This was reported in the two earlier bug report threads, probably before that too, and still not fixed.

  • What platform you're playing on: Steam
  • What your PC setup/build is like (graphics card, processor etc.).: 1230v3, GTX 1070, 16gb ram, SSD, Sound Blaster Z, Windows 10     
  • Whether you're a Standard or Deluxe user (doesn't apply to Oculus). : Super Deluxe   
  • Whether or not you have any non-standard peripherals connected, like steering wheels, gaming mice etc. : G920 steering wheel+shifter

 

This ^  PS4 Deluxe owner.


Love the game guys, but please fix this. Low hanging fruits.

image.png.d402348ac77239b18a18c7820d862d07.png

Edited by MarcoMaas
ps4 and pic for attention :)

Share this post


Link to post
Share on other sites

What are the bugs to report if they are not taken into consideration? 8 months have passed and Italian notes in Spain are still wrong! My patience is ending. I paid for a complete and correct game, not full of errors that continue to be ignored. We are doing beta testers (for free) when you should be in control and check if the game is correct. Is this your way of dealing with customers and fans? Of course, by now stupid people like me have already paid ...

  • Like 1

Share this post


Link to post
Share on other sites
47 minutes ago, Deltone91 said:

8 months have passed and Italian notes in Spain are still wrong!

We made some updates to this specifically in Version 1.10; it's in the Patch Notes.

Are there still some that are incorrect?

  • Like 1

Share this post


Link to post
Share on other sites
15 hours ago, MattyH1812 said:
  • What platform you're playing on. 
  • - Steam, PC / Xbox
  • What your PC setup/build is like (if playing on Steam).
  • - i7, 16GB RAM, GTX 1650Ti 
  • Whether you're a Standard or Deluxe user.
  • - Deluxe
  • Whether or not you have any non-standard peripherals connected, like steering wheels, gaming mice etc.
  • - No

The new "Consolidation Finals" elimination setting in custom RX events needs a toggle on/off in event settings rather than just being on regardless in order to allow us to play the way we want to, simulating Euro RX seasons for example where consolidation finals are not used.

Pleeeeeaaase can an option be added? Words cannot describe how much I hate this setting. I know it's a little thing and I bring it up every time there's a new patch but I'm desperate 😂

Hi @MattyH1812 unfortunately this isn't something we will be doing at this point. We really appreciated your enthusiasm for this feature though. I just wanted to give you a heads up. Sorry about that dude.

  • Like 1
  • Thanks 1
  • Sad 1

Share this post


Link to post
Share on other sites

I found another annoying, frustration bug since 1.10 update:
The game doesn't pick up my custom user presets for the steeringwheel, always uses factory defaults. I have to re-start every stage if i want to use my presets, otherwise i don't remember which buttons i have to press for a function in any car... This was OK before this update
PC/Steam/Deluxe v1.10 - Logitech G27

G27_forget_settings_forever.thumb.jpg.d945b0ab91ba275d0b72722461c45238.jpg

Share this post


Link to post
Share on other sites
21 hours ago, mesa said:

Type 2 (Racenet Error😞
182375128_DirtRally2Screenshot2019_10.30-12_07_24.thumb.jpg.2bd97efd6819b5af612c5a18eb319f82.jpg
PC / Steam

 

 

11 hours ago, Nytefyre said:

Played Through: Steam, no VR

OS: Windows 7 64bit

CPU/GPU: i7-3770 / GTX 1070 GTX RoG Edition

Game Version: Deluxe Version, currently v1.10

Controls: Logitech Mouse and XBox360 Controller

 

I'm thinking this is a mismatch thing, but, I started a monthly rally (The Community Events Monthly Challenge, RWD H3 Class) and am currently in Monaro, Australia. I started this while in v1.9, and after the version 1.10 update, I get this message when trying to continue:

 

CONNECTION FAILED

Progressing to the main menu will result in you losing your progress

Error Code: 3d9d11debbaec10-cd3417a4-40-58

**Retry**

**GO TO MAIN MENU**

**BACK**

 

The strange thing is, it will let me load into that event, and even run shakedowns, however, when I try to go to the *START* option and begin the actual run, that is when I get the CONNECTION FAILED error message and code listed above. It has happened 100% of the time out of easily 15 to 20 tries. That includes attempted fixes like rebooting the PC, restarting Steam itself, and closing/reloading DR2.0.

 

Thanks in advance for your help! I hope I can get back to it soon!

 

EDIT: After trying the other races (a combination of Daily Challenges and Weekly Challenges, it would seem that the Monthy RWD H3event that was in progress is the only one affected. I would like to NOT lose the progress I've made, especially since I completely reset my account recently (my choice, no fault on your part), every credit counts!! LOL! Anyways, if the only way to fix this, is to retire from that event, I'll do that. A fix, however, would be MASSIVELY appreciated. Also, the reset I performed made me lose my 'My Team' M2 BMW for the first set of World Series qualifiers. I'm hoping that will re-appear in my garage soon, especially since I participated in round 2 of the qualifiers. And, if you wanted to be extra generous, I was a part of the launch day RaceNet issues where you were kind enough to offset those problems with some credits. Anyways, I'll give this a few days, and tackle the other challenges. Thanks again for the great game, and for any help you can provide!

 

Wishing you all smooth, clean runs! Thanks!

 

Hi all.

I've just been informed that Challenges started pre-1.10 should now be working post 1.10.

Have another go and ping me if anything comes up 🙂 

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×