Jump to content

1.10 and analog Handbrake

Recommended Posts

PJ Tierney, will the handbrake issue be fixed once and for all? Because with the last update, in practice, nothing has changed.

Edited by orangejuiced83
  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, orangejuiced83 said:

PJ Tierney, will the handbrake issue be fixed once and for all? Because with the last update, in practice, nothing has changed.

We are looking to tweak handbrake performance in 1.10, ensuring it works correctly in all game modes.

Patch notes aren't final yet but work has been done on the handbrake 👍🏻

  • Thanks 1
  • Agree 2
  • Disagree 1

Share this post


Link to post
Share on other sites

Is the DIRT RALLY 2.0‘s handbrake an analog or a button?The input reporting is button

Edited by KyoLee

Share this post


Link to post
Share on other sites

 

 

It's an analogue input. There's some updates coming to it in a few days.

Share this post


Link to post
Share on other sites
33 minutes ago, JKangSC said:

Still behaves as a button with 1.10 update. Anyone?

Have you reconfigured it?

 

 

Share this post


Link to post
Share on other sites
2 minutes ago, PJTierney said:

Have you reconfigured it?

Went to input settings, reassigned the handbrake, drove the Feista R5 in Dirtfish. Pulling the handbrake just around 10% locked up the rear wheel.

  • Agree 1

Share this post


Link to post
Share on other sites

Hi guys,

I still did not have the time to try the 1.10 myself unfortunately. Anybody has some feedback to give about it ? Did you guys try it yet ?

Thanks !

Edited by koog2003

Share this post


Link to post
Share on other sites

I’m not convinced it changed anything to be honest!! Input recording works perfectly and the game clearly sees the handbrake as a analog input but in theory it seems to apply the same braking force to the rear wheels in game whether your at 1% or 100% 

Share this post


Link to post
Share on other sites

Works fine for me 👍 You habe to recalibrate it first, then it works (I us  a Thrustmnaster Sparco)!! A long waiting is finished: Asuper analog-handbrake 😊 Thx!

  • Like 1

Share this post


Link to post
Share on other sites

Well it's definitely not digital and not a button anymore.  The changes are significant, but not perfect, here is what I wrote in Discord to clarify:

The HB is working better now, in the sense that;
- the input reporting slider seems accurate in showing what the game thinks is happening with the HB.
- Setting a saturation of 150% is now allowing the car to launch. And adding that extra 50% saturation does scale the input and thus the force of the HB in the simulation.
- So the analog range is improved by another 50%.

Certainly it's not perfect as you're still locking wheels in an R2 at around 45% of the range of the linear HB (tarmac, spain, softs, balanced car) . Would probably need more adjustment range (with another approach no doubt to scale the force)(edited)

Summary: It's much improved . Full range of adjustment - not yet


Set your saturation to 150%, deadzone to maybe 5% (your preference based on your hardware), and enjoy an analog HB up to about 50% (so I'd say it's half way there!)

Edited by bn880
  • Like 1
  • Thanks 1
  • Agree 1

Share this post


Link to post
Share on other sites

How do you calibrate the handbrake? I’m using the thrustmaster tss on Xbox one x!

Share this post


Link to post
Share on other sites

does anybody feels that sometimes the handbrake activates ramdonly during the stage?... now I have this strange feeling (sometimes the car looses the rear in a nosense way)

Share this post


Link to post
Share on other sites
48 minutes ago, grancab said:

does anybody feels that sometimes the handbrake activates ramdonly during the stage?... now I have this strange feeling (sometimes the car looses the rear in a nosense way)

I dont use a handbrake but try to add some deadzone to it

Share this post


Link to post
Share on other sites
1 hour ago, grancab said:

does anybody feels that sometimes the handbrake activates ramdonly during the stage?... now I have this strange feeling (sometimes the car looses the rear in a nosense way)

Any time the HB engages you hear strange clicking sound and a bit of  a higher pitched sound when on.  Set deadzone as the other user said.

Edited by bn880

Share this post


Link to post
Share on other sites

I’m still not convinced I’ve tried unbinding and reassigning the handbrake, calibrating the wheel, changing the handbrake saturation up to 150% and no matter what I do any input on the handbrake locks the rear wheels

  • Like 1
  • Sad 1

Share this post


Link to post
Share on other sites
1 minute ago, Evo8uk said:

I’m still not convinced I’ve tried unbinding and reassigning the handbrake, calibrating the wheel, changing the handbrake saturation up to 150% and no matter what I do any input on the handbrake locks the rear wheels

Which car and which location?  I will give it a shot later today.

Share this post


Link to post
Share on other sites

In dirt rally the handbrake works perfectly, I can't understand that. Has the development team changed over the years?

Edited by orangejuiced83

Share this post


Link to post
Share on other sites
1 hour ago, orangejuiced83 said:

In dirt rally the handbrake works perfectly, I can't understand that. Has the development team changed over the years?

AFAIKThere was a big simulation model change and input code change, and the result is this.  But anyway, it's not bad now, in my tests so far.

  • Like 1

Share this post


Link to post
Share on other sites
4 hours ago, bn880 said:

AFAIKThere was a big simulation model change and input code change, and the result is this.  But anyway, it's not bad now, in my tests so far.

Ok, I understand but, it's hard for me to think that expert programmers are not able to work on code now. Anyway, tomorrow, probably, I'll have a chance to try it and I hope that, as you said, this time there has been a tangible improvement compared to the 1.09 patch. However, it would be appreciable if they worked on it a little longer and gave us back a fully functional peripheral.

Share this post


Link to post
Share on other sites
9 hours ago, bn880 said:

Which car and which location?  I will give it a shot later today.

It was on the dirt fish free Roam in dry conditions with the R2 fiesta and also the 1995 Impreza.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×