Jump to content
Want to report an issue? Have a bug to report? Please look here first!!!! Read more... ×
Sign in to follow this  

Game can't be played

Recommended Posts

Hi,

WIndows 10, 3770K, 16GB Memory, AMD Fury X

I did the apparently stupid mistake of changing the graphics option from "Fullscreen" to "Windowed", I have not been able to play the game since,

If I start the game in DX12 the game is prompted "Running" in Steam for 10 seconds, before nothing happening.

If I start the game in DX11 the game launches and after the Lewis&Vettel screen is goes dark. But the game is running I can hear the sound and that I am operating the menu.

So I have tried the following: Validate game files, reinstalled the game and DDU/reinstalled GPU drivers.

Setting "-fullscreen" command under Steam launch option. The game stii luanches in window mode.

Any ideas how to force the game back into Fullscreen mode? If anybody could share a video showing the steps from main menu to video options so I could try changing this blind?

 

 

Share this post


Link to post
Share on other sites

Hey!

You can just change the hardware_settings_config.xml that can be found from Documents\"My Games"\"F1 2019"\hardwaresettings\

image.png.7d153efb43089464336de546db917015.png

Try to change the displayMode to 1, as I believe that would be toggling on Exclusive Fullscreen.

Hopefully this helps 🙂 If it doesn't, get back to me and I'll take another look.

Share this post


Link to post
Share on other sites
1 hour ago, UP100 said:

Hey!

You can just change the hardware_settings_config.xml that can be found from Documents\"My Games"\"F1 2019"\hardwaresettings\

image.png.7d153efb43089464336de546db917015.png

Try to change the displayMode to 1, as I believe that would be toggling on Exclusive Fullscreen.

Hopefully this helps 🙂 If it doesn't, get back to me and I'll take another look.

Hi @UP100

Tried it now. The same thing happens, seems like the game writing these settings when launching. 

When I open the file after the game has launched, the value is 2 again:

<hardware_settings_config applyOOTB="false">
    <cpu name="Intel(R) Core(TM) i7-3770K CPU @ 3.50GHz" processors="8" processorStride="1" processorBinding="1" />
    <graphics_card deviceId="0x0162" rating="0">
        <resolution width="1920" height="1080" displayMode="2" vsync="false" vsyncInterval="auto" frameRateLimiterEnabled="true" frameRateLimiterValue="75">
            <refreshRate numerator="0" denominator="0" />
            <windowPosition x="0" y="0" />
            <outputMonitor index="1" />
            <aspectRatio auto="true" width="0" height="0" />
            <hdr mode="0" peakNits="1000" />
        </resolution>

Share this post


Link to post
Share on other sites
1 minute ago, matses51 said:

Hi @UP100

Tried it now. The same thing happens, seems like the game writing these settings when launching. 

When I open the file after the game has launched, the value is 2 again:

<hardware_settings_config applyOOTB="false">
    <cpu name="Intel(R) Core(TM) i7-3770K CPU @ 3.50GHz" processors="8" processorStride="1" processorBinding="1" />
    <graphics_card deviceId="0x0162" rating="0">
        <resolution width="1920" height="1080" displayMode="2" vsync="false" vsyncInterval="auto" frameRateLimiterEnabled="true" frameRateLimiterValue="75">
            <refreshRate numerator="0" denominator="0" />
            <windowPosition x="0" y="0" />
            <outputMonitor index="1" />
            <aspectRatio auto="true" width="0" height="0" />
            <hdr mode="0" peakNits="1000" />
        </resolution>

If the game is overwriting the settings, you could try setting the file to read only mode through the properties window. It could also be that the hardware_settings is broken in some way, so renaming the current one and starting the game will generate a new hardware settings file that you could then try to modify.

I personally have had issues with the game's hardware settings files as the game doesn't want to launch with a newly generated file, so I'd advise to backing up the original by just renaming it to something else.

I'll try to take a look at the hardware settings files when I've reinstalled the game 🙂 

Share this post


Link to post
Share on other sites

Update,

Also tried making the file read only, but to no luck. Although the value stays at  "1" the game is running windowed since i can move my cursor between the screens.

Share this post


Link to post
Share on other sites

Have you tried pressing ALT+TAB while the game is running? This changes from window to fullscreen in other Codemasters titles.

Edited by UP100
Checked hardwaresettings stuff, didn't found much :/

Share this post


Link to post
Share on other sites

Hi @UP100

Removing the setting files seems to have worked.

I cut them to desktop and the game booted on DX12 fullscreen and I was able to get to menu,

I don't have time to try and play now, but will try tonight.

Thanks for the assist so far

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×