Jump to content

Discussion Thread for Patch Notes for 1.18

Recommended Posts

Hi everyone and welcome to the Patch 1.15 discussion thread.

Patch 1.18 is out now on all platforms. You can find the full patch notes here.

If something from this patch is not working the way it should, let us know in this thread. 

Please post any other issues and bug reports not related to this patch in the Technical Assistance forums here.

Be aware that any posts that do not relate to the patch will be removed and added to the Patch Off Topic Thread. Feel free to discuss anything not pertaining to the patch about the game there. 

Thanks all!

  • Like 2

Share this post


Link to post
Share on other sites

can NOT launch the game with DX12 after patching 1.18.

F1 2019 Executable has stop working.

Share this post


Link to post
Share on other sites
2 minutes ago, wenjunyang1990 said:

can NOT launch the game with DX12 after patching 1.18.

F1 2019 Executable has stop working.

Hi @wenjunyang1990,

Can you try launching through Steam if you aren't already to see if that works.

Share this post


Link to post
Share on other sites
10 minutes ago, BarryBL said:

Hi @wenjunyang1990,

Can you try launching through Steam if you aren't already to see if that works.

hi @BarryBL

i've tried everything, restarted steam, re-downloaded the game and Nothing change.

Share this post


Link to post
Share on other sites

Hi there,

Wondering if there were any changes which should make my car now drive like a boat? Went from being consistently top 6-8 in races on 90 difficulty to being dead last on 85 last race I tested. My McLaren is roughly equal 3rd best with several teams in season 2 on PC (25% races); using the driving force GT wheel with ABS and full traction control.

All of my settings appear to be rolled over, so no issue there but the biggest difference I've noticed is all of a sudden I'm not able to turn the car into corners using setups which have always worked. Not an issue if an increase in difficulty was intentional to give better players more of a challenge, it's the first patch I've actually noticed changes, but can't see where in the patch notes it would be due to.

 

Regards,

Pat.

Share this post


Link to post
Share on other sites
17 minutes ago, Formulaoneteam said:

SC ???? W T F

Yeah this is Ridiculous. We have been promised to fix it since August. Until this is fixed all other patches are useless

Edited by Geboy91
  • Agree 3

Share this post


Link to post
Share on other sites
1 hour ago, wenjunyang1990 said:

hi @BarryBL

i've tried everything, restarted steam, re-downloaded the game and Nothing change.

Hi @wenjunyang1990,

Did this work in DirectX12 before? Could you try running the game in DirectX11?

Share this post


Link to post
Share on other sites

something wierd, after the patch if I alt-tab out of the game the force feedback from my wheel stops working (g27), I need to unplug/plug for it to start working again. Never happened before and I alt-tabed all the time in long races if I need to check on something

Share this post


Link to post
Share on other sites
49 minutes ago, BarryBL said:

Hi @wenjunyang1990,

Did this work in DirectX12 before? Could you try running the game in DirectX11?

DX11 is OK but DX12 isn't.

Share this post


Link to post
Share on other sites
2 minutes ago, wenjunyang1990 said:

DX11 is OK but DX12 isn't.

Hi @wenjunyang1990,

Could you send in a DXDiag when possible and we can try and diagnose the problem for you. Also try some suggestions here (this should also have a how to guide on creating a DXDiag file too) 

 

Share this post


Link to post
Share on other sites
13 minutes ago, Erudain said:

something wierd, after the patch if I alt-tab out of the game the force feedback from my wheel stops working (g27), I need to unplug/plug for it to start working again. Never happened before and I alt-tabed all the time in long races if I need to check on something

Hi @Erudain,

New one to us. Could you add a little more detail and I'll get this to the Development team for you. What I need is:

A short description of the problem:

Platform you’re on (PS4, Xbox One, PC, Steam):

Game Version (Shown on the Start screen in the bottom left hand corner):

Game Mode, including if it was Single Player or Multiplayer (Time Trial, Career, Grand Prix, Custom Game etc):

If in Multiplayer, how many players and how many AI?

What happened in the lead up to the problem?

If you get an error message, the exact wording of the error message you're receiving:

Any accessories you are using (wheel, pad, etc):

If you have any videos or screenshots, please share them. If the video is long, please include a timestamp for when the issue appears:

 

Share this post


Link to post
Share on other sites
43 minutes ago, BarryBL said:

Hi @Erudain,

New one to us. Could you add a little more detail and I'll get this to the Development team for you. What I need is:

A short description of the problem:

Platform you’re on (PS4, Xbox One, PC, Steam):

Game Version (Shown on the Start screen in the bottom left hand corner):

Game Mode, including if it was Single Player or Multiplayer (Time Trial, Career, Grand Prix, Custom Game etc):

If in Multiplayer, how many players and how many AI?

What happened in the lead up to the problem?

If you get an error message, the exact wording of the error message you're receiving:

Any accessories you are using (wheel, pad, etc):

If you have any videos or screenshots, please share them. If the video is long, please include a timestamp for when the issue appears:

 

PC Steam Win10 using DX12 ver.

Ver. 1.18

Career mode

Wheel Logitech G27

what happened? 1.18 update installed and now if I alt-tab out of the game I'm losing force feedback when I go back to the game. Never happened before. If I unplug and re plug the wheel it fixes, but if I alt-tab again the same thing happens, I lose force feedback and have to unplug again.

 

Edited by Erudain

Share this post


Link to post
Share on other sites
1 minute ago, Erudain said:

PC Steam

Ver. 1.18

Career mode

Wheel Logitech G27

what happened? 1.18 update installed and now if I alt-tab out of the game I'm losing force feedback when I go back to the game. Never happened before. If I unplug and re plug the wheel it fixes, but if I alt-tab again the same thing happens, I lose force feedback and have to unplug again.

 

Thanks for the information @Erudain,

Please check online and ensure you have the latest firmware for this wheel before we investigate this for you. Also, are you running in full/windowed viewing mode for the game?

Share this post


Link to post
Share on other sites
4 minutes ago, BarryBL said:

Thanks for the information @Erudain,

Please check online and ensure you have the latest firmware for this wheel before we investigate this for you. Also, are you running in full/windowed viewing mode for the game?

Yes it has the latest drivers/firmware...there hasn't been a new driver for the G27 for like 8 years. Running the game in fullscreen

Share this post


Link to post
Share on other sites

Thanks @Erudain

I'll pass this over to the development team and let you know once I have any feedback for you.

Share this post


Link to post
Share on other sites
5 hours ago, JuanCarMR said:

hi @BarryBL

Will you fix SC in a future patch?

Thank you for answering me.

See? Here it goes again.

@BarryBL constantly replies on the other dx12 and g27 questions, but 2 questions with 1 with him tagged in it just....

 

gets....

 

no...

 

reply....

 

surprising. 
 

no response whatsoever, just simply avoiding.

Edited by AlexTT
  • Agree 4

Share this post


Link to post
Share on other sites

Lol I just noticed a minor error with the new e-mail you get with the grid penalty. The email comes from Carl but is signed by Jeff.....unless Carl got a schizophrenia attak after I crashed into Sainz

image.thumb.png.46b22355e687aa6f2457375ad34a781b.png

Edited by Erudain

Share this post


Link to post
Share on other sites

I'm getting the Abu Dhabi custom pack for sure! I love the colors of the car and racing suit. 

image.png

image.png

Edited by FOneFanatic
add pics
  • Haha 1
  • Agree 1

Share this post


Link to post
Share on other sites

So the two biggest issues with the game, safety car and badly balanced AI driver performances are still not sorted? Awesome. But hey, more very important custom liveries! 

 

Honestly, it's like you're purposely trying to annoy your playerbase. And it's working.

  • Agree 6

Share this post


Link to post
Share on other sites
1 minute ago, Liaveil said:

So the two biggest issues with the game, safety car and badly balanced AI driver performances are still not sorted? Awesome. But hey, more very important custom liveries! 

 

Honestly, it's like you're purposely trying to annoy your playerbase. And it's working.

And so we all think something else is the biggest issue with the game.

In my opinion the frequent crashes, stability issues, and desyncs in multiplayer are way more important to fix asap. 

Share this post


Link to post
Share on other sites
9 hours ago, BarryBL said:

Hi @wenjunyang1990,

Could you send in a DXDiag when possible and we can try and diagnose the problem for you. Also try some suggestions here (this should also have a how to guide on creating a DXDiag file too) 

 

Hi @BarryBL

It's ok now, thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×