Jump to content

Language problem

Recommended Posts

Hi,

i have bought a f1 2019 legendary edition, and i experienced a lot of problems. It seems to be a waste of money.

The installer is fully automatized and install only the english audio, but i'm italian. There is no way to install any other audio language, i don't want the english version of the game, i had paid for the italian version of the game. I try to install this game with the dvd, also with steam, but result is the same.

There are not compatibility problem, with the audio card, the english audio working perfectly, the italian audio files are missing, and every localised part of the game not work

There is a way to resolve this problem ? it seems to be not tested the game installation properly

 

IMG-20191125-WA0000.jpg

IMG-20191125-WA0001.jpg

IMG-20191125-WA0002.jpg

  • Agree 1

Share this post


Link to post
Share on other sites

Steam is in italian, my friend has f1 2018 in italian working good, with a steam installation. All the other games are in italian only this has problems

Share this post


Link to post
Share on other sites

Hi @Robby1982,

Try switching to English and then back to Italian, this could trigger a clean re-install of the language packs you need.

Share this post


Link to post
Share on other sites

@Robby1982

Possibly you're Steam is in Italian, but your game is in English. Please retry the steps: 

On the Steam menus, right click on the F1 2019 game and go to 'Properties'. In the top tab bar, go to 'Language' and then change to 'Italian'. This will download the Italian language pack for you. 

Does this trigger a download on your F1 2019 game? It should start a short download installing the language pack you need. We've tested this solution here and it works correctly.

Share this post


Link to post
Share on other sites

I posted the photo of the cover back, the game in fully italian.

This looks like a work around, not a real solution

Tried once more, nothing happened

Share this post


Link to post
Share on other sites

Are your menus in Italian? 

We've tried our methods here and our solution has worked correctly.

Try checking your settings in-game. Game Options>Settings>Audio Settings> Advanced Audio Settings 

Share this post


Link to post
Share on other sites

Installer menu was in italian, installation was in italian, in-game menu was in italian, audio only english.

This solution not working for me, i don't know why is so hard to understrand.

in advanced audio settings italian audio, mute, in english no problem with the sample audio. No more languages to try

 

Share this post


Link to post
Share on other sites

Hi Robby,

This is our recommended fix, and has been approved by other players. Please see here and here for other players experiencing your problem and the confirmed solutions.

If this still does not work, please confirm I will get this passed over for you for further investigation. It is just when we try to replicate your issue with the mentioned solution, it works every time for us. New Audio files will only be available via the Properties of the game (right clicking in steam)

Share this post


Link to post
Share on other sites

Good for him, but NOT STILL WORKING. No issues are displayed, no crush, simply nothing happens, italian aadio files still missing, no one package installation. i have no idea to explain better my situation and repeat the same word every time not helping me.

Share this post


Link to post
Share on other sites
On 11/25/2019 at 7:00 PM, Robby1982 said:

There is no way to install any other audio language, i don't want the english version of the game, i had paid for the italian version of the game.

The thing is that this makes me believe (like Barry), that you simply missed the change language option from Steam -> F1 2019 -> Right-click -> Propeties -> Language -> <Language>

The physical release has the same language options as the Steam one, at least in F1 2018 and GRID 2019 which are the two games I've tried 🙂 

  • Agree 1

Share this post


Link to post
Share on other sites
On 11/25/2019 at 10:30 PM, Robby1982 said:

Hi,

i have bought a f1 2019 legendary edition, and i experienced a lot of problems. It seems to be a waste of money.

The installer is fully automatized and install only the english audio, but i'm italian. There is no way to install any other audio language, i don't want the english version of the game, i had paid for the italian version of the game. I try to install this game with the dvd, also with steam, but result is the same.

There are not compatibility problem, with the audio card, the english audio working perfectly, the italian audio files are missing, and every localised part of the game not work MyColes

There is a way to resolve this problem ? it seems to be not tested the game installation properly

 

IMG-20191125-WA0000.jpg

IMG-20191125-WA0001.jpg

IMG-20191125-WA0002.jpg

I have also faced similar issue.

Edited by oldeini

Share this post


Link to post
Share on other sites

This is not a solution, but only a workaround. For me not working this "solution". Still not found any kind of solution, and i doubt i can find in a future, here i found only a totally waste of time and absolutely not respect. Sorry @oldeini, i can't help you

Share this post


Link to post
Share on other sites

Hi @Robby1982,

Have you tried uninstalling and re-installing the game? We've tested the solution here and it worked every time for us.

  • Disagree 1

Share this post


Link to post
Share on other sites

Just thinking have the posters got a regionalised Italian version of Windows 10 and this is why the language pack fixes are not working? (And also that the Italian users maybe have the English language packs installed as additionals)

It's possible because your test installations will be English (US) or English (UK), therefore your default audio packs will be different.

I agree the settings trigger is a workaround, there should be an installation option that overrides any other regional settings in W10.

@BarryBL @UP100 @Robby1982 @oldeini

Edited by steviejay69

Share this post


Link to post
Share on other sites
33 minutes ago, steviejay69 said:

Just thinking have the posters got a regionalised Italian version of Windows 10 and this is why the language pack fixes are not working? (And also that the Italian users maybe have the English language packs installed as additionals)

It's possible because your test installations will be English (US) or English (UK), therefore your default audio packs will be different.

I agree the settings trigger is a workaround, there should be an installation option that overrides any other regional settings in W10.

@BarryBL @UP100 @Robby1982 @oldeini

Downloading the language stuff is handled by Steam, so if the files do not exist, they haven't either picked the right language, or steam has forgotten to install them 😕 

For example here is what my audio/2019/speech folder looks like.

image.png.856d6266025933be6ef7c4eec803a4b2.png

This is because I've selected the Japanese localization through Steam, so Steam downloaded the additional Japanese localization files. The game should then automatically switch to Japanese speech, but it seems that in this report's case, it hasn't happened.

My workaround should work in those cases where the folder does look like this, but you just don't get the right speech files in-game.

  • Agree 1

Share this post


Link to post
Share on other sites
2 hours ago, UP100 said:

Downloading the language stuff is handled by Steam, so if the files do not exist, they haven't either picked the right language, or steam has forgotten to install them 😕 

For example here is what my audio/2019/speech folder looks like.

image.png.856d6266025933be6ef7c4eec803a4b2.png

This is because I've selected the Japanese localization through Steam, so Steam downloaded the additional Japanese localization files. The game should then automatically switch to Japanese speech, but it seems that in this report's case, it hasn't happened.

My workaround should work in those cases where the folder does look like this, but you just don't get the right speech files in-game.

Was more really thinking of WHY the workaround doesn't or can't be replicated.

We could do with 'Useful' as a reaction or 'Informative' although I have marked 'Agree'

Share this post


Link to post
Share on other sites

@UP100 windows 10 is fully italian, is an hp commercial with italian warranty, so i'm sure that is not english version, cracked and more...

There is not installed the english keyboard, or language pack.
The reinstallation do nothing always the same problem, only english. I try also the spanish, same result. Wasted another 2 hours, thanks a lot

 

Share this post


Link to post
Share on other sites
21 hours ago, Robby1982 said:

@UP100 windows 10 is fully italian, is an hp commercial with italian warranty, so i'm sure that is not english version, cracked and more...

There is not installed the english keyboard, or language pack.
The reinstallation do nothing always the same problem, only english. I try also the spanish, same result. Wasted another 2 hours, thanks a lot

 

You tagged the wrong guy 🙂 

@steviejay69 was talking about this stuff...

Share this post


Link to post
Share on other sites
1 hour ago, UP100 said:

You tagged the wrong guy 🙂 

@steviejay69 was talking about this stuff...

Still stand by the analysis. I think the Italian language is not working because the OS IS Italian. The workarounds you are trying work if the OS is English with Italian language and voice packs installed.

There have been language issues in many versions of Windows, not least Windows 10.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×