Jump to content
Want to report an issue? Have a bug to report? Please look here first!!!! Read more... ×

(1.18.1-1.18.2) Game keeps crashing after few minutes of playing

Recommended Posts

That should have been a dx12 attempt, yes.

I've tried again and that time i finished a one hour race, so at the very least there's a huge improvement compared to the situation before.

  • Thanks 1

Share this post


Link to post
Share on other sites

@steviejay69 ok so, we're not fully there yet, it's certainly loads better on the DCH driver, but it's still crashing every now and then, but now without a crash dump dialog.

Share this post


Link to post
Share on other sites
1 hour ago, incapable said:

@steviejay69 ok so, we're not fully there yet, it's certainly loads better on the DCH driver, but it's still crashing every now and then, but now without a crash dump dialog.

So it just crashes to desktop or locking up?

Share this post


Link to post
Share on other sites

Hi!
Sorry for late reply. But I found the reason!
If I connect the G29 and start F1, the game crashes after a few minutes. If the wheel is not connected and I bump over the track using the keyboard, there are no problems. Still, it's strange that this happens only after 1.18.1 update.

So, what's next? Of course, Logitech assumes that the problem caused by the game. So I can't expect any help from there.


Many thanks to all who helped finding the problem!

 

EDIT:

I've tried again without any changes und now it seems to work. 

Edited by EadZ1

Share this post


Link to post
Share on other sites

@steviejay69 Yes, it just plain crashes to desktop without warning, and no crash dialogs or anything. I'm having trouble coming through a single practice session. Just had another go and again, it crashed.

Share this post


Link to post
Share on other sites

Unfortunately, F1 crashes again and again. Whether with or without wheel doesn't matter.

Share this post


Link to post
Share on other sites

Usual recommendations, verify game files via Steam. 

Then, if you have the stomach (and depending on fast internet or fast storage) either uninstall the game and restore from backup or redownload.

This has the effect of redoing the first run executables.

I recommend a restart after uninstallation, then after first run (DX12) set any preferences in-game, quit without gameplay and restart.

Then play DX12.

Share this post


Link to post
Share on other sites

@steviejay69

I'll try to reinstall it from scratch, but I must ask at this point, is there any progress being made on identifying the issue and a possible fix? Because, as you've surely noticed, there's a striking similarity in hardware, even though I reinstalled windows a day (or something) before the update and others have not.

We've determined at least two of us are running the same motherboard, keyboard and steering wheel.

We've also determined were running GPUs from different manufacturers so it's unlikely to be the issue.

So it would either be something with that specific motherboard, corsair icue or Logitech g-hub that seems to cause a load of issues with the specific fixes in the patch.

That surely must be plenty to attempt to find the actual problem with the update?

Share this post


Link to post
Share on other sites

There is another issue with the other board that I've PMed about.

In previous fixes, I would recommend removing iCue and I never used G_HUB with Logitech peripherals I owned so I have no direct ability to test (I always used updated LGS and I use SetPoint to update my keyboard and then uninstall it). However, the software is providing a cooling function on your board and you advise it can't be removed. 

My initial advice was to remove it. 

Only CM know if there is any progress being made on this, there are no accurate patch notes and the decision to roll out what they are calling a hotfix as a mandated patch is a very poor one.

There was the beta branch option available so if they had chosen that, you could both provide direct feedback as to whether the 1.18.1 patch is the cause of your issue.

Due to their typical communications issues, I'm afraid I'm all you have and I'm not affiliated to CM in any way, but I do have a track record of solving issues on the forum for more than a few users.

  • Thanks 1
  • Agree 1

Share this post


Link to post
Share on other sites

@steviejay69

Ah I see, that's where I got confused a bit, your not affiliated with CM and I assumed you were, in that case, yeez man you're awesome for trying to help us out this much!

But yes, icue is critical for my current setup, and lgs is used for my mouse and steering wheel, but I guess lgs could be tried, do I'll give that a shot. But the nature of the crashes really make me think they did something very wonky in the graphics engine.

  • Agree 1

Share this post


Link to post
Share on other sites

Hello, 

I have same issue after the setup of patch 1.18.1. When I try open F1 2019 with Steam, the EXE crash directly and EGO dumper will open.

It's able to start a rollback for remove 1.18.1 patch ? Thanks. 

Share this post


Link to post
Share on other sites
13 hours ago, jeremb01 said:

Hello, 

I have same issue after the setup of patch 1.18.1. When I try open F1 2019 with Steam, the EXE crash directly and EGO dumper will open.

It's able to start a rollback for remove 1.18.1 patch ? Thanks. 

No, it's not. Unless CM do it.

Share this post


Link to post
Share on other sites

Hi everyone,

Can you try with the latest hotfix, 1.18.2 and let me know if it has improved?

 

 

Share this post


Link to post
Share on other sites

I loaded up AUS benchmark then BAH benchmark, no crashes, no noticeable frame drops so it hasn't broken anything for me AFAIK. Not a scientific test, but it's all I can be arsed to do.

Share this post


Link to post
Share on other sites

Hi @incapable,

Thanks for the post.

This is still with the new 1.18.2 hotfix correct? Has this happened often since the new hotfix? Did you send a crash dump report?

 

 

Share this post


Link to post
Share on other sites

@BarryBL Yes that is with the 1.18.2 hotfix.
I've tried it once or twice a day since the update, and it's happened most of the time, i think i've made it through 1 entire race.
I've only sent one crash dump report as the dump reporter dialog simply only appeared once, most crashes were straight to the desktop without it ever showing up.

Share this post


Link to post
Share on other sites

Hi,

nothing much to add...here's the rig

Thrustmaster t500

I7 5800K  - 32 GB RAM

2080Ti (no OC)

Latest drivers from Nvidia 442.41 (tried to roll back but nothing change)

tried both DX 11 and 12

Simply game random crash after a bunch of minutes of any game mode...it freeze for a couple of second (audio too) then crash to desktop. I've attached the log I got...no way to see a crashdump in the steam dir...last one was from 8th December, but the game just crashed again a few minutes ago...

EDIT: anoter crash

 

crash.txt

crash2.txt

Edited by Alastre

Share this post


Link to post
Share on other sites

Hey @Alastre, I've merged your thread to an older thread that seems to be currently about the same kinds of issues 🙂 If you think there is something you're not experiencing, I can split this to a new bug report.

I believe you didn't include the crash dump with your attachments, so please see "How to find crash dump" from this thread, if you want to include a crash dump.

 

Share this post


Link to post
Share on other sites

@UP100

 

Thank you, I've haven't attached dump coz as I wrote, there's no "fresh" dump after last patch.. Game crashes and all I got are the log files I've attached.. It doesn't create any crash dump file anymore 

  • Like 1

Share this post


Link to post
Share on other sites

I did get a game minimized from fullscreen (lost focus) during the first benchmark run on Adrenaline 2020 (19.12.2) posted elsewhere.

As my post above, very rudimentary testing revealed it wasn't 1.18.2 that caused this but the driver update itself.

I went DDU to remove the old 19.9.2 driver without trying in-place upgrade and it failed in the first attempt. I used the AMD Registry Cleaner to 'fix' the installation and the driver installed the second time, but it was after that the game minimization occurred. (I was probably using quite an old DDU (18.0.2.0), I will rewind the system and try again with an in-place.)

Update: With the in-place, everything was fine. BM same, no installer issues (Dec 12 release of 19.12.2 there was a Dec 10), no game issues.

Edited by steviejay69
DDU was up to date but 18.0.2.1 is now released

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×