Jump to content

DiRT Rally 2.0 - Version 1.11 Bug Reports

Recommended Posts

The livery of Larsson is not completly correct. I don't know exactly how it is called, "boot lid"? The underside has a carbon texture. But in game it is blue. 

image.thumb.png.712fe66bc88440ecdcd55405272b2855.png

Share this post


Link to post
Share on other sites

• PC, Steam user.
• Windows 7 professional 64 bit, Intel Core i5-3450 3.10 GHz, 12 GB RAM, Nvidia GeForce GTX 1060 3GB.
• Deluxe user.
• OSW Simucube (steering wheel), Xin-Mo Controller (Shifter), BU0836-LC Interface (Pedals), BU0836A Interface (Handbrake).

Bug: Ford Fiesta RXS Evo 5 (RX 2019) wipers.

197955027_FiestaRXSEvo5wiper.thumb.jpg.48be12ca77d92356c56ae8149c728491.jpg

Edited by Deltone91

Share this post


Link to post
Share on other sites
15 minutes ago, Deltone91 said:

Bug: Ford Fiesta RXS Evo 5 (RX 2019) wipers.

197955027_FiestaRXSEvo5wiper.thumb.jpg.48be12ca77d92356c56ae8149c728491.jpg

That is no bug. In real life it only has one
5L3A2399.jpg

  • Agree 1

Share this post


Link to post
Share on other sites

Had a bit of a weird one doing the AI Monthly last night.

I'd done 2 stages on Tuesday and was 25 seconds up on 2nd with about 7 mins of driving done.

When I continued last night i finished about 7th on SS3 with a time of 4.20 but when I went to the overall time screen it had me in 7th overall with a time of 44m 20s.

It looked like it had taken the SS3 times and added about 40 mins on to everyone's stage time to get the overall time thus completely deleting the actual times for SS1 and SS2....

It didn't make much difference as I won the event anyway but I would hate for this to happen to someone who has completed all but 1 stage and then it resets it all when they come to do the last stage!!

 

 

 

  • Like 3

Share this post


Link to post
Share on other sites

hello. ive been having a bit of sound trouble since the 1.11 update. It is the sound cutting out bug. i never had this issue until this latest update.  Its happened to me 3 times in the past day or so, and its only done it for the engine sounds of the BMW E30 each time. i have a good headset, and i can just barely hear the engine sounds, like the volume is at 1 or 2, not at full volume like 100. i can hear the revs, the shifts, all of it, so its not missing, but it get buried under my co-driver calls, road/track noise, etc. the game is providing the calls and environmental sound effects just as they should be, no issues there. the odd part is that it will be just fine on some runs, then go back to being almost silent.

all other cars up til this point have been working and sounding fine.

i play through Steam on my PC.

thanks in advance for any help/info/fix you can do to hopefully straighten this out.

have a good 1!

-Nytefyre

Share this post


Link to post
Share on other sites

In singleplayer rallycross qualifying there is often a really severe inconsistency between the AI drivers you race against and the randomized times from the other qualifiers. I beat the AI drivers in my heat only to finish 16th because somehow the random AI times are 10-20 seconds faster than the AI drivers I race against, when they should be around the same level. This can happen on any RX track

Here the fastest AI driver is 2:48 while the randomized times are 2:30, which is world record pace on every lap despite this being only elite level. Shows how terribly off the randomized times are

20191219194240_1.thumb.jpg.4da6e9f402b81850b53f40505edd8329.jpg20191219194302_1.thumb.jpg.631364d62e9cca39628279c149bc0309.jpg

 

 

Edited by HoksuHoo
  • Like 3

Share this post


Link to post
Share on other sites
On 12/18/2019 at 4:47 AM, HoksuHoo said:

This just keeps happening. Just crashed twice in the same career rally event.

sdfsd.png.93b1003d0924b8bc7a883e34b78b8539.png

It only happens in online related modes, not in freeplay. Usually after completing a stage when uploading stage time, but has happened elsewhere too. Has happened in career menu, and in test drive.

My game is not modified in any way, and I have all DLC enabled. Have tried verifying files on Steam and reinstalling but that doesn't fix the problem. Have sent what must be damn near 20 error reports by now.

And the FAQ link still doesn't work.

  • What platform you're playing on (for PC also state Steam, Microsoft or Oculus): Steam   
  • What your PC setup/build is like (graphics card, processor etc.): 1230v3, GTX 1070, 16gb ram, SSD, Windows 10, SB Z
  • If you're playing on PC, state whether you're in 2D or VR: 2D. 2560x1440 resolution
  • Whether or not you have any non-standard peripherals connected, like steering wheels, gaming mice etc: Logitech G920 steering wheel+shifter

 

I have sent 100's of these since february 2019. I'm sure the report is just ending up in a place where

Codies never check, or is read by people who have no clue what they are looking at. However, there

is a solution that can help you reduce how often they will appear though: 

 

The game is loaded with bad code, and one of the places is after a stage, when you choose Replay, you

get the confirmation screen that say "YES/NO". 

 

This screen will try to fry your GPU with bad code, and is therefore excellent to use to get a stable clock

on your GFX card. Use Afterburner (or your preferred monitoring GFX soft), and look at the temp going up 

while in that screen (YES/NO). Wait until the game crashes, and take note of what the temp was. This may

take a few minutes depending on how close you are to the limit. (There is a chance you already have low

enough clock, and that you are experiencing an unrelated BUG, but I highly doubt it).

 

Lower your clock/voltage on the GPU, (maybe also back off a bit on the RAM). Make sure you set so low

clock that you can stay in the YES/NO-screen for 5 minutes without having the game crash.

 

Now, work your way up by checking with the temp and make it close to where the game crashed during your

first test, and leave it there. This should reduce how often you get those crashes.  

 

Cheers :

 

TO CODEMASTERS:

Don't go ahead and fix this screen now!. You need to fix all the other bad code first! 

This screen is the only good tool we have to get a somewhat stable game.

 

 

 

  • Like 2

Share this post


Link to post
Share on other sites

DR2 - BUG - Personal Best time is wrong. 

After crashing out in Jezioro Lukie, the game registered the time as my PB time, and 

all Split Times got messed up, leaving last sector as done in 13 seconds. Luckily it did 

not register on the Leaderboard, but further improvement of my setup and time is now

very difficult as I am racing against slow 3 first sectors, and an impossible 4th sector.

 

I want to know how I can get the PB deleted for this stage. 

 

Below is 2 videos. The first is showing the wrong PB time (skip to end of video). 

The second is showing the Ghost when the BUG was triggered. There is a timer in the top

left corner. The Ghost disappears pretty much on the time 2:28.077, which is the wrongly

registered PB time. 

 

 

 

 

 

Specs in my signature

Edited by Eagleizer
Added info about specs

Share this post


Link to post
Share on other sites

UDP Telemetry does not send a reset message in the following transition: [Driving in Free roam (DirtFish)] -> [Return to Service Area]

If 3rd-party hardware/software relies on this reset message, it will be stuck on the last active car state while player sits in the service area.

"hardware_settings_config.xml" <udp enabled="true" extradata="3" ip="127.0.0.1" port="20777" delay="1" />

Share this post


Link to post
Share on other sites

• PC, Steam user.
• Windows 7 professional 64 bit, Intel Core i5-3450 3.10 GHz, 12 GB RAM, Nvidia GeForce GTX 1060 3GB.
• Deluxe user.
• OSW Simucube (steering wheel), Xin-Mo Controller (Shifter), BU0836-LC Interface (Pedals), BU0836A Interface (Handbrake).

Bug: Wrong note with Italian co-driver

NEW ENGLAND RALLY (USA), (Fury Lake Depart - North Fork Pass Reverse)

446383431_NEWENGLAND(FuryLakeDepart-NorthForkPassReverse).thumb.jpg.03c89ba93d412a057612c5cc2aea5fea.jpg

Share this post


Link to post
Share on other sites

Version 1.11.1 - Steam - Super Deluxe Edition

Living the Dream and Watch the DELTA Steam achievements do not count the progress properly and are unreachable.

Achievments_bug.jpg

  • Agree 1

Share this post


Link to post
Share on other sites

As per another thread:

On 12/15/2019 at 8:46 PM, Tigron said:

Version 1.11.1 - Steam - Super Deluxe Edition

Subaru WRX STI Rallycross has problem with window texture next to left mirror (look in the red circle on screenshots). It does not become dirty or wet. It is repetitive and especially visible in heavy rain.

 Dirt Rally 2 Screenshot 2019.12.14 - 16.24.44.08.jpg

Dirt Rally 2 Screenshot 2019.12.14 - 16.06.08.01.jpg

Share this post


Link to post
Share on other sites

Version 1.11.1 - Steam - Super Deluxe Edition

In daily awards screen results show wrong stage picture. In fact they are messed up. See in red circle on the screenshots.

Dirt Rally 2 Screenshot 2019.12.21 - 12.22.17.57.jpg

Dirt Rally 2 Screenshot 2019.12.21 - 12.22.27.06.jpg

  • Like 2

Share this post


Link to post
Share on other sites

• PC, Steam user.
• Windows 7 professional 64 bit, Intel Core i5-3450 3.10 GHz, 12 GB RAM, Nvidia GeForce GTX 1060 3GB.
• Deluxe user.
• OSW Simucube (steering wheel), Xin-Mo Controller (Shifter), BU0836-LC Interface (Pedals), BU0836A Interface (Handbrake).

Bug: Killarney (South Africa) Rallycross AI times

Career mode, Master difficulty, in every qualification I manage to finish 1st, but all other AI opponents make decidedly shorter times, only when they aren't running in my battery!

3115431_KillarneyIAtimes(1).thumb.jpg.d6a829dcda013d4ac3c1a4d91abc1575.jpg

2044091115_KillarneyIAtimes(2).thumb.jpg.09b61b90f8dd1427a93c573b18b9c9aa.jpg

  • Like 2

Share this post


Link to post
Share on other sites

• PC, Steam user.
• Windows 7 professional 64 bit, Intel Core i5-3450 3.10 GHz, 12 GB RAM, Nvidia GeForce GTX 1060 3GB.
• Deluxe user.
• OSW Simucube (steering wheel), Xin-Mo Controller (Shifter), BU0836-LC Interface (Pedals), BU0836A Interface (Handbrake).

Bug: Estering Rallycross Joker lap

Happens again that sometimes the Joker lap is not counted, and therefore are forced to do so 2 times to have no penalty.

Share this post


Link to post
Share on other sites
9 hours ago, Deltone91 said:

Career mode, Master difficulty, in every qualification I manage to finish 1st, but all other AI opponents make decidedly shorter times, only when they aren't running in my battery!

It may be a feature. Championship is won by total points. In qualifiers you get points not by place you get, but by total time of the stage. So make sure to have a very clear and fast run in qualifiers. Though eventually you will have to overtake everybody to get the best stage time. In Semi-finals and finals you get points by the place. There is a clear disclaimer about it before each race.

In this week AI Challenge I had 7th position by points after qualifiers. Then I managed to be 1st in semi-finals and finals. That made me 1st in the championship. Though 2nd and 3rd place got exactly the same amount of points total. No winner situation. 🤪

5 hours ago, Deltone91 said:

Happens again that sometimes the Joker lap is not counted, and therefore are forced to do so 2 times to have no penalty.

Make sure you did not jump the start or did not do some bad cuts during the lap. The penalty may be double joker lap or invalid joker lap. So you will have to take another joker lap.

Edited by Tigron
  • Disagree 2

Share this post


Link to post
Share on other sites
51 minutes ago, Tigron said:

It may be a feature.

The random times from the other qualifiers can be 20 seconds faster than the AI drivers in your qualifier. That is not a "feature", it just means the randomized times are way off the mark. They should be around the same level as the drivers you race against but all too often they are not even close. Stop lecturing about rallycross rudiments when you don't understand what the issue even is

  • Agree 1

Share this post


Link to post
Share on other sites
On 12/17/2019 at 1:28 PM, somethingthing said:

The rendering distance on trees and grass could need some improvement, it pops up in the view. Add a extra (higher) setting? Easy to spot on Poland and USA. Watch the clip i uploaded in the previous thread.

I'm noticing this too in VR on Rift S. Trees seem to change color and shape when about 30 meters away. Its jarring when it happens. Tried on Ultra settings with no change.

The trees also sometimes have 'ghost' limbs that look like a bunch of dots in a grid-like pattern. Especially noticeable in Poland.

Share this post


Link to post
Share on other sites

The HDR effect making scenes too dark or too bright is still an issue in v1.11
It is especially bad in cloudy or shady areas. The scene becomes almost pitch black.
Using Oculus store version of the game on Rift S.
System: Windows 10, i7 9700K, RTX 2080, 16gb RAM

 

Share this post


Link to post
Share on other sites

Under VR (Samsung Odyssey+), I am not able to lean in any direction. The head position is fixed (although I can look around). I can move my seat location with the numpad, but when I lean forward, I do not move forward in my seat position. 

PC, Steam, Deluxe Version
Windows 10
Samsung Odyssey+
i7-8770k
32GB DDR4
1080ti
G27 Controls

Share this post


Link to post
Share on other sites

I have again some issues with the rain, this was in a club event. It was fixed by restarting the game.

Location: Wales

Car: Citroën C4 

Console: PS4 Pro

 

IMG_4523.JPG

  • Like 1

Share this post


Link to post
Share on other sites

• PC, Steam user.
• Windows 7 professional 64 bit, Intel Core i5-3450 3.10 GHz, 12 GB RAM, Nvidia GeForce GTX 1060 3GB.
• Deluxe user.
• OSW Simucube (steering wheel), Xin-Mo Controller (Shifter), BU0836-LC Interface (Pedals), BU0836A Interface (Handbrake).

Bug: Yas Marina (Abu Dhabi) Rallycross AI times

Career mode, Elite difficulty, when AI players run in my own battery, they always do shorter times than other batteries. This also happens at Master level. Please investigate.. Thank's!

999597756_YasMarinaIATimes.thumb.jpg.7c949ee89668aea5feaebd48463c8f3f.jpg

  • Like 2

Share this post


Link to post
Share on other sites

• PC, Steam user.
• Windows 7 professional 64 bit, Intel Core i5-3450 3.10 GHz, 12 GB RAM, Nvidia GeForce GTX 1060 3GB.
• Deluxe user.
• OSW Simucube (steering wheel), Xin-Mo Controller (Shifter), BU0836-LC Interface (Pedals), BU0836A Interface (Handbrake).

Bug: car body damage

Already Reported!

Career Rallycross, Elite Level, before starting the event, the car had no damage. As you can see from image, there are no reported damages to be repaired, but the car has a damage body!

868032624_Carbodydamage.thumb.jpg.a80111cb12b2a2a7a8485e8549144adc.jpg

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×