Jump to content

[PC][AUDIO] "Voice Control Disabled" - F1 won't use my mic

Recommended Posts

I don't know what happened, but I get the "Voice Control Disabled" prompt whenever I boot up the game now. What's really weird - it worked flawlessly 3 days ago before I reinstalled Windows 10.

Reinstalled W10, decided to upgrade to W10 Pro this time from an EDU license. Install went fine, updated all my usual drivers for Nvidia and audio drivers for the Mobo. Zero issues outside of F1, voice works great in Steam Chat, Discord, Skype, basically everything else.

  • So far I've tried the "reinstall kinect voice recognition" and all those installer files located in the /installers folder. That worked before when I first installed F1 like 2 weeks ago.
  • I've gone into the sound settings and disabled every other unused audio device on my PC; I have 3 left now - Speakers, Arctis 7 (game), Arctis 7 (chat). A7 (game) is default audio device, A7 (chat) is default communication device
  • Under recording I have disabled every other device on my system; only device is Arctis 7 (chat) which is set to default.
  • I've changed properties on each audio device to disable "exclusive control" by any app thinking maybe discord was hijacking the audio. No luck there.
  • I've made sure "voice recording" is enabled in windows, and I've also made sure to allow apps to use voice recognition
  • I've even turned on cloud based voice recognition thinking maybe this was needed somehow

I'm out of ideas on this one. Any help would be HUGE as not being able to get race updates easily on my G27 is a pain during a 57 lap Bahrain race...

Game Version: Latest I can pull from Steam. 1.81?

SYSTEM:

  • i7 3770k
  • EVGA 1080ti
  • 16gb DDR3 @ 1600hz
  • Gigabyte Sniper 3
  • 1tb 970 Evo SSD (game install directory)
  • OS: Windows 10 Pro (region: US)
  • Steel Series Arctic 7 headset
Edited by Mike Dee

Share this post


Link to post
Share on other sites
Posted (edited)

Anyone have any ideas to try? I've reinstalled everything I can think of except the OS (again). I know it is tied to Cortana/Windows speech recognition and I've tried to enable everything I can in the system settings to give access. I don't ever see F1 or any codemaster process on those system setting pages though so I can't be 100% sure F1 actually gets access. I've tried multiple language packs even (I'm US based, bought a bulk OEM W10 Pro key so not 100% sure if I have a US region key [if those even exist?]) because I read a few posts about if the language settings didn't match it would auto disable.

I'm stumped and I really hate not being able to talk to Jeff. I feel like I'm missing out on a good chunk of the game because I can't navigate the MFD more than just flipping through each page. I'll try any at this point and if you need any logs or data, tell me how to generate it and you'll have it ASAP.

My only lead is it has something to do with W10 Pro - I had this working before my OS install when I was on W10 Student Edition. Maybe I'm missing a normal install file Home edition has, or maybe I need to manually give that file/dll/exe/whatever the added permissions? Maybe it's a regedit? I feel like it's something very basic like that, a system setting that isn't enabled or configured right and I just can't find it

Thanks for anything you all can suggest

Edited by Mike Dee

Share this post


Link to post
Share on other sites

Mike, can you post a dxdiag. There is a lot of knowledge around here and this file is the first requested to see if it can be sorted. 

In Windows 8, Windows 10:

  1. Press the [Windows]+[R] keys on your keyboard to bring up the Run command.
  2. In the "Run" command box, type in dxdiag and press <Enter>. The DirectX Diagnostic Tool pop-up window should appear.
  3. Click on "Save all Information."
  4. Save the information to your Desktop, keep the file name as is.

Share this post


Link to post
Share on other sites
Posted (edited)

I think the community has established it is an intermittent issue. It should work, and sometimes it does, sometimes it doesn't. If you restart the game without doing anything, sometimes it starts working again.

Refreshing the Kinect runtimes usually works as a temporary fix until it reverts to the above behaviour.

Anecdotally, I am almost always using Discord if I ever use voice control. Discord is almost always a perpetual beta product, updating every five minutes to cram in features I never use. I'd be surprised if this doesn't break things TBH.

Edited by steviejay69
Discord

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×